Inhalt

Elektronik Verwaltung Hilfe

Inhaltsverzeichnis

Verwaltung von elektronischen Bauteilen. Speichermöglichkeit von Bildern, anlegen von Gehäuse, Bestellungs-Verwaltung, Stückzahlen und Preise. Unterstützt unterschiedliche Datenbank-Systeme, so kann es auch mit mehreren Rechnern gleichzeitig benutzt werden (Client/Server, MySQL).

Nr | Beschreibung
100 | Installation
1000 | Bauteil Verwalten
2000 | Bestellung
3000 | Suchen
4000 | Gehäuse Verwalten
5000 | Kiste
6000 | Adressen
7000 | Typ, Kathegorie der Bauteile
8000 | Debug
(c) 2010 by Markus Müller E-Mail: mm@MmVisual.de


Installation

Installation

1. Entscheidung Art der Installation

Diese Software benötigt für den Betrieb eine Datenbank. Welche Sie einsetzen hängt von der Nutzungsart ab. Haben Sie nur einen Rechner, so können Sie SQLite als Datenbank nutzen. Wollen Sie hingegen mehrere PC's benutzen oder haben einen Server so muss MySQL verwendet werden. MySQL bietet auch ein Passwortschutz. Dafür ist der Installationsaufwand etwas größer.

2.a Installation mit SQLite

Für SQLite verwenden Sie die INI-Datei "Elektronik.ini" und kopieren diese in das Programmverzeichnis. Anschließend muss die SQLite DLL von der Seite "www.SQLite.org" geladen werden. Das Archiv heißt derzeit "sqlitedll-3_7_0_1.zip", die Versionsnummer ändert jedoch fortlaufend. Entpacken Sie das Archiv in das gleiche Verzeichnis wie die EXE. Das war's auch schon.

2.b Installation mit MySQL

2.b.1 Laden von MySQL, wenn Sie es noch nicht installiert haben

Der Windows-Download kann von der Seite "www.apachefriends.org" geschehen. Installiert wird mit dem Setup "Apache" und "MySQL".

2.b.2 Einrichten neuen User

  • Internet-Explorer http://localhost/phpmyadmin/ eingeben
  • Rechte
  • Neuer Benutzer hinzufügen
  • Benutzername MyElektronik
    • Host "Lokal" auswählen ("Jeder") bei Benutzung mit mehreren PC's
    • Passwort 2x MyElektronik
    • alle Häkchen bei "Daten"
    • alle Häkchen bei "Struktur"
    • OK Taste

2.b.3 Einrichten neue Datenbank

  • Zurück auf die Hauptseite, Klich auf das Symbol "phpMyAdmin" links oben
  • Im Feld "Neue Datenbank" der Name "elektronik" eingeben
    • Kollation "utf8_unicode_ci" auswählen (letzter Eintrag)
    • Taste Anlegen

2.b.4 Struktur in Datenbank importieren

  • links die Datenbank "elektronik" auswählen
  • Importieren klicken und die SQL-Datei "Elektronik_Start.sql" auswählen
  • OK Taste

2.b.5 INI-Datei anpassen

  • Diese "Elektronik.ini" Datei kopieren.
  • Im Abschnitt [DB] evt anpassen "User=" und "Passwort=" und "HostName=" wenn Sie einen Server haben hier der Name oder IP-Adresse.

3. Fertig, EXE starten.

Sollten dennoch Probleme auftreten, so werden diese unter "Debug" / "Log" alle protokolliert.

4. Erste Einträge...

Bevor man Bauteile anlegt sollte erst einmal zumindest ein "Typ" eingerichtet werden um das Bauteil zuordnen zu können. Bei der MySQL Installation sind hier schon einige angelegt.

Dann unter "Adressen" Lieferanten anlegen, wie Reichelt und Conrad usw.

Dann unter "Kiste" Sortierkästen und Schubladen

Dann unter "Gehäuse" Bauteilgehäuse wie DIP8, SO8, TO92 usw.

Jetzt kann ein "Bauteil" mit allen Eigenschaften angelegt werden.

5. Datensicherung

5.a Bei SQLite einfach die Datei "Elektronik.sq3" sichern

5.b Bei MySQL folgende Schritte ausführen

  • Internet-Explorer http://localhost/phpmyadmin/ eingeben
  • links Datenbank "elektronik" auswählen
  • Exportieren
  • Häkchen setzen: Export in einer Transaktion zusammenfassen
  • Häkchen setzen: Fremdschlüsselüberprüfung deaktivieren
  • Häkchen setzen: Senden
  • OK Taste
  • SQL Datei irgendwo speichern
  • Bei Systemcrach kann diese Datei wie oben beschrieben wieder importiert werden und alles läuft wieder.

Die SQL Datenbankkomponente dieser Software unterstützt direkt verschiedene Datenbanksysteme, allerdings sind von mir nicht alle getestet. Hier die Liste:

  • asa7, asa8, asa9
  • firebird-1.0, firebird-1.5, firebird-2.0, firebird-2.1
  • firebirdd-1.5, firebirdd-2.0, firebirdd-2.1
  • interbase-5, interbase-6
  • mssql
  • mysql, mysql-4.1, mysql-5, mysqld-4.1, mysqld-5
  • oracle, oracle-9i
  • postgresql, postgresql-7, postgresql-8
  • sqlite, sqlite-2.8, sqlite-3
  • sybase


Bauteile Verwalten

Bauteile verwalten

In der Bauteilverwaltung werden alle Bauteile angelegt, Lager und Gehäusevarianten verwaltet und Lieferanten eingetragen.

In der Bauteil-Übersicht wird von einer Bauteilvariante nur der Haupt-Typ eingetragen, z.B. 7400. Die Untertypen wie z.B. 74HC00, 74LVX00 unter "Lager / Gehäuse". Oder unter Bauteil wird nur der Widerstandswert "R 4,7 KOhm" eingetragen, alle Leistungsklassen und Gehäuseformen kommen nach "Lager / Gehäuse".
Der Vorteil liegt auf der Hand, die Bauteileliste enthält dadurch viel weniger Einträge und ist somit übersichtlicher. Gleichzeitig sieht man unter "Lager / Gehäuse" alle Typen mit der gleichen Funktion.

Um ein Bauteil schnell auswählen zu können kann die Bezeichnung im Schnellsuchen-Feld neben dem Datum eingegeben werden. Dabei springt der Datensatz in den Tabelleneintrag.

Mit der "Warenkorb-Taste" kann der Artikel in die Bestell-Vorschlagliste übernommen werden. Dabei wird gleich der Reiter "Bestellung" geöffnet und in das "Menge" Eingabefeld gesprungen.

Wenn ein Neues Bauteil angelegt wird, so muss eine Typ-Zuordnung mit der Taste "..." ausgewählt und eine "Bezeichnung" eingegeben werden.

Der Link zum "Handbuch" kann eine Datei sein oder man kann auch eine Internet-Adresse angeben, dabei muss ein "http://" voranstehen.

Im Textfeld unterhalb von "Library" kann eine Beschreibung des Bauteils eingegeben werden.

Ein Bild kann mit Hilfe der Taste "Bild" eingefügt, kopiert oder gelöscht werden. Es ist insbesondere darauf zu achten, dass es mit einem Zeichenprogramm verkleinert, bzw. optimiert wird. Es wird in der Datenbank in PNG Format abgelegt und sollte auf der Festplatte nicht mehr als 32KB haben. Nur so ist sichergestellt, dass es nicht zu großen Verzögerungen beim Laden von Bildern aus der Datenbak kommt.
Wenn das Bild in der Vorschau nicht ganz dargestellt werden kann, da das Mini-Fenster zu klein ist, so kann mit Doppelklick ein Vorschau-Fenster geöffnert werden.

Wenn der Datensatz kopiert wird, so wird das Bild nicht mit kopiert.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils gelöscht. Bei der Bestell-Liste wird die Bauteil-Zuordnung gelöscht, der Eintrag bleibt jedoch erhalten..

Lager / Gehäuse

Hier werden die Bauteilvarianten, Lagermengen und Gehäuseformen gespeichert.

Die Eingabefelder müssen nicht ausgefüllt werden, nur das was man möchte.

Neben dem Mengen-Feld gibt es die Korrektur-Berechnung. Wenn z.B. 43 Stüch aus dem Lager entnommen wurden und der Lagerbestand ist 821, dann ist es doch umständlich dies von Hand zu rechnen. Hier kann rechts neben dem Menge-Eingabefeld die Korrektur-Menge eingegeben werden und mit der - / + Taste der Bestand geändert werden. Die Menge wird bei der Minus-Taste auf 0 begrenzt.

Wenn als "Kiste" z.B. der "Sortierkasten" eingegeben wurde, so kann im Feld "Lager-Nr" die Box, z.B. "A4" eingegeben werden.

Im Eingabefeld unterhalb von Library kann ein Beschreibungstext eingegeben werden.

Wenn um den Artikel in die Bestell-Vorschlagliste in diesem Reiter die "Warenkorb-Taste" gedrückt wird, dann wird automatisch auch die Information "Lager/Gehäuse" im Bestellvorschlag gespeichert. Damit wäre bei Status "geliefert" ein "buchen in Lager" mit automatischer Mengen-Korrektur möglich.

Adresse

Hier wird dem Lager/Gehäuse ein Lieferant zugeordnet und der Einkaufspreis eingetragen.

Im Eingabefeld unterhalb von "Gehäuse/Lager" kann ein Beschreibungstext eingegeben werden.

Wenn um den Artikel in die Bestell-Vorschlagliste in diesem Reiter die "Warenkorb-Taste" gedrückt wird, dann wird automatisch auch die Information "Lager/Gehäuse" und "Adresse/Lager/Gehäuse" im Bestellvorschlag gespeichert. Damit wäre bei Status "geliefert" ein "buchen in Lager" mit automatischer Mengen-Korrektur und eine Übernahme des Einkaufspreises möglich.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Eintrag kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Warenkorb-Taste, Eintrag in Bestellen
 | Auswahl eines Typs / einer Datei
 | Filtern von Positionen anhand aktuellem Typ
 | Öffnen der Datei / Internet Browser


Bestellung

Bestellung

Hier wird vorgemerkt welche Artikel zu bestellen sind, welche bestellt wurden und welche geliefert und bereits eingelagert sind.

Die Bestell-Vorschlagliste kann entweder von "Hand" gefüllt werden, indem die "Neu" Taste gedrückt wird oder aus "Bauteile" heraus mit der "Warenkorb-Taste". Wichtig ist, dass auch Bauteile aufgerschrieben werden können die gar nicht als "Bauteil" angelegt sind.

Im Eingabefeld "Bauteil" kann das angelegte Bauteil ausgewählt werden. Erst wenn dies ausgewählt wurde, kann das dazugehörige "Lager/Gehäuse" und "Adresse/Lager/Gehäuse" ausgewählt werden, sofern die dem Bauteil hinterlegt worden sind.

Wenn "Adresse/Lager/Gehäuse" ausgewählt wird, so wird bei "Lieferant 1" automatisch der Eintrag aus dem Bauteil übernommen. Sollte "Lieferant 1" bereits belegt sein, so wird dies in "Lieferant 2" eingetragen, sofern dieser nicht auch belegt ist.

Mit "Lieferant 1 / 2" hat man die Möglichkeit zwei Lieferanten vor zu sehen, denn man weiß ja nie bei wem man zu erst bestellen möchte. Hier könnte man auch die Preise vergleichen.

Status der Bestellung

Taste | Beschreibung
 | "offen", noch nicht bestellt
 | "bestellt", Bestellung an Lieferant übergeben
 | "geliefert", bestellte Ware angekommen
 | "eingelagert", Waren in "Kiste" einsortiert

Neben den Status-Tasten ist die "Y" Taste. Anhand dieser kann die Tabelle gefilter werden. Wenn diese gedrückt wird, so sind nur noch die Positionen sichtbar, die den gleichen Status haben wie die ausgewählte Position.

Exportieren einer Bestellung:
Für den Lieferant "Reichelt" kann die Bestellung exportiert werden und wenn man als Reichelt "MyKunde" registiert ist, kann dieser importiert werden. So auch umgekehrt.
Beim Import eines exportierten Reichelt-Warenkorbes kann global der Status aller erkannten Positionen geändert werden. Anhand dieser Funktion kann z.B. nach Bestellung bei Reichelt alles mit einem Rück-Import auf Status "bestellt" gesetzt und nach der Anlieferung auf Status "geliefert" gesetzt werden. Beim setzen auf Status "eingelagert" wird nur der Status geändert, jedoch keine Lagerbuchung vollzogen.

Gelieferte Ware ins Lager buchen:
Mit der Taste "In Lager Buchen" kann eine Positione, die als "geliefert" markiert wurde in das Lager gebucht werden. Die Taste wird nur dann aktiv, wenn auch ein "Lager/Gehäuse" ausgewählt wurde und die Menge > 0 ist.
Die Aktion: Das Bauteil wird unter "Lager/Gehäuse" von der Menge hochgezählt, die Bestellposition erhält den Status "eingelagert". Wenn das Feld "Adresse/Lager/Gehäuse" ebenfalls ausgewählt ist und einer der Lieferanten 1/2 die gültige Adresse hinterlegt hat und der EPreis eingetragen ist, dann wird auch der EPreis in die Bauteildaten übernommen.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Eintrag kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Export / Import-Funktion
 | Filtern von Positionen anhand aktuellem Status

Felder in der Tabelle die grau/farblich hinterlegt sind können nur in der Eingabemaske geändert werden.


Gehäuse verwalten

Gehäuse verwalten

Hier werden alle Gehäuse Typen der Bauteile angelegt. Zu jedem Gehäuse kann auch ein Bild hinterlegt werden.

Im Eingabefeld unterhalb von "Pins" kann ein Beschreibungstext eingegeben werden.

Ein Bild kann mit Hilfe der Taste "Bild" eingefügt, kopiert oder gelöscht werden. Es ist insbesondere darauf zu achten, dass es mit einem Zeichenprogramm verkleinert, bzw. optimiert wird. Es wird in der Datenbank in PNG Format abgelegt und sollte auf der Festplatte nicht mehr als 32KB haben. Nur so ist sichergestellt, dass es nicht zu großen Verzögerungen beim Laden von Bildern aus der Datenbak kommt.
Wenn das Bild in der Vorschau nicht ganz dargestellt werden kann, da das Mini-Fenster zu klein ist, so kann mit Doppelklick ein Vorschau-Fenster geöffnert werden.

Wenn der Datensatz kopiert wird, so wird das Bild nicht mit kopiert.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils entfernt, jedoch nicht der Datensatz gelöscht. So auch bei der Bestell-Liste.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Neuer Kind-Eintrag im ausgewählten Eintrag
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle


Kiste

Kiste

Hier werden die Lagerorte "Kisten" verwaltet.

Hier werden nur die Kisten, Schubladen, Regale usw. eingetragen. Nicht jedoch z.B. "Sortierkasten 1, Box A/4", die "Box A/4" wird unter "Bauteile" eingetragen, denn sonst müsste man für jeden Sortierkasten 60 Einträge, für jede Schublade machen.

Die Felder "Nummer", "Pos X" und "Pos Y" sind Eingabefelder für Zahlen.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils in die Box entfernt, jedoch nicht der Datensatz gelöscht. So auch bei der Bestell-Liste.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Neuer Kind-Eintrag im ausgewählten Eintrag
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle


Adressen

Adressen

Hier werden die Lieferanten verwaltet.

Die Felder sollten selbsterklärend sein.

Unter "Internet" kann die Internetseite eingegeben werden, die mit der Taste ">>" mitels eines Internetbrowsers gezeigt werden kann.

Die Adresse mit der Bezeichnung "Reichelt" hat eine Sonderstellen, mit ihr können Reichelt Warenkörbe undter "Bestellung" exportiert und importiert werden.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils entfernt, jedoch nicht der Datensatz gelöscht. So auch bei der Bestell-Liste.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Eintrag kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Internetseite öffnen


Typ

Typ, Kathegorie der Bauteile

Hier werden die Kathegorieen angelegt die ein Bauteil annehmen kann.

Wichtig ist hierbei dass es nicht zu viele Untertypen gibt, denn man kann anhand dieser Typeinordnung ein Bauteil filtern. Daher sollte dies rellativ "allgemein" gehalten werden.

Jeder Eintrag kann in der unteren Eingabezeile einen frei definierbaren zusatztext haben.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Neuer Kind-Eintrag im ausgewählten Eintrag
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle

Mit Klick auf den Eintrag kann er editiert werden.


Debug

Debug

Hier werden alle Programmfehler geloggt und können direkt Datenbankmanipulationen ausgeführt werden.

Unter dem Reiter "Log" können einzelne Zeilen oder das ganze Protokoll mit der rechten Maustaste kopiert werden. Das Programm kann automatisch den Log in eine Datei schreiben, wenn der Parameter der INI-Datei [Programm] LogInFile=1 gesetzt wird.

Unter dem Reiter "Datenbank" kann direkt ein SQL-Befehl eingegeben werden. Die Datenbank öffnet bei SELECT eine Tabelle, bei anderen Befehlen wird der SQL-Befehl ausgefürt, z.B. UPDATE zeigt keine Tabelle.
Die Daten in der Tabelle können sogar manipuliert werden. Wenn Felder mit einem "ID" im Feldname geändert werden kann die Konsistenz der Daten nicht gewährleistet werden.
Diese Funktion sollte nur im Notfall angewendet werden und man sollte genau wissen was man tut.


Suchen

Suchen

Mit suchen können Bauteile gefunden werden.

Im Suchen Eingabefeld kann "*" als Wildcard-Zeichen verwendet werden. Die Groß/Kleinschreibung spielt ebenfalls keine Rolle.

Doppelklick auf die Tabelle springt zum "Bauteil".