www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EA DOGM128-6, st7565r


Autor: sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mit dem oben genannten Display ein Problem mit dem Kontrast. 
Dieser ändert sich mit dem Display-Inhalt. Die Initialisierung scheint 
zu funktionieren und der Spannungsbooster wird auch eingeschaltet, 
betrieben wird das Display mit 3,3V.

Sobald ich jetzt Linien auch dem Display zeichne (Daten: 0x01, 0x02,...) 
ändert sich der Kontrast.

Bei den benötigten Kondensator handelt es sich um 1µF Kerkos.

Hat da jemand eine Idee?


sebastian

Autor: Tobias B. (roxxity)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Hab das selbe Problem. Wenn man am Booster-Ausgang misst, schwankt die 
Spannung zwischen 11V (Alle Pixel schwarz) und 9V (Muster mit Pixel 
an/aus abwechselnd).

Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.