www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik CAN Bus Probleme mit Empfang!!!


Autor: Leo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich brauche dringend Unterstützung.
Ich den SJA1000 an einem AVR angeschlossen(8Bit Controller).
Wenn ich mit der Schreibe-Funktion eine Botschaft zum PEAK CAN Dongle
sende, dann
wird die Botschaft nicht korrekt dargestellt.Siehe Bild! Auf dem CAN
Bus tut sich ja was, und
zwar wird der Count hochgezählt wenn eine Botschaft empfangen wird. Der
identifier sowie die Daten werden
nicht drgestellt. HMMM.....
Laut Oszi arbeitet der SJA1000 korrekt.
An was kann dies liegen????


Ich weiss einfach nicht mehr weiter!

MfG Henning

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.