www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik qurz anschließen at90s2313


Autor: Roman Konrad (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo an alle,
ich hab da ein kleines problem!

ich habe eine platine gebaut mit 15 leds und jeweils 270ohm
widerständen davor. alles läuft mit 5v DC. alle leitungen müssten
richtig sein und das programm ist auch korrekt, da ich es auf einer
anderen Platine getestet habe! Mein Problem:

Wenn ich die Stromverbindung herstelle passiert gar nichts, obwohl das
programm vorschreibt, dass alle leds leuchten sollen. Wenn ich nun aber
mit einem voltmeter xtal1 und ground verbinde gehen entweder alle
leuchtdioden an oder nur mal hier und da ein paar! das ist alles sehr
sehr seltsam!! ich als ich einen 10k widerstand von xtal1 zu ground
gelegt habe blieben alle leds an. ich hatte einen ähnlichen effekt als
ich xtal1 und xtal2 so verband. außerdem habe ich ein 10k wiederstand
von reset zu 5V+ (VCC) gelegt. nun funktionierte alles.

als ich nun aber ein programm schrieb, dass die leds zum leuchten
bringen sollte ging dies nicht. die leds blieben nach wie vor permanent
an. ich weiß mir nicht mehr zu helfen.

kann es sein, dass der qurz nicht richtig rum ist oder so? wie ist das
mit den kondensatoren (22pF)? es gibt ja immer ne seite mit schrift und
eine ohne, wierum müssen die denn?

bitte helft mir!!!
ein zeichnung oder so wäre super!

e-Mail: Moeffmaster@aol.com


VIELEN DANK!

Roman Konrad

Autor: leo9 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
code, schaltung usw. posten, dann kann man sich vielleicht einen Reim
auf deine Frage machen. Mit einem Voltmeter am Xtal wirst du nichts
sehen da brauchts schon ein Oszilloskop.

grüsse leo9

P.S. ein "gleicher" Beitrag würde auch reichen.

Autor: Roman Konrad (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ich weiß, sorry wegen der verdoppelung! naja ich hab da jetzt schon
was rausgefunden! es wird wahrscheinlich an den Kondensatoren liegen!
ich war im chat und hab da mal nachgefragt! danke das so schnell
geantwortet hast! mal sehen ob das funzt, ansonsten melde ich mich
nochmal! danke!

MfG Roman

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.