www.mikrocontroller.net

Forum: Platinen Eagle 5 / Eagle 4.x: Schaltplan abwärtskompatibel?


Autor: Antal 377 (antal)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen Schaltplan mit der aktuellen Eagle Light-Version (5.0) 
erstellt. Leider passt das Projekt nicht auf die begrenzte 
Platinenfläche - sind die Schaltplandateien (*.sch) abwärtskompatibel, 
sprich könnte ich diese theoretisch mit einer älteren (Voll-)Version 
(4.xx) öffnen und weiterbearbeiten? Die nächsten Tage fehlt mir leider 
der Zugang zu den Rechnern mit den älteren Versionen, daher kann ich es 
derzeit nicht ausprobieren.

Habe hier im Forum einige Beiträge gefunden, dass dies mit den 
Board-Dateien (*.brd) nicht funktioniert, aber leider nichts zu den 
Schematics.


Danke im voraus!

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich das mitbekommen habe klappt das leider nicht. Auch im Forum 
von Cadsoft wurde diese Frage schon öfter gestellt und verneint. Da gibt 
es leider auch keine Abhilfe...

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle Versionen sind aufwärts aber nicht abwärtskompatibel.
Die neue Version hat Funktionen, die die Vorgängerversion nicht hat.
Die ältere Version kennt die neuen Funktionen nicht.

Autor: Antal 377 (antal)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmpf, Mist, das heißt dann wohl, alles nochmal neu...selber schuld.

Autor: goggel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die ältere Version kennt die neuen Funktionen nicht.

Genau aus diesem Grund gehört da eine Funktion "Speichern in Eagle 4 
Format". Sicher nicht trivial eine solche Funktion, aber gehört halt 
dazu.

Autor: Noch-Mit-Pizza-Ofen-Löter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... wie auch das Kontext Menü und so einige andere Sachen eigentlich 
schon seit Jahren dazugehört haben hätten sollten wollen müssen und 
überhaupt.

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Natuerlich sind sie nicht abwaertskompatibel das sollte einleuchten, das 
brauch ich garnich ausprobieren. Wenn das nen gescheites Format waere 
(XML z.B.) waere es u.U. abwaertskompatibel bei diesen wenigen 
Aenderungen.

Autor: Moppel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist nicht klar, wie das funktionieren soll und wie XML dabei hilft. 
Die Version 5 hat Features, die Version 4 nicht kennt. Und wenn man die 
dann einfach weglässt, hat man eine andere Zeichnung. Dabei ist es doch 
ziemlich egal, wie groß oder klein die Abweichungen sind. Es handelt 
sich schließlich um eine technische Zeichnung, und die muss exakt so 
aussehen, wie sie erstellt wurde.

Bei einer Textverarbeitung sehe ich natürlich ein, dass das kein Problem 
ist. Aber doch nicht in einer technischen Zeichnung?!?

Aber da Ihr hier eine andere Meinung habt, übersehe ich wohl noch etwas. 
Helft mir bitte auf die Sprünge.

Übrigens: Ihr könnt doch das Ganze als Script exportieren. In diesem 
Script könnt Ihr alles löschen, was nicht benötigt wird und dieses dann 
in der Version 4 ausführen.

Autor: User (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Kann man ein mit Version 5.4 erstelltes Eagle File mit Version 5.3 
öffnen?

Autor: Walter Tarpan (nicolas)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.