www.mikrocontroller.net

Forum: Platinen TQFP in Eagle


Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich muss auf eine Platine sowohl DIP-IC's als auch TQFP-IC's 
draufbringen. Beim Leitungen zeiehen rastet die Maus aber immer irgendwo 
zwischen oder nur halb auf den Beinchen. Wo kann ich eine bessere 
Rastung einstellen? wenn ich ein anderes kleineres Gitter nehme, kann 
ich den IC nicht so ausrichten, dass Lötstelle geneu auf Rasterpunkt 
kommt...

Autor: Hannes J. (Firma: eHaJo.de) (joggl) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du vom Schaltplan redest:
Versuchs mal mit dem "Net" anstelle von "Wire"-Befehl.
Dann sollte Eagle eigentlich merken, dass du eine Verbindung machen 
willst mit dem Beinchen. Ansonsten kannst du ja den Alternate-Raster 
ganz klein machen. Dann erhältst du beim Drücken der ALT-Taste den ganz 
feinen Raster und solltest treffen.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gast wrote:
> Hallo,
>
> ich muss auf eine Platine sowohl DIP-IC's als auch TQFP-IC's
> draufbringen. Beim Leitungen zeiehen rastet die Maus aber immer irgendwo
> zwischen oder nur halb auf den Beinchen. Wo kann ich eine bessere
> Rastung einstellen? wenn ich ein anderes kleineres Gitter nehme, kann
> ich den IC nicht so ausrichten, dass Lötstelle geneu auf Rasterpunkt
> kommt...

Du musst beim Routen bei den Pins anfangen, die NICHT auf dem Raster 
liegen. Dann geht's problemlos.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und dazu am besten das raster ein bisschen feiner als 1,27mm standard 
einstellen.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Michael H* (-holli-)

>und dazu am besten das raster ein bisschen feiner als 1,27mm standard
>einstellen.

Nicht ein "bisschen", sondern überlegt. Man sollte immer ganzzahlige 
Teile des Platzierungsraster verwenden. Ich z.B. arbeite viel mit 10mil, 
das ist 1/5 vom 50 mil Standardraster. Damit kann man schon sehr viel, 
sehr eng layouten und es wird dennoch gleichmässig.

http://www.mikrocontroller.net/articles/Eagle_im_H...

MFG
Falk

Autor: Gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Im Anhang das Bild vom Layout-Editor. Kann man das Raster (sichtbar oder 
nicht - ist mir egal) nicht automatisch durch die Mitte der Pins legen. 
Am Pin ganz rechts klappts z.B. nicht, während es links in der Mitte 
noch rtelativ gut aussieht.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast (Gast)

>Im Anhang das Bild vom Layout-Editor. Kann man das Raster (sichtbar oder
>nicht - ist mir egal) nicht automatisch durch die Mitte der Pins legen.

Nur, wenn alles Bauteile das gleiche Raster haben. Ist heute aber immer 
seltner.

>Am Pin ganz rechts klappts z.B. nicht, während es links in der Mitte
>noch rtelativ gut aussieht.

Lies den Link nochmal. Er ist gewachsen ;-)

MFG
Falk

Autor: Gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ganz so zufrieden bin ich noch nicht. Der Pinabstand beträgt 0.8mm, als 
Raster habe ich 0.2mm eingestellt. Das Ergebnis wieder im Anhang...

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist du sicher mit den 0,2mm Raster? Irgendwas scheint da nicht zu 
stimmen.
Zumindest sind deine 0,8mm kein Vielfaches von 0,2mm (Pins und Raster 
laufen leicht auseinander.)

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, genau so steht es im Datenblatt des Controllers drin.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
stell mal ein .brd rein, dann schau ich mir genauer an. Denn eins von 
den beiden Maßen kann nicht stimmen.

Autor: Gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ist es

Autor: Haku (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also abgesehen davon, dass das Raster da wirklich schief ist (d.h., der 
TQFP, da is was krumm damit), kann ichs eigentlich prima routen, wenn 
ich meine Leiterbahnen auf den Pins des TQFP beginne.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist auch sehr auffallend, dass Eagle beim routen des Controllers 
automatisch in den Top-Layer wechselt. Bei den anderen Teilen war das 
nicht so.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, dein eingestelltes Raster von 0,2mm ist korrekt, aber dein TQFP ist 
etwas zu kurz. Den der hat einen Pinabstand von ca. 0,74mm.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was kann ich da jetzt machen? den IC nach Angaben aus dem Datenblatt 
selber machen?

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wäre eine sinnvolle Maßnahme.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat jemand von euch schonmal sowas gemacht? ich bin doch wohl nicht der 
einzige, der einen at90can128 mit eagle routen will...

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es wechselt in den top-layer, weil dein bauteil auf der oberseite sitzt

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Haku (Gast)

>Also abgesehen davon, dass das Raster da wirklich schief ist (d.h., der
>TQFP, da is was krumm damit), kann ichs eigentlich prima routen, wenn
>ich meine Leiterbahnen auf den Pins des TQFP beginne.

Das könnte der OP auch, wenn er nicht zu faul wäre mal ein paar Hinweise 
zu beachten.

MfG
Falk

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast

Dein Board kann ich nicht öffnen, ist wohl mit Eagles 5.0 gemacht?

Autor: Gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ist nochmal das Board...

Autor: Gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...und hier der Schaltplan.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab nur 4.14, der Schaltplan braucht aber 4.6 oder höher. ISt auch 
egal. Die Problemlösung wurde mehrfach klar beschrieben. Und ein Gehäuse 
mit 0.74mm Pitch ist Müll, hat wohl einer "per Hand" auf Inch 
umgerechnet und grosszügig gerundet. :-(

MFG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.