www.mikrocontroller.net

Forum: HF, Funk und Felder Koexistenz von ZigBee und GPS auf einer Platine


Autor: Holger M. (nezaya)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat hier irgendwer schon Erfahrungen mit dem gemeinsamen Einsatz von 
ZigBee und GPS auf einer Platine gemacht?

Konkret geht es darum, dass ich hier ein Meshnetics ZDM-A1281-A2 (neu: 
MNZB-24-A2) Modul zusammen mit einem FSA01 GPS Modul der Firma Falcom 
auf einem Board betreibe. Das ZigBee-Modul scheint jedoch den 
GPS-Empfang derart zu stören, dass zwar Satelliten empfangen werden, 
jedoch kein Fix erfolgt. Das GPS-Modul einzeln funktioniert, scheint mir 
aber allgemein sehr störanfällig gegenüber anderen Sendern zu sein.

Ich hatte prinzipiell keine großen Probleme erwartet, da die Frequenzen 
eingentlich weit genug auseinander liegen und die Kombination von GPS 
und Bluetooth ja bekanntlich auch funktioniert.

Die Antennen von ZigBee und GPS sind auf einer 65 mm x 40 mm großen 
Platine auf der jeweils gegenüberliegenden Seite so weit wie möglich 
voneinander entfernt angeordnet.
Sowohl die Bereiche um das GPS als auch um das ZigBee-Modul sind wie im 
jeweiligen Datenblatt angegeben gelayoutet. Allerdings gibt es eine 
gemeinsame Masseverbindung/Massefläche die beide Module verbindet.

Hat jemand bereits ähnlich schlechte Erfahrungen gemacht, oder 
funktioniert der gemeinsame Einsatz von ZigBee und GPS bei 
irgendjemandem?

Gruß nezaya

Autor: FUNKY (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ZigBit module should not be placed next to consumer electronics which 
might interfere with ZigBit’s RF frequency band.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe mir gerade mal die GPS-Frequenzen angesehen.  Ich gehe mal davon
aus, dass du einen zivilen Empfänger auf 1575.42 MHz betreibst und
keinen militärischen auf 1227.60 MHz. ;-)  Letzteres könnte mit der
halben Endfrequenz schon irgendwie kollidieren...

Ansonsten gibt's da vor allem den 16-MHz-Takt mit seinen Oberwellen,
die durchaus bis in diese Bereiche hinein reichen.  Allerdings ist
die 99. Harmonische mit 1584 MHz doch recht weit weg, als dass ich
mir davon Störungen vorstellen kann.

Sind deine Störungen eigentlich kanalabhängig, oder treten sie immer
auf, sobald der AT86RF230 aus dem SLEEP heraus ist?

Autor: FUNKY (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei solchen Mini-Modulen legt der Hersteller doch keinen Wert auf die 
Elektronik, die da noch so in der Nähe liegt. Ich denke das sind 
leitungsgebundene Störungen durch das Funkmodul.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
FUNKY wrote:
> Bei solchen Mini-Modulen legt der Hersteller doch keinen Wert auf die
> Elektronik, die da noch so in der Nähe liegt. Ich denke das sind
> leitungsgebundene Störungen durch das Funkmodul.

Und wo kommen diese genau her?  Weißt du denn, welche Taktquellen
da drin werkeln, und wie oder warum diese in die GPS-Frequenz
einstreuen?

Kennst du diese Module überhaupt?

Autor: FUNKY (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Kennst du diese Module überhaupt?

Nein, die kenne ich nicht, aber ich kenne solche Probleme.

Ich würde jede Leitung einzeln mit dem GPS-Modul verbinden um zu sehen 
von welcher die Störung eingestreut wird. Evtl. auch auf allen evtl. nur 
durch die Versorgung. GPS und das Modul arbeiten übrigens analog und 
nicht digital.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein paar Ideen:

1.Verhätnismäßigkeit der Signale ?
Im einfachsten Fall stopft Dein Sender den GPS-Empfänger zu, da er 
wesentlich näher ist als der Sat.

2.Auch wenn der Schaltpln richtig ist, kann die Anordnung entscheidend 
sein.

3.Gemeinsame Spannungsversorgung ? Bei höheren Frequenzen helfen die 
10nF-Abblock-Kerkos nicht mehr.

Autor: hellboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mich würde es viel mehr interessieren den militärischen teil von gps 
nutzen zu können ;) ich hab so ein ding sogar schonmal in betrieb 
gesehen und auch mitbekommen wie der schlüssel gehüted wird ... ich 
fürchte das system ist zu gut geschützt

Autor: Holger M. (nezaya)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke schon mal für die Antworten!

@Jörg Wunsch:
Also der Controller auf dem ZigBee-Modul arbeitet mit 4 MHz, daher hatte 
ich diese Störungen schon mal ausgeschlossen. Das GPS ist ein ziviles, 
also 1575.42 MHz. Prinzipiell hatte ich keine Schwierigkeiten erwartet, 
da ich vermutete, das die 2,4 GHz des ZigBee weit genug von der Frequenz 
des GPS weg liegt. Bluetooth GPS-Mäuse machen ja vor, dass es geht.

Eine Abhängigkeit von den einzelnen Kanälen habe ich noch nicht 
untersucht. Prinzipiell habe ich die Störungen sobald das ZigBee an ist. 
Da die Störungen auch auftreten, wenn ich die Module auf zwei getrennten 
Platinen (mit getrennter Spannungsversorgung) betreibe, gehe ich davon 
aus, das es sich um Funkstörungen handelt.

Ich hatte gehofft, das die Masseflächen auf der Platine da schirmend 
wirken und ich keine Probleme habe. Wenn ich mir aber beispielshaft das 
Spektrum eines TI CC2420 ZigBee Radios ansehe, dann ist da inclusive 
Side-Lobes im GPS-Band absolut nichts mehr. Ich nehme mal an, dass das 
beim Atmel Radio in den Meshnetic Modulen nicht viel anders sein wird. 
Interessant wäre jetzt eine Aussage über das Empfangsspektrums des 
GPS-Moduls.

Ich werde mal dran bleiben. Vielleicht findet sich ja noch was.

@oszi40:
> 1.Verhätnismäßigkeit der Signale ?
Ja, da hast du rech, je näher ich die Antennen der Module aneinander 
bringe, desto schlechter wirds. Außerhalb der Platine ist ab ca. sieben 
Zentimetern Abstand fast keine Störung mehr warzunehmen. Allerdings sind 
die Antennen wie oben beschrieben auf der Platine knapp sechs Zentimeter 
außeinander. Und das ganze soll später noch kleiner werden.

> 2.Auch wenn der Schaltpln richtig ist, kann die Anordnung entscheidend
> sein.
Stimmt, wenn ich das Modul um 90° gedreht zum GPS ausrichte wird der 
Einfluss etwas geringer.

> 3.Gemeinsame Spannungsversorgung ? Bei höheren Frequenzen helfen die
> 10nF-Abblock-Kerkos nicht mehr.
Ich werde mal schauen ob ich das irgendwie noch besser blocken kann. Mit 
dem Ozsi das ich gerade habe kann ich leider nur bis 60 MHz testen. Da 
war zumindest nichts verdächtiges festzustellen.
Ich denke sollte als nächstes mal die Sende bzw. Empfangsspektren 
untersuchen.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klingt ja wirklich nach zugestopftem Empfänger.  Vielleicht lässt sich
mit einem Tiefpass (oder gar Bandpass -- gibt's da vielleich noch
SAWs dafür?) vor dem GPS-Empfänger was machen?  Ich weiß, GPS empfängt
12 oder 16 dB unter dem Rauschen, da muss man ziemlich vorsichtig
sein.

Autor: Holger M. (nezaya)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Klingt ja wirklich nach zugestopftem Empfänger
Die Vermutung drängt sich auf.

Wie im Blockschaltbild (Anhang) aus dem Datenblatt zu sehen ist die 
Antenne das einzige Filterelement vor dem LNA. Laut Hersteller soll die 
zwar ausreichend gut Filtern, aber dem ist wohl nicht so. Dann geht 
warscheinlich der LNA in die Aussteuergrenze.

Der Einbau eines Filters ist bei dem FSA01 Modul jedoch schwierig, da 
die Antenne gleich onboard ist. Genau deshalb hatte ich das ja mal 
ausgewählt.

Jetzt werde ich wohl doch zu einem Modul ohne Antenne wechseln müssen 
und den HF-Teil selbst machen.

Ich hatte mal noch versucht die Elektronik des GPS-Moduls durch ein 
Metallgehäuse zu schirmen um eventuelle Einwirkungen an späterer Stelle 
im Verarbeitungsprozess auszuschließen, dann ging jedoch garnichts mehr.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die Firmware auf dem Zigbit selbst im Griff, oder läuft da der
generische Stack von Meshnetics?  Ist halt die Frage, wenn du den
IEEE-802.15.4-Transceiver selbst steuerst, kannst du ja mal gucken, ab
wo die Störungen anfangen:

. TRX ist im TRX_OFF (nur 16-MHz-Quarzsozillator läuft => hat
  Oberwellen, je nach Konfiguration hast du eine Taktausgabe an
  MCLK)
. PLL is aktiv (TRX im PLL_ON oder RX_ON), VCO könnte rausstrahlen
. TRX ist im Sendebetrieb

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Notlösung:
Wenn der GPS-Empfänger zugestopft wird, dann schalte doch für diese 
Empfangszeit einfach den Störer kurz ab.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 wrote:

> Wenn der GPS-Empfänger zugestopft wird, dann schalte doch für diese
> Empfangszeit einfach den Störer kurz ab.

Ich denke mal, das Zeitregime des GPS-Moduls lässt sich von außen auch
nicht beeinflussen, das Teil ist ja auch autonom.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn das GPS-Modul nicht im D-Zug fährt, sollten einige Sekunden reichen 
den rechten Ort zu bestimmen, ehe der Störer wieder zugeschaltet wird ?

Frage ist eher wie man für diese Zeit das kleine ZigBee-Modul zum 
Schweigen bringt, ohne das es seine bisherigen Daten vergisst.

Autor: Holger M. (nezaya)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das GPS oder ZigBee kann ich leider nicht wechselseitig betreiben. Das 
ZigBee muss bei der Anwendung immer Kontakt zum Netz halten. Das GPS 
muss auch im Sekundentakt Positionsdaten liefern.

Ich nutze den Meshnetics eZeeNet Stack, also keine direkte Ansteuerung 
der Hardware.

Was ich im Moment überlege ist das GPS erst eine gültige Position 
bestimmen zu lassen, und dann die Funkhardware in Betrieb zu nehmen. 
Nach dem ersten Fix ist das GPS-Modul nämlich nicht mehr so anfällig für 
die Störungen. Einmal zur Navigation benutze Satelliten bleiben nach dem 
Einschalten des ZigBee-Moduls erhalten, wenn auch bei abgeschwächten 
Signalpegel. Das ist aber auf Dauer auch keine Lösung. Vorallem weiß ich 
noch nicht, was passiert, wenn die verwendeten Satelliten nicht mehr 
sichtbar sind. Dann können warscheinlich auch keine neuen gefunden 
werden und ich bin in der selben Situation wie zuvor.

Da ist wohl eine neue Hardware fällig.

Autor: GPS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist das FSA01 geschirmt oder offen wie auf den Bildern im Netz ?

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einschaltverzögerung des Störers wäre schon ein guter Ansatz.

Nebenbei: Zum GPS-Empfang wäre noch zu bemerken, daß jeder GPS-Sat nach 
meiner Kenntnis 23 Stunden pro Runde braucht. Folglich rotiert das ganze 
System langsam und der Empfang des Sat am Horizont ist natürlich 
schlechter als genau oben drüber. Daher wird es gute und schlechtere 
Empfangsmomente am gleichen Ort geben, die man vorsorglich mit einplanen 
sollte!

Autor: Holger M. (nezaya)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das FSA01 ist so wie im Netz dargestellt offen. Leider hat eine 
Schirmung des Moduls mit Metallfolie keine Besserung, sondern eher eine 
Verschlechterung gebracht. Wobei ich das nochmal näher untersuchen muss.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.