www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik JTAG ICE mkII - keine JTAG-Verbindung mehr ab 4.4V


Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich möchte einen ATmega128 mit Hilfe meines JTAG ICE mkII debuggen. Es 
war keine Verbindung zu stande zu bringen. Während des Bastelns hatte 
ich mal die Spannung ein wenig zurück gedreht, und siehe da: plötzlich 
funktioniert's ?-|

Praktisch sieht's so aus, dass bis 4.3V VTarget in der zu 
programmierenden Schaltung (angezeigt in HWSettings) alles wunderbar 
läuft (Signatur lesen  Programmieren  Debuggen).
Ab 4.4V geht bei JTAG nichts, aber auch gar nichts mehr. SPI 
funktioniert aber weiterhin einwandfrei bis 5.5V (weiter nicht 
probiert), aber damit kann man leider nicht debuggen...

Hat jemand eine Idee, woran das liegen könnte? An den betreffenden Ports 
hängt ausschließlich der Debugger (und an ein paar Ports davon 
Varistoren gegen Masse zwecks Überspannungsschutz).

Ich habe versucht, wie empfohlen die JTAG-Ports (TMS, TDI, TDO, TCK) 
mittels 10k Widerstand gegen VCC zu ziehen. Brachte aber für diesen 
Effekt keinen Unterschied.

Dann vermutete ich, der Schaltregler würde mit seiner Frequenz 
vielleicht irgendwie mit dem JTAG-Takt Schwierigkeiten machen, aber auch 
4.8V aus 4 NiMH-Akkus anstelle des (nun abgelöteten :-( ) Schaltreglers 
brachten keine Änderung.

Gibt es noch etwas, das ich ausprobieren oder kontrollieren kann?
Danke für eure Tips.

Gruß,
Christian

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: einen zweiten JTAG ICE mkII habe ich auch probiert mit exakt 
den selben Ergebnissen, der scheint also auch ok zu sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.