www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR-Dude: Manual und Praxis


Autor: Cerberus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie bekomme ich AVR-Dude dazu, mit meinem USB- AVRISP2 zu kommunizieren?

Ich habe das Manual gelesen und ich habe auch zur Identifizierung des 
Ports die Eingabe
avrdude -c avrisp2 -p m128 -P usb:xxx -v

versucht, aber statt die USB-Ports anzuzeigen, wie im Manual beschrieben 
bekomme ich nur

found 5 Busses

avrdude: usbdev_open<>: did not find any <matching> USB device "usb:xxx"

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und mit
avrdude -c avrisp2 -p m128 -P usb -v

Autor: Cerberus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
genau das Gleiche
Sei angemerkt, dass der Programmer aber im AVR-Studio problemlos 
funktioniert

Autor: Marius Wensing (mw1987)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Arbeitest du eventuell unter Vista oder XP 64-bit?

In den 64-bit Versionen scheint es zu Problemen mit den USB-Treibern zu 
kommen. Hab da mit AVRDude auch so meine liebe Not.
Liegt wohl an libusb.

AVR Studio verwendet ja den Jungo-Treiber der einwandfrei geht.

MfG
Marius

Autor: cerberus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne ne ganz trivial 32 bit

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast ja den LibUSB Treiber installiert, der bei WinAVR dabei ist? Und 
nicht den Jungo Treiber, den AVR Studio verwendet?!

Autor: cerberus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, ich hatte den Jungo, jetzt habe ich beide und werde mal schauen 
was jetzt dabei raus kommt. Jedenfalls hat er gerade schon mal die Ports 
angezeigt, das ist doch schon mal was...

Autor: cerberus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun habe ich wieder 2 wundervolle Stunden damit versaut AVR-Dude dazu zu 
bewegen meine Prozessoren zu brennen ... Angeschissene Rechts raus.
Das Problem: AVR-Dude interessiert sich nicht nur nicht für die 
Einstellung von 125kHz zum brennen, damit es auch wirklich nicht geht 
schreibt es die Frequenz auf 1 Mhz.
So eine Müll
Wie kann ich avr Dude dazu überregen, erst die Fuses mit 125khz zu 
schreiben und dann das Programm mit 2 oder 2 Mhz?
die -B Option funktioniert schon mal nicht

Autor: Dirk Broßwick (sharandac)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
versucht mal

avrdude -c avrisp2 -p m128 -P usb -v -F -t

damit kommst du in den command-mode für den avrdude, dort kannst du mit

sck n

die clockfrequenz einstellen in µs.

CA Dirk

Autor: cerberus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK es funktioniert also doch mit der -B Option, man darf nur nicht 2 
davon in einer Commandozeile haben.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.