www.mikrocontroller.net

Forum: PC Hard- und Software COM2 nach COM 1 umbenennen?


Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe seit ein paar Tagen eindes dieser neuen Dual Core Boards drin, 
die keine zwei RS232 mehr haben. Das stellt mich vor das problem meinen 
Debugger zu betreiben. Nun gibt es einen Stecker auf dem Board an den 
sich so ein COM Port anschliessen lässt. Diesen auch gekauft, im Bios 
aktiviert. Da lassen sich da nur noch die IRQs einstellen und IO 
Adressen, mehr nicht.

Es ist ein MSI Board Neo2 für den Athlon64. Da steht, dass damit COM1 
konfiguriert wird. Im Geräte Manager aber steht, dass es nur einen COM2 
im Computer gibt und das Dumme ist weiter, dass MPLAB nur COM2 erkennt 
und sich daher nicht mit dem Debugger verbinden kann.

Weiss einer, wie man bei diesen Boards aus dem COM2 einen COM1 macht?

Gruss,
Christian

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian wrote:

> Weiss einer, wie man bei diesen Boards aus dem COM2 einen COM1 macht?

Einfach im BIOS die Basisadresse ändern. Ich glaub 0x2F8 war COM2 und 
0x3F8 COM1

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, geht leider nicht, es wird immer auf COM2 gelegt, egal was ich 
einstelle.

Auch in der Registrierung klappt es nicht aus COM2 COM1 zu machen, beim 
nächsten Start wird es wieder COM2.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Gerätemanager Rechtsklick auf den 
Port->Eigenschaften->Anschlusseinstellungen->Erweitert
Dort kannst du die Port-Nummer ändern. Natürlich darf COM1 nicht schon 
belegt sein, sonst musst du den erst auf einen anderen Port legen.

Autor: Jorge (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal in System auf Gerätemanager -> Anschlüsse -> COM
-> Anschlusseinstellungen -> Erweitert -> COM1 auswählen.

Wenn das nicht geht, dann liegt das Prob am zugrundeliegenden Treiber. 
Vielleicht kann man da was konfigurieren (welcher isses denn?).

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

demzufolge ist COM1 bereits belegt aber das Dumme ist: Das Board hat nur 
einen COM Port Stecker und bietet auch nur einen im Bios an. Der Treiber 
ist garantiert einer von Windows oder der CD die bei dem Board dabei 
lag. COM1 wird in der Liste gar nicht aufgeführt.

Ich glaube, dass es sinnlos ist da weiterzusuchen.... da scheint die 
Firmware des Bios vielleicht ne Macke zu haben, auch wennn die aktuell 
ist.

trotzdem Danke schön !

Autor: Christian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es geht, ich habe COM1 !!! Obwohl der belegt war.

Ich kann zumindest eine Verbindung aufbauen, nur die Kommunikation 
klappt noch nicht aber den Stecker im Rechner kann man ja auf beiden 
Seiten einstecklen, vielleicht ist der nur falsch herum...... probiere 
das gleich nach dem Gewitter aus.... muss Rechner erstmal ausmachen.

Autor: Christian J. (elektroniker1968)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ende der Geschichte!" Egal wie man es auch dreht, alle Möglichkeiten 
durchprobiert : keine Verbindung zum Debugger und ein ganz normales 
Senden von Zeichen zur RS232 von einem Multimeter gibt bei Hyperterminal 
nichts mehr aus. Mit dem alten Board hat das alles geklappt, also 
scheint das Problem beim Neuen zu liegen. Vielleicht weil sich keiner 
der Entwickler so richtig um den COM Port mehr gekümmert hat, braucht ja 
auch keiner ausser den Bastelfritzen :-(

Autor: Ja mann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist auf dem Mainboard ein 10-poliger (2x5) Pfostenstecker ? Wenn ja: Es 
gibt mindestens 2 verschiedene Belegungen des Kabels. Bei der einen ist 
Pin 1 am Pfostenstecker auf Pin 1 an der SubD-Buchse, Pin 2 auf Pin 2, 
etc. Bei der anderen Variante geht Pfosten 1 auf SubD 1, 2 auf 6, 3 auf 
2, 4 auf 7 usw...

Am besten mit einem Terminalprogramm was senden und am Pfostenstecker 
messen.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jup, ich hab auch so nen GigaByte Board, da ist die Anschlussbelegung 
so, dass der normale Adapter, bei dem das Flachbandkabel durchverbunden 
ist, nicht passt. Da braucht man einen speziellen, oder muss selber 
löten.

Autor: [Frank] (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das sind z.B. die beiden Steckervarianten.

Autor: Christian J. (elektroniker1968)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Au weia..... dass die sich nicht einig werden können.  Im Handbuch steht 
aber die Belegung, das hilft schon mal, ich habe Variante 1

Wird wohl das Billigste sein sich beide zu kaufen und auszuprobieren 
statt da herumzulöten

Autor: Christian J. (elektroniker1968)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liess mich doch keine Ruhe..... bruzzel.... löt...

Jungs, ihr seit Spitze !!!!

Le voila:

Connecting to MPLAB ICD 2
...Connected
Setting Vdd source to target
Target Device PIC18F2680 found, revision = a2
...Reading ICD Product ID
Running ICD Self Test
...Passed
MPLAB ICD 2 ready for next operation

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.