www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Ansteuerungssignal übertragen mit impuls Trafo!


Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi Leute,

ich habe das folgende Problem:
ich habe einen Impulsübertrager, der folgende Eigenschaften hat:

Lstreu=250µH
Lpri=10mH
Lsek=10mH
ü=N1:N2=1
Rpri=1,5ohm

es soll eine rechteckförmige Ansteuerung von sekundärkreis in den 
Primärkreis übertragen werden. Die Schaltfrequenz ist zu verstellen im 
Bereich zwischen 1Hz (bzw. 0Hz) bis 600kHz.

Wie kann man dies Ansteuerungssignal übertragen bzw. wie muss man den 
Trafo beschalten. damit man im Primärkreis CMOS Area beschalten kann.

Vielen Dank für eure Infos

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@gast (Gast)

>Lstreu=250µH
>Lpri=10mH
>Lsek=10mH
>ü=N1:N2=1
>Rpri=1,5ohm

Hmm.

>Bereich zwischen 1Hz (bzw. 0Hz) bis 600kHz.

Welchem Hirnm entspringt diese Vorgabe?

0Hz ist schon mal gar nicht drin, ein Trafo überträgt nur 
Wechselspanung. 1 Hz ist auch Unsinn. Ich schätze mal mit dem Trafo geht 
das Leben ab 10 kHz los, drunter wird das Ding sättigen.

MFG
Falk

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das geht doch wohl,

erst ab aber vielleicht ab 20Hz oder 100Hz.
Das ist nich das Problem. Das Problem ist die beschaltung.

ich habe folgende schaltung:

                      --Cx--
CMOs---220n--1k--Trafo--Rx---1k---CMOS
                            |Zener
                            |gnd

RX=4k7
CX=3n3

Zener=15V

ob man das was anders beschalten kann, möchte ich wissen.

mfg

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den 1k vor dem Trafo könnte man wohl weglassen.

Aber so überträgst du nur die Flanken deines Ansteuersignales. Da 
brauchst du noch einen Pulsformer, der die sozusagen integriert um zB 
wieder eine PWM zu erhalten.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
genau, das ist ja das ziel. ich brauche nur Flanken. (Der Trafo ist ja 
Impulstrafo)
aber die schwingung am CMOS-eingang in primärkreis ist irgendwie 
komisch, wenn das Signal unter 7V ist dann schaltet mein CMOS 
(Schmidttrigger) ab.

Ich brauuche irgendwie nicht so zu schwingende Flanken.
was kann man noch besser machen.

Danke

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>aber die schwingung am CMOS-eingang

Oszibild mit Eingang und Ausgangssignal??

Autor: gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
anbei findest du die Simulationsfile mit LTspice.

V5 bezieht sich auf mein VCO Ausgang und in_Schmidt ist kritischer 
Punkt, um Schmidt trigger richtig zu funktionieren.

an out_norm habe ich ein retrigbaren Mono-Flop. mit einsteigender Flanke 
schaltet er.

So, wenn man die simulation laufen lässt und beobachtet, dann kann man 
sehen, dass der Eingang vom Schmidt trigger komischerweise an- und 
auschalten. Es hängt ja von Pegel (erst ab 7V bzw. unter 7V) ab.

vielleich hat jemand eine Idee, um das etwas zu verbessern.

danke

Autor: gast (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier ist die entsprechenden Verläufe.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.