www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Fehler in Transistorschaltung?


Autor: TeslaZwerg (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin hier gerade am Verzweifeln, ich hab jetzt schon 3 Transistoren
geschrottet, jetzt hab ich gedacht, ich muss doch mal nachfragen.
Also ich hab die Schaltung wie im Anhang aufgebaut, die Eingänge der
Transistoren sollen man einzeln von einem AVR gesteuert werden. Nun ist
meine Frage, ob der Schaltplan so richtig ist. Ich meine er müsst
stimmen, da ich das ganze schon mit einem einzelnen Transistor getestet
hab. Nun wird allerdings jedesmal wenn ich 5V an die Basis anleg der
7805 der 5V Spannungsversorgung ziemlich warm. Der Lüfter der an dem
Transistorausgang hängt, dreht sich für ein paar sekunden, und dann is
schluss.
Danke schonmal für die Antworten

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yo,kein Wunder.

Häng mal nen Widerstand vor die Basis (2) dann klappts besser ;)

so um die 0.5 bis 1K (Probieren)

Autor: Thomas K (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich glaube du brauchst einen vorwiderstand.
wo überhaupt hängt denn da der avr dran?

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achg ja,nochwas vergessen.


Der Regler wird vermutlich so warm weil ebenfalls vermutlich keine
Kühlung drann ist und der Lüfterstrom nochmal vermutlich schon
reichlich hoch ist.

Ebenso vermute ich mal das der Regler von 12 auf 5V Regeln soll und
keinerlei Blockkondensatoren (Besonders 100nF zwischen Masse und
ausgang) besitzt so das er Schwingt wie bekloppt.

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei uns in der Firma hiess diese Funktion "welmen" nach einem Herrn
Welm... Transistoren durch Hitze töten...
Jedem Transistor  einen Widerstand von 0,5 bis 1K Ohm spendieren, und
die Menge der toten Transistoren nimmt merklich ab.

Autor: TeslaZwerg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lol ok, ich hab 1K vor die Basis, jetzt gehts.
Der Regler is in Ordnung, der wird normal überhaupt nicht warm.
Blockkondensatoren sind 3 mindestens drin :) und mim Lüfterstrom hatte
der garnichts zu tun, das hat ein anderes Netzteil erledigt.
Im Datenblatt des Transistors steht allerdings dass er 5V an der Basis
verträgt...aber egal, jetzt gehts ja.
Mal was anderes: Was gibt eigentlich ein Multimeter aus, wenn man damit
nen Transistor misst?

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Basis zu Emitter darf höchstens so 0.6 bis 0.7 Volt sein, nie 5V (da
war wahrscheinlich in Sperrrichtung gemeint).
Sie dir mal die Grundlagen von Transistoren an, die Schaltung ist schon
etwas "merkwürdig".

Autor: TeslaZwerg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was ist an der Schaltung merkwürdig? wenn an der Basis Strom anliegt,
schaltet der Transistor, und der Verbraucher, den man an den Klemmen
untern anschließt, läuft. Vielleicht kommt es dir komisch vor, weil ich
die Schaltung nicht komplett gezeichnet hab, aber dazu war ich du faul
:)
Die einzelnen Basen werden natürlich später von einem AVR angesteuert
und an den Klemmen hängen Lüfter. Wenn jetzt immer noch was merkwürdig
ist, dann bitte sagen.

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, wenn die Schaltung anders aussieht als du gezeichnet hast, dann
ists was anderes.

Aber die Basis direkt an +5V hängen ist halt Blödsinn. Einfach einen
Widerstand davor und einzeichnen, dass es an den µC Ausgang angehängt
ist, ist dann klarer und auch nicht mehr Zeichenaufwand.

5V an Basis und Emitter an Minus ist das selbe wie eine Diode zw. 5V
und  Minus hängen. Transistor wie auch Diode sterben dabei.

Autor: edi.edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

die schaltung wurde am 1° April gezeichnet und HAT funktioniert!

ed

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Tesla,

wenn du Induktive Lasten Treiben willst, dann nicht die Freilaufdioden
vergessen, sonst beginnt das Transistorsterben,
von neuem.

Gruß,
Arno

Autor: TeslaZwerg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tip mit den Dioden. Ich hab Sicherheitshalber mal welche
rein, aber in den Lüftern müssten eigentlich schon welche verbaut sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.