www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik N-FET schaltet Gate Spannung ohne Drain Spannung durch?


Autor: Oliver H. (snatch)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe ein kleines Problem. Ich versuche einen N-FET IRF540N zu 
verstehen.

Der Transistor ist laut angehängert schaltung verschaltet.

Am Gate hängt eine Rechteckspannung mit 20 KHz die wie im unten 
angehängten Screen des Oszis CH I auch gemessen wird. Am Drain hängt 
keine Spannungsquelle und auch sonnst nichts. Das Füßchen zeigt ins 
leere. Warum messe ich nun  wie im screen CH II zu sehen am Source, 
genau die Spannung, die am Gate anliegt? Sollte dort nicht 0 raus kommen 
und erst eine Spannung anliegen, wenn ich am Drain eine Spannung anlege?

Ich habe das nicht so ganz begriffen.

Andersrum, wenn ich mit gleicher Schaltung am Gate eine normale 
Gleichspannung anlege, sagen wir 10V, dann messe ich am Source keine 
Spannung. Dann schaltet er nicht den Gate nach Source durch, so sollte 
es ja auch sein. Erst wie oben beschrieben, beim anlegen einer 
"Wechselspannung" verhält er sich so "falsch"



Gruß
Denis

Autor: Oliver H. (snatch)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch den screen vom Oszi.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn dein Widerstand ausreichend hochohmig ist, dann könnte dies eine 
kapazitive Kopplung über die Source-Gate Kapazität sein.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Denis H. wrote:

> Warum messe ich nun  wie im screen CH II zu sehen am Source,
> genau die Spannung, die am Gate anliegt?

Weil du eine Gate-Source-Kapazität hast, die für hohe Frequenzen
einen Teil der Leistung vom Gate direkt auf das Source koppelt.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Offensichtlich ist R1 sehr hochohmig. Nimm mal 100Ohm oder sowas, dann 
dürften nur noch Spikes durch die Schaltflanken durchkommen

Autor: Oliver H. (snatch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

kann ich das verhindern?

Mein Vorhaben ist, das signal einer Spannung am Gate 10V Rechteck 20KHZ 
auf eine 24V Gleichspannung am Drain zu übertragen. Ich möchte also 
Verstärken. Wie mache ich das dann am besten?

Gruß
Denis

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wäre nützlich, mehr über die Last zu erfahren. Denn um nur einen Oszi 
anzuschliessen ist ein IRF540 vielleicht etwas übertrieben. Und mit 
einer diesem Typ adäquaten Last dran löst sich das Problem sowieso in 
Luft auf.

Autor: Oliver H. (snatch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

es geht da grundsätzlich erst mal ums Verständniss.

Das mit dem 100Ohm Wid. an Source war richtig. Danke sehr. Jetzt 
schaltet er wie gewollt. So lange nichts am Drain angeschlossen ist. 
Messe ich nun auch am Source ausser kleinen Spitzen nichts mehr.

Das ist also abgeschlossen.


Neues Problem.
Gate = 10V 20KhZ Rechteck
Drain = 0-24V gleichspannung über 100Ohm Last
Source über 100Ohm an Masse.

Ich bekomme nun nicht die vollen 24V durchgeschaltet. Bei 4V ist 
schluss.


Zur genauen Erklärung was geschen soll:

Ich habe vor über einen LM3524N ein PWM-Signal zu erzeugen. Dieses soll 
über einen Treiber TC427 Eben den N-Fet ansteuern, welcher mir dieses 
Signal auf 24V Verstärken und an einen Trafo geben soll. Es funktioniert 
alles soweit auch gant gut. Ich bekomme bis zum Gate des IRF540 ein 
Sauberes 20kHz Rechtechtsignal mit 10V. Nur schaffe ich nicht, dieses 
auf die 24V Gleichspannung zu übertragen.

Gruß
Denis

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hau den Widerstand an Source weg, dann wird es funktionieren.

Autor: Denis G. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe es Mittlerweile verstanden und nn funktioniert auch alles.

Nur wenn ich statt einer Ohmschen Last am Drain den Trafo dran hänge, 
messe ich am Drain kein Rechteck mehr sondern lauter hässliche Sptzen. 
Ich vermute aber, dass die daran liegt, dass die SPule nicht belastet 
war und eine Spannung zurückidutierter.

WErde das heute mal testen.

Ich danke euch!

Autor: avion23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Denis,
bei einer Spule brauchst du eine Freilaufdiode. Wenn das nicht erwünscht 
ist kann ein Snubber helfen.

Autor: rudi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>bei einer Spule brauchst du eine Freilaufdiode.

Statt dieser Freilaufdiode kannst Du aber auch eine Sekundärwicklung 
verwenden und die entstehende Energie dorthinein transportieren, statt 
sie über der Freilaufdiode zu verheizen.
Wie eben richtig gesagt wurde, kann man mit einer RC-Beschaltung die 
"ersten" Spitzen kappen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.