www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schaltnetzteil Verluste


Autor: Hans1111 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
habe mir dieses Netzteil nachgebaut:
http://www.mikrocontroller.net/articles/Controller...
habe nur statt der 5 V, 24 V Ausgangsspannung eingestellt, anstatt des 
TNY264 den TNY268 und als Trafo MYRRA 74030 für mehr Leistung genommen. 
Bei dem Trofo habe ich alle drei Sekundärwicklungen in Reihe geschaltet 
um auf die 24 V Spannung zu kommen.
Die Schaltung funktioniert auch soweit, habe nur bei einer Last von 16 W 
(50 Ohm) einen Wirkungsgrad von 75 % was ja doch recht wenig ist. 
Handelsübliche Netzteile kommen bei der Leistung auf etwa 85 %.
Woran könnte es liegen? Ich tippe aufgrund der Wärmeentwicklung ganz 
stark auf den Trafo, da dieser ziemlich heiß wird, obwohl alle 
Sekundärwicklungen zusammen nicht einmal 1 Ohm haben. Der TNY268 wird 
zwar auch etwas warm, aber dass ist aufgrund des Innenwiderstandes des 
internen Transistors normal glaube ich.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitte erläutere, wie Du den Wirkungsgrad gemessen hast bei Deinem Aufbau 
(Art der verwendeten Meßgeräte, etc.).

Denn so wird es hier nicht klar, was Du wie gemessen hast -- ich komme 
bei 50 Ohm an 24 V auf etwas weniger als 12 W.


Andrew

Autor: Bensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine Kristallkugel sagt, du hast die Trafowicklungen falsch 
verschaltet.....

Autor: Hans1111 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andrew Taylor
SRY es waren 50 Ohm und 100 Ohm parallel zueinander sind genau 17,28 W.
Die Leistung wird mir von der Power Supply angezeigt, einmal in Watt und 
einmal in VA. Die Leistung in Watt wird von der Power Supply mit 23,3 W 
bei einer Ausgangsleistung von 17,28 W angegeben.

Autor: sous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Hans1111:

>>>Ich tippe aufgrund der Wärmeentwicklung ganz
>>>stark auf den Trafo, da dieser ziemlich heiß wird, obwohl alle
>>>Sekundärwicklungen zusammen nicht einmal 1 Ohm haben.

Nur mal so generell als Hinweis:
- Was heißt 'Nicht mal 1 Ohm'? 0,9 Ohm würden in diese Kategorie fallen 
und wären auch schon nicht ganz wenig.

- Verluste eines Trafos werden nicht alleine durch den (ohmschen) 
Wicklungswiderstand hervorgerufen, im Kern kann es auch noch nicht 
vernachlässigbaren Energieumsatz geben.

- Desweiteren: siehe die anderen beiden Postings nach Deinem...

Autor: Hans1111 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Hans1111
Hier das Datenblatt zum Trafo:

http://www.farnell.com/datasheets/83481.pdf

Meine Beschaltung:

PIN 1 = N/A
PIN 2 = N/A
PIN 3 = TNY268
PIN 5 = 250 VDC

PIN 6 = 28 V
PIN 7 = N/A
PIN 8 = PIN 9
PIN 9 = PIN 8
PIN 10 = GND

Ist es korrekt?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so ein Aufwand für ein Netzteil mit 24V/500mA??
Ein solches Steckernetzteil kostet 5,-Euro fertig...

Autor: Lupin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du es mal mit 320VDC versucht? Eigentlich sollten 250 ja auch 
gehen...

Du hast einen myrra 74032 und nicht 74030 oder?

Was für ein power supply benutzt du?

Misst du direkt am power supply oder nach X Metern anschlusskabel? Kann 
sein das du einiges an Verlust an den Kabeln hast.

Hast du die Schaltung mit der Zener diode am ausgang übernommen? Hab 
festgestellt die Regelung ist mit der Zener Diode ziemlich mies. 
Vielleicht gehst du davon aus, dass über deiner Last 24V sind - in 
wirklichkeit könnten es mehr/weniger sein.

Finde ich ja cool das mein Artikel zum Nachbau angeregt hat.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans1111 wrote:
> @Andrew Taylor
> SRY es waren 50 Ohm und 100 Ohm parallel zueinander sind genau 17,28 W.
> Die Leistung wird mir von der Power Supply angezeigt, einmal in Watt und
> einmal in VA. Die Leistung in Watt wird von der Power Supply mit 23,3 W
> bei einer Ausgangsleistung von 17,28 W angegeben.

okay, das erklärt die etwas mehr als 16W.

Ich wiederhle noch mal meine bereits gestellte Frage: Wie bzw. mit 
welchem Meßgerät hast Du die Leistung gemessen.
Präziser: Mich interessiert die Eingangsseite - Präzisonswattmeter oder 
Baumarktgerät? Oder einfahc Eingangsstrom mit Amperemeter gemessen und 
dann mit Netzspannung 230V multipliziert?

Andrew

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dir ist schon klar, dass man in einem SNT nicht einfach so irgendeinen 
Trafo einbauen kann, auch wenn der vom Wicklungsverhältnis her passen 
könnte?

Hier kommt es auf die eingespeicherte Energie an, und die hängt von der 
Induktivität und der Schaltdauer ab, am allerwenigsten aber vom 
Wicklungsverhältnis.

Wenn du so wichtige Komponenten (und der Trafo ist hier mit die 
wichtigste) einfach so austauschst, wundert mich dein Ergebnis nicht.
Wenn der Trafo heiß wird, geht der evtl. in die Sättigung?

Autor: Hans1111 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Lupin
Ne ist ein Marry 74030, der 74032 hat nur eine Sekundärwicklung. Die 250 
VDC die ich draufgebe sind das Maximum was ich aus der Power Supply 
rausholen kann. Prinzipiell funktioniert es auch mit 90 V, jedoch steigt 
der Verlustfaktor mit sinkender Spannung nur minimal.
Die Ausgangsspannung ist eigentlich ziemlich stabil, je nach Last 
variiert diese um ca. 0,5 V, aber das ist OK.
Wenn ich den Finger auf den Trafo draufhalte könnte ich schwören, dass 
die Wärme  von der Sekundärseite kommt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> habe nur statt der 5 V, 24 V Ausgangsspannung...
Darüber hinaus ist dir auch klar, dass das bei gleichem Strom
dann die 5-fache Leistung wäre --> 5 mal größerer Trafo nötig?

Autor: Lupin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meiner Meinung nach ist der TNY268 ein klein wenig zu klein. Ein TNY280 
wäre besser geeignet.

Versuch es mal mit einer kleineren Last. Wahrscheinlich wird der 
Wirkungsgrad dann besser sein.

Autor: Lupin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar der Trafo passt schon, der ist für diese Reglerfamilie ausgelegt. 
Da braucht man gott sei dank nicht selbst drüber nachdenken ob der 
richtig ist :-)

Hans du kannst auch mal den snubber des Trafos nachmessen, also an der 
Kathode von D3. Da sollte die Spannung nicht weit über 100 volt gehen. 
Wenn doch verkleinere mal R1.

Auf der Primärseite nach größeren Spannungsspitzen und Klingeln zu 
suchen ist generell keine schlechte idee.

Autor: Hans1111 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Lothar Miller
Guter Tipp. Der von mir gewählte Regler hat eine Taktfrequenz von 132 
kHz. Der Trafo eine Eingangsinduktivität von 750 µH. Laut dieser Seite 
hier:
http://schmidt-walter.eit.h-da.de/smps/spw_smps.html
Wird mir bei meinen Werten eine Eingangsinduktivität von 3,5 mH 
empfohlen.

Wie wirkt es sich eigentlich aus, wenn man eine zu niedrige 
Eingangsinduktivität hat? Schließlich wird die Energie ja trotzdem 
übertragen und die Spannung bleibt auch unter Last stabil.
Kann es sein, dass die Primärseite durch die zu niedrige Induktivität 
öfters in die Sättigung gerät, dadurch zu viel Strom zieht und nicht 
mehr im optimalen Arbeitsbereich arbeitet (wenn man das so sagen kann)?

Autor: Lupin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wundern tut mich das auch, dass die Prim. Induktivität so niedrig ist. 
Aber wenn man sich das Datenblatt des Trafos anschaut dann steht da ja 
noch die Arbeitsfrequenz des jeweiligen Reglers hinter. Und die ist in 
der Tabelle bei den TopSwitch Reglern 100kHz.

Autor: Hans1111 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt einen zweiten Trafo in Reihe geschaltet, wodurch ich auf eine 
Gesamtinduktivität von 1,5 mH auf der Primehrseite komme. In der Tat 
verbessert sich der Wirkungsgrad von 75 % auf 87 %. Daher glaube ich 
wirklich, dass die Eingangsinduktivität mit 750 µH, bei einer 
Taktfrequenz von 132 kHz und der übertragenen Leistung von 17 W zu 
niedrig war.
@Lupin
Im Datenblatt steht ja nur, dass es funktioniert, was ja auch stimmt. 
Leider wird der Wirkungsgrad dabei nicht erwähnt. Es ist wohl wirklich 
so, dass die Eingangsimpedanz welche sich aus der Frequenz und der 
Eingangsinduktivität ergibt, nicht zu klein sein darf.

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>nicht zu klein sein darf.

Das stimmt wohl. Hat aber (erstmal) nichts mit der Imdedanz (da kein 
Sinus)
sondern mit der Stromanstiegsgeschwindigkeit.

Ist das L zu klein, steigt der Strom zu schnell. Und da wird wohl die 
Drosselsättigung erreicht, bevor der PWM-Zyklus zuende ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.