www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATX Netzteil steigt aus (Stromspitzen) - Abhilfe gesucht


Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallihallo zusammen,

wir setzen ein modernes ATX-PC-Netzteil ein, um einen Bürstenmotor 
anzutreiben. Das Netzteil kann 630W abgeben. Wir brauchen nur die 12V 
Schiene, welche 21A abgeben kann.
Der Motor wird über eine PWM (ca. 32kHz) von einem FET Lowside 
angesteuert.
Unser Problem ist nun, dass das PC-Netzteil abschaltet, wenn die Sache 
ca. 8A zieht. (mit Digitalmultimeter gemessen...)
Die Vermutung ist nun, dass durch die PWM die Stromlimite kurzzeitig 
überschritten wird und das Netzteil den Rettungsanker wirft Oder dass 
die PWM die Schutzmechanik des Netzteils sonst irgendwie aus der Bahn 
schleudert.... Wir bräuchten aber dringend mehr Strom...

Wie können wir verhindern, dass uns das Netzteil abschaltet, wie sieht 
die physiologie dieser Abschaltmechanik aus?

Gruss
Mario

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
fetten C am Ausgang des Netzteils?

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PC Netzteile setzen eine entsprechende Last auf dem 5V Zweig (und ATX 
wohl auch auf dem 3.3V Zweig) voraus. Sonst arbeitet der 12V Zweig nicht 
bis zu  der aufgedruckten Maximalstromstärke (hier wohl: 21A)

Welche Last hast Du an den 5/3,3 Volt angeschlossen?



Andrew

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, wusste doch, dass ich was vergessen hatte :)

Die 5V-Leitung war mit 1.1A belastet. 3.3V gar nicht.

Ich habe das Netzteil mal an meine Stromsenke gehängt (steuerbarer 
FET...), da konnte ich dem Netzteil auch ohne Last am 5V-Ausgang 21A 
abringen...

Also daran wirds wohl eher nicht liegen...

Aber reicht denn ein dicker Elko? Der will ja auch wieder aufgeladen 
werden...

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schöner Test mit der Stromsenke, aber der zeigt Dir lediglich das Dein 5 
V Zweig funktioniert. Was ich Dir ja auch schon kurz beschrieben habe 
oben warum das mit hohen Strom funzt (ist der geregelte Hauptausgang).

Also so wird es was: 5 V mit ca. 1/3 Nennstrom belasten (Widerstand).
3.3V Zweig mit ca. 1/4 Nennstrom belasten.

Nun den 12V Zweig an die Stromsenke.

Was geht jetzt?

Den Kondensator kannst Du bei kurzen Stromspitzen als Stütze verwenden.
Aber Dein NT regelt ja die 12V schon deutlich unter 21A ab (so schreibst 
Du ja 8A).
Da kommst Du mit dem Kondensator allein nicht viel weiter.


Andrew

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eh verflixt... ich konnte dem Netzteil ohne Last an 5V an der 12V 
Schiene die 21A abringen. Und das über ca. 30 Sekunden. Dann bekamen die 
Kabel warm.

Aber ich werde morgen mal beide Schienen belasten und schauen obs geht. 
Falls es dennoch abschalten würde: Was dann? LC-Filter am Ausgang? Oder 
wie funktioniert die Schutzabschaltung? Kann man die nicht irgendwie 
aushebeln?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Mario (Gast)

>Schiene die 21A abringen. Und das über ca. 30 Sekunden. Dann bekamen die
>Kabel warm.

http://www.duden.de

>Falls es dennoch abschalten würde: Was dann? LC-Filter am Ausgang?

Nö.

> Oder wie funktioniert die Schutzabschaltung? Kann man die nicht
> irgendwie aushebeln?

Diesen Gedanken solltest du unverzüglich vergessen.

MFG
Falk

Autor: Katapulski (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Falk
Du mußt nicht gleich den großen Zampano geben, von wegen "Duden".

Vielleicht muß Mario oft die englische Sprache nutzen und hatte
das Wort "became" statt "wurde" im Kopf.

gez. Katapulski

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder vielleicht ist er auch Schweizer und sagt : Da händ d Kabel warm 
übercho... ;)

Dann mal her mit den konkreten Vorschlägen... :)

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mario wrote:
> Eh verflixt... ich konnte dem Netzteil ohne Last an 5V an der 12V
> Schiene die 21A abringen. Und das über ca. 30 Sekunden. Dann bekamen die
> Kabel warm.

??? Wat nu - beim ersten Mal Meßfehler??
Oder ist es reproduzierbar.

Gegen die Wärme: Versuch mal mehrere von den Schwarzen (Minus) parallel 
zu schalten.
Ebenso mehrere von den gelben (+12V)

normaler Querschnitt ist AWG14 oder 16, das ist so um die 0.55 bis 0.75 
mm2 - das ist EINZELN mehr reichlich mit 21A belastet (meine freundliche 
Formulierung für: überlastet).

>
> Aber ich werde morgen mal beide Schienen belasten und schauen obs geht.
> Falls es dennoch abschalten würde: Was dann? LC-Filter am Ausgang? Oder
> wie funktioniert die Schutzabschaltung? Kann man die nicht irgendwie
> aushebeln?

Ich würde sagen: Du belastet erstmal, schreibst dann was ging.

Dann schauen wir hier im Forum weiter.

Schutzschaltungen aushebeln ist selten eine gute Idee.

Nimm lieber aus 1-2-3 ein günstiges Lambda, Kepco, etc. Netzteil mit 
reinen 12V, xxA (also single voltage output).

Aber wie gesagt, schaun mer mal.


hth,
Andrew

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm... wir werden sehen :)

Aber jetzt mal ganz allgemein: Wie funktioniert die 
Überstromabschaltung? Misst er mit einem Shunt oder funktioniert das 
thermisch(NTC/PTC) ?

Gruss
Mario

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PC-Netzteile würde ich echt nur für PCs nutzen. Da werden die dollsten 
Sachen aufgedruckt!!!!

Es gibt ja auch richtige Netzteile für feste Ausgangsspannungen. 
(Schaltnetzteile Meanwile o.ä.)

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Negativ.
5V und 3.3V je mit 1 Ohm belastet. Hat genau gleich abgeschaltet.
Und Versuche, die Strommess-Shunts zu brücken haben in einem Knall mit 
folgender Dunkelheit geendet :)

Jetzt machen wir das anders. PWM-Endstufe raus, Stromsenke als 
gesteuerten Widerstand rein.

Ist übrigens für unsere 2m-Propeller-Clock:

http://mauerer.m.googlepages.com/displayfromhell

Gruss
Mario

Autor: Sachich Nich (dude) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schickes Ding, macht sich auch gut an einer Junkers Ju 52... ;)

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Grundlast auf 3,3 V und 5 V sollte ca. 2 Ampere betragen, durch die 
PWM-Steuerung brauchst du auch eine Grundlast für die 12 V von ca.1,5 A.
PWM ist ja Aus- und Einschalten, d.h. die 12 V-Leitung ist zwischendurch 
ohne Stromentnahme und das Netzteil schaltet ab.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mario wrote:
> Negativ.
> 5V und 3.3V je mit 1 Ohm belastet. Hat genau gleich abgeschaltet.
> Und Versuche, die Strommess-Shunts zu brücken haben in einem Knall mit
> folgender Dunkelheit geendet :)

Ihr seid sowieso wahnsinnig oder?

630W für so einen kleinen Rotor und außerdem: Ihr habt da auf dem Bild 
nicht wirklich PC Netzteile parallel geschaltet, oder?
http://mauerer.m.googlepages.com/Testlauf.png/Test...

Ich wunder mich, dass euch das Dingen nicht um die Ohren fliegt. Bei 
kleinsten Unwuchten fliegt rappelts doch sicher schon ordentlich.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch, die 4 Netzteile waren alle parallel :) Aber gebracht hat es wie 
erwartet nichts.
Schlussendlich haben wir die beiden Motoren seriell direkt ans 630W 
Netzteil gehängt und mit einem Anlaufwiderstand anlaufen lassen, damit 
das Netzteil nicht abschaltet. Der Widerstand konnte dann gebrückt 
werden.

Aber etwas ist noch komisch: In dieser Konfiguration zogen die Motoren 
26A aus einer 12V Schiene. Spezifizier wäre diese Schiene gemäss 
Netzteil-Aufdruck für 20A... Aber das Netzteil schaltete nicht ab... 
Komische Dinger das...(die 26A wurden zuverlässig gemessen)

So drehte der Rotor dann mit 400 RPM. Die Unwucht war nicht sehr gross. 
An der Party haben wir ihn auf einem halben Meter hohen Gestell aus zwei 
Bier-Harassen mit Spanngurten auf einen Tisch gezurrt. Hat prima 
funktioniert und den Dauerbetrieb sogar überlebt, obwohl die Motoren an 
der äussersten Grenze liefen (hatten 80° Gehäusetemperatur)

Youtube-Video "2 Meter Propeller Clock  - AMIV HERTZ 7"

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Simon K.:
http://www.relaiscomputer.de/pics/pic8g.jpg
von http://www.relaiscomputer.de
Unter Menü Bilder->Stromversorgung (bis 100A)

mfg
gast

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich weiß ist es ziemlich gefährlich dies zu tun, weil 
Ausgleichsströme fließen, wenn die Spannungen nicht 100%ig 
übereinstimmen.

Autor: Chris W. (squid1356)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also mal ganz abgesehen das euer Projekt ziemlich beeindruckend ist, 
treibt ihr da ganz schön gefährliche Sachen.  Ich finde es bedenklich 
solche riesigen Propeller frei rotieren zu lassen.
Was glaubt ihr wenn da einer versehentlich Hand oder Kopf reinhält?
Und dann noch auf einer Party laufen lassen, echt extrem, Leute!
Da solltet ihr euch echt was überlegen, nen Käfig oder so!

Zu dem Motor:
Für solch einen haufen Computernetzteile hättet ihr sicher ein 
vernünftiges Single-Supply Netzteil bekommen, was so 30A liefert. Mal 
nach Lambda oder ähnlichem suchen (wurde ja auch schon gesagt, möchte 
das nur nochmals verdeutlichen!!)
Man kann hier auch nen Konventionellen Trafo, zB einen Halogentrafo 
nehmen, die sind recht günstig, aber schwer, und müssen stabilisiert 
werden, das sehe ich aber nicht so kritisch. Konventionelle Trafos 
kommen aber besser mit Stromspiten klar. Große Elkos nicht vergessen. 
Hier dann auch ggf. ne Einschaltstrombegrenzung vornehmen.

Dem Motor würde ich übrigens ne Kühlung spendieren, sonst macht der das 
nicht ewig mit.

Die von euch bisher eingesetzte Einschaltstrombegrenzung ist meiner 
Meinung nach der richtige Weg, besser als ein überdimensioniertes 
Netzteil.

Dann noch ne Frage: warum wird der Rotor mit PWM gesteuert? Wenn er mit 
Nennspannung betrieben wird sollte das doch glatt laufen, nicht? Falls 
er zu schnell ist wäre da ein Getriebe imho die bessere Wahl.

Autor: Chris W. (squid1356)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christoph Weidenhaupt wrote:
> Da solltet ihr euch echt was überlegen, nen Käfig oder so!

Auf der Seite war zu lesen:

>>Diese Propeller Clock ist also sehr gefährlich. Die Masse des Rotors ist 
>>relativ hoch, es stecken sehr viel Energie und sehr hohe Geschwindigkeiten 
>>dahinter. Deshalb bekommt das Ding auch noch einen Schutzkäfig, damit der 
>>Sargbauer weniger zu tun bekommt...

Sorry, das habe ich überlesen! Dann aber bitte schnell ;-)

Autor: Chris W. (squid1356)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach und nochwas: warum nehmt ihr nicht nen einfachen 230V 
Asynchronmotor?
Die gibts doch auch in langsamen Geschwindigkeiten, kleines Getriebe und 
das Ding wedelt wie verrückt...
Würde das ganze stark vereinfachen!

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, man hätte das einfacher machen können.Aber aus Fehlern lernt man ja 
bekanntlich. Beim Aufbau ändern sich die Konzepte auch immer mal wieder, 
da muss man halt umdenken und Kompromisse eingehen.

Und ein Netzteil, das 30A pumpen kann und speziell dafür ausgelegt ist 
kostet halt... so ein PC-Netzteil ist Massenware.
Wir mussten halt schon auf das Budget schauen, da sind Motoren halt auch 
wieder schwer zu kriegen. Ein Elektro-Kettensägenmotor vom Schrott hätte 
sicher auch funktioniert, nur kommen diese Ideen immer zu spät...

Die Motoren werden einzeln von einem 40mm PC-Lüfter angeblasen. Ein 
Kühlkörper wäre nicht schlecht, hat aber keinen Platz.
Die Motoren werden nicht gesteuert, sind direkt ans Netzteil geklemmt.

Wegen der Sicherheit: Dass das Ding absolut tödlich ist (der Rotor wiegt 
sicher seine 5-6Kg) sind wir uns bewusst. Wie man auf dem Video sieht 
lief das Ding in einem abgesperrten Bereich und nur wir hatten Zugang. 
Zudem haben wir zwei Gitter neben dem Rotor plaziert und nochmals alles 
mit Absperrband dicht gemacht. Ein Notaus wurde in sicherer Entfernung 
angebracht.

Autor: Chris W. (squid1356)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mario wrote:
> Ja, man hätte das einfacher machen können.Aber aus Fehlern lernt man ja
> bekanntlich. Beim Aufbau ändern sich die Konzepte auch immer mal wieder,
> da muss man halt umdenken und Kompromisse eingehen.
richtig, kenne ich ;-)

> Und ein Netzteil, das 30A pumpen kann und speziell dafür ausgelegt ist
> kostet halt... so ein PC-Netzteil ist Massenware.
Klar, aber ihr hattet 4? Computernetzteile, vielleicht wäre da schon ein 
besseres einzelnes drin gewesen.
>so ein PC-Netzteil ist Massenware.
Halogentrafos auch, und die sind recht billig. ;-)

> Wir mussten halt schon auf das Budget schauen, da sind Motoren halt auch
> wieder schwer zu kriegen. Ein Elektro-Kettensägenmotor vom Schrott hätte
> sicher auch funktioniert, nur kommen diese Ideen immer zu spät...
vielleicht möchtet ihr euer Projekt ja noch verbessern. probiert das mit 
dem Vorgeschlagenen 230V Motor doch mal aus. (die dinger sind 
unglaublich billig und sehr zuverlässig. habe noch mindestens 2 hier 
rumliegen, wollter euch einen holen kommen?? ;-) )

> Die Motoren werden einzeln von einem 40mm PC-Lüfter angeblasen. Ein
> Kühlkörper wäre nicht schlecht, hat aber keinen Platz.
das bringt nicht viel, die luft kühlt höchstens das Gehäuse. Ihr solltet 
die Luft wenn schon durch die Luftschlitze am Läufer vorbeiführen (zB. 
mit einem Rohr.) Der kleine Luftfächer in den Motoren reicht hier nicht. 
Das was warm wird sind die Wicklungen im Läufer, das es riecht ist ein 
sehr deutliches Zeichen von Überlastung.

> Die Motoren werden nicht gesteuert, sind direkt ans Netzteil geklemmt.
ok, habe ich dann auch gesehn. Das ist der richtige Weg.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Interesse an einem verbesserten Antrieb ist vorhanden. Wir werden da 
sicher noch dran rumfummeln.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nimm doch einfach eine Spule und fertig.......

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.