www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 über USB to COM-Adapter anschließen


Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich bin gerade dabei, mein neues STK500 in Betrieb zu nehmen.
Da mein Laptop keinen COM-Anschluß besitzt, verwende ich hierfür einen 
USB-Adapter. Allerdings hatte ich hiermit trotz unzähligen Versuchen 
noch keinen Erfolg. Das STK500 wird vom AVR-Studio einfach nicht 
erkannt, auch wenn ich alle in der Liste verfügbaren COM-Ports 
durchprobiere!
Ich vermute, daß die Adapter-Lösung ausgangsseitig doch keinen 
vollwertigen COM-Port bereitstellt.
Naja, ist halt so'n billiger China-Sch***!

Habt Ihr schon ähnliche Erfahrungen gemacht?
Wie kann ich mir da behelfen?

Vielen Dank und Euch allen eine schöne Adventszeit!

Grüße
J.R.

Autor: Gast123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jürgen,

bei mir funktioniert das STK500 eigentlich klaglos an einem 
USB-RS232-Adapter. Der allerbilligste war es nicht, aber ob das ein 
Zeichen für Qualität ist, ist die Frage.

Was ich mal probiert hatte: die Nummer des virtuellen COM-Ports manuell 
auf einen freien Wert kleiner 8 (oder 16??) zu setzen. Ich weiss nicht 
mehr obs das STK/AVRstudio oder mein Terminalprogramm war. Bei einem von 
beiden lies sich das Ganze so zum laufen bekommen.

Was auch sein könnte: der Adapter liefert keinen RS232-Pegel sondern nur 
0V/5V.. Könnte man evtl. mal mit dem Oszi nachmessen..

Viel Erfolg und ein schönes Wochenende..
Christian

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schau doch einfach im Gerätemanager unter Anschlüsse nach, welche COM 
Dein USB-Adapter bekommen hat. Dann weißt es und mußt nicht probieren...

Außerdem kannst Du dort notfalls auch den Adapter auf eine der unteren 
COM setzen (meist Eigenschaften -> Port Settings -> Erweitert), das geht 
aber nicht mit allen Adaptern.

Gruß aus Berlin
Michael

Autor: Jürgen R. (hobbyloeter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Christian,

danke für Deine schnelle Antwort!

Wie genau hast Du das denn gemacht mit der Nummer des COM-Ports?
Welchen USB-Adapter verwendest Du denn (Typ/Hersteller/Bezugsquelle)?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.