www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik QT100 - kein Heartbeat-Puls


Autor: Alexander D. (alexander_d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Experten,

für einen kapazitiven Sensor nutze ich den Baustein QT100 von Atmel. 
Beim Testaufbau hat alles funktioniert, aber jetzt bei der "richtigen" 
Leiterplatte sind 3 von 5 QT100 ohne Heartbeat-Pulse.

Der QT100 hängt mit seinem Ausgang direkt an einem Portpin eines 
ATtiny2313, der interne Pullup ist eingeschaltet. Der 
Sampling-Kondensator hat 47nF, der Baustein ist mit 100nF direkt am 
VDD-Pin abgeblockt. Alle QT100 (auch die ohne Heartbeat) schalten 
einwandfrei bei Berührung.

Der Pullup ist auch tatsächlich aktiv, denn mit einem Amperemeter messe 
ich vom Portpin 150µA gegen Masse.

Hat jemand diesen Effekt schon mal beobachtet?

Gruß,
Alexander

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit was mißt Du die Pulse ? Welche Kapazität hat die Messspitze ?

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich aber ein Bestückungsfehler.

Autor: Alexander D. (alexander_d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Analog wrote:
> Mit was mißt Du die Pulse ? Welche Kapazität hat die Messspitze ?

die Pulse messe ich mit dem Oszilloskop am Ausgang des QT100. Da spielen 
die 30pF des Tastkopfs keine Rolle.

Einen Bestückungsfehler kann ich ausschließen, es sind ja nur ein paar 
Bauteile.

Gruß,
Alexander

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mit den Dinger mal gearbeitet, habe sowas aber nicht 
festgestellt. Einen Bestückungsfehler kann man auch mit ein paar 
Bauteilen machen. Manche Bestücker nehmen einfach Nachbarwerte, wenn sie 
den Wert nicht da haben. Da ist schnell mal 100nF anstatt 10nF usw. 
bestückt. Aber die Logik sagt mir einfach, daß wenn 3 von 5 nicht gehen, 
daß da was falsch oder grenzwertig bestückt wurde.

Naja, also ich habe damals einen Mikrokontroller am OUT-Pin gehabt.Was 
hängt den alles am Out-Pin? Hast Du ein RC-Glied dazwischen? Ist der 
Pullup von Out nach Vdd vorhanden?

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hängt die Versorgungsspannung an der Versorgungsspannung des µC? 
Versuche mal eine Getrennte Spannung (z.B. über eigenen 5V 
Spannungsregler).
Und Der Tastkopf hat doch einen Einfluss auf den Schaltkreis, zumindest 
bei mir. Sobalt ich mit dem Tastkopf an die Sensorfläche gehe schaltet 
er ein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.