www.mikrocontroller.net

Forum: PC Hard- und Software libs für LTspice, besonders PT100


Autor: markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

ich habe mir gerade LTspice heruntergeladen und möchte ein bisschen 
damit rumspielen.
Demnächst werde ich eine Messchaltung aufbauen, für die ich ein 
Termoelement alla PT100 benötige.

Woher bekomm ich weitere Bibliotheken für LTSpice und vorallem eine 
Bibliothek für den PT100 ?
Bzw. kann ich die PT100-Charakteristik in LTSpice irgendwo "einstellen" 
?

Danke für eure Hilfe :)

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ob es fertige Bibliotheken für PT100 gibt, weiß ich nicht.
Es ist allerdings auch nicht verkehrt, sich mal mit der Materie 
auseinander zu setzen. Dann kann man sich nämlich eigene Modelle selber 
basteln.
Zur Einführung mal der spannungsgesteuerte Widerstand:
http://www.ecircuitcenter.com/Circuits/vc_resistor...

Autor: Jürgen R. (hobbyloeter)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nimm doch einfach einen ganz normalen Widerstand und gebe den Wert als 
Parameter ein (s. Anhang).
Hier ist der Widerstand R1 das Pt100-Element. Dessen Wert ist ein 
Parameter. Deshalb Pt100 in geschweiften Klammern.
In der obersten Anweisung .PARAM... wird sein Wert definiert, hier ist 
die Pt100-Formel (s. Wikipedia http://de.wikipedia.org/wiki/Pt100) 
hinterlegt.
Die Variable TEMP ist die Temperartur. Hierfür mußt Du halt den 
gewünschten Wert angeben (z.B. .TEMP=100), oder du kannst die Simulation 
bspw. mit .STEP TEMP LIST 0 50 100 für verschiedene Werte 
"durchsteppen".

Sowas ähnliches hab ich mal für ein Pt1000-Element gemacht und es hat 
ganz gut funktioniert.

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Hilfesuchender (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry dass ich den alten Thread ausgrabe, aber ich komme nicht weiter.
Ich habe versucht das von Jürgen geschriebene umzusetzen.
Datei ist im Anhang.
Scheinbar akzeptiert er .step nicht als Kommando für eine Simulation. 
Wenn ich die Simulation starten will fragt er mich nach den Parametern.
Ist vermutlich ein einfacher Fehler, aber ich finde ihn nicht.

Autor: cmd (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Du benötigst noch ein 'Simulation Command' d.h. welche Analyse 
ausgeführt werden soll.

.op -> Arbeitspunkt (liefert in diesem Fall Spannung vs. Temperatur)
.tran 10m -> Spannung vs. Zeit = drei Kurven für die Temperatur

Autor: Hilfesuchender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank, jetzt klappts.
Ich dachte .step würde zum simulieren genügen. Denken ist nicht immer 
gut.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.