www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Netzteil: elektronische Regelung mit dem LM2575


Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich hoffe mir kann jemand helfen. Ich möchte mit dem LM2575-HV 
Buck-Converter, eine elektronisch Regelbares Netzteil bauen. Schaltbild 
siehe Anhang. Der Differenzverstärker ist so ausgelegt das bei einer 
Spannung von 2.667V > Ua=8V und bei 5V > Ua=15V wird. Nun hab ich das 
ganze Aufgebaut und funktioniert soweit auch, allerdings fängt das 
Ausgangssignal am LM2575 an zu schwingen. Der Spannungsrippel von Ua 
beträgt ungefähr 200mV. Normalerweise   ist am Ausgang des LM2575 ein 
Pulsweitensignal, bei mir ist das Signal allerdings mit einem 
abklingenden Sinus überlagert, auch die Frequenz ändert sich. Mein 
Differenzverstärker hat die Faktoren 0.2 und 0.6, also eigendlich klein 
genug um bei kleinen Spannungen nicht so doll zu verstärken. Das Problem 
tritt bei einem Strom von 200mA auf. Die Eingangsspannung beträgt 48V. 
Ich hab eine Spule von 600uH und ein Kondensator von 470uF am Ausgang.

Meine Frage ist nun, ist eine elektronische Regelung mit dem LM2575 
möglich. Wenn ja, wo könnte das Problem in meiner Schaltung liegen, dass 
sie anfängt zu schwingen?

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schalte mal je 1 nF zu R7 und R4 parallel!

Klausi

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich schon gemacht. Hab die Grenzfrequenz auf 1kHz gesetzt, hat 
leider nichts gebracht.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe sowas auch schonmal versucht, mit einem LM2576-Adj. Das 
Ergebnis war in etwa gleich. Ähnliches habe ich auch schon im Internet 
gelesen: Angeblich ist es sehr schwer bis unmöglich einen LM257x derart 
zu missbrauchen.
Das hilft dir zwar nicht weiter, aber du bist nicht allein mit dem 
Problem.

Autor: A. K. (prx)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Als Anregung eine Schaltung mit LM2575, die ich in der Steuerung von 
einem Pärchen grösserer Lüfter verwendet habe. Direkt mit PWM waren die 
zu laut, also gab's ein Redesign mit LM2575 als via Controller 
steuerbarer Gleichspannungsquelle.

Gesteuert wird über Gleichspannung an C3, vom Controller erzeugt via 
PWM. Regeln tut der LM2575 selber.

Regelschwingung konnte ich keine feststellen. Lastwechselreaktion usw 
habe ich mangels Bedarf nicht untersucht. Regelcharakteristik auch nicht 
- da die Rückkopplung von der Gleichstromeinkopplung und von C3 
beeinflusst wird kann sich da durchaus was anderes ergeben als im 
Datasheet steht.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> bei mir ist das Signal allerdings mit einem
> abklingenden Sinus überlagert, auch die Frequenz ändert sich.
Zu welchem Zeitpunkt kommt der abklingende Sinus?
Beim Abschalten des Transistors?
Mach doch mal ein Foto davon.
Ich denke, das ist normal, nur dein Layout ist evtl. etwas ungünstig ;-)

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bild im Normalbetrieb.

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier sieht man die Schwingung die entsteht.

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das gleiche nur anders Aufgelöst. Hier kann man die Frequenzänderung 
sehen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist das die Normaldarstellung vom Tek oder hast du den so eingestellt, 
dass er Einzelpunkte statt Interpolation darstellt?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermut das Oszi zeigt nicht das an, was wirklich passiert. Dieses 
Rauschen im letzen Bild dürfte die gleiche Schwingung wie ein Bild zuvor 
sein, nur durch eine zu geringe Samplerate wird Mist gemessen.
Die Sinusschwingungen sind normal, das ist das übliche Ausschwingen wenn 
die Spule zu klein ist, der Strom also 0 wird.
Nur das Fehler eines Impulses im letzen Zyklus ist nicht normal.

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist die Normaldarstellung, ist halt durch die Auflösung nicht als 
Sinusschwingung zu erkennen.

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Eingangsspannung beträgt 48V.
>Ich hab eine Spule von 600uH und ein Kondensator von 470uF am Ausgang.

Eingangs-C?

Ich sehe in Deinem Bild keinen LM2575. Vielleicht mal ganze Schaltung 
posten.

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hab noch eine Messung gemacht, dort sieht man das der Ausgang plötzlich 
für eine längere zeit abgeschaltet wird. Gut zuerkennen wo der Ausgang 
zusammenbricht gelbe Kurve.

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal die komplette Schaltung.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Benedikt
> das ist das übliche Ausschwingen wenn
> die Spule zu klein ist, der Strom also 0 wird.
 ??
Das mit dem stromlosen Schwingen mag ja sein, aber was hilft dir da eine 
"größere" Spule (ja, ich meine schon die Induktivität, nicht die Bauform 
;-)?

Wenn die eingelagerte Energie raus ist, dürfte doch auch eine große 
Spule/Induktivität schwingen, nur eben mit einer anderen Frequenz. Oder?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller wrote:
> Das mit dem stromlosen Schwingen mag ja sein, aber was hilft dir da eine
> "größere" Spule (ja, ich meine schon die Induktivität, nicht die Bauform
> ;-)?

Sie kann mehr Energie speichern.

> Wenn die eingelagerte Energie raus ist, dürfte doch auch eine große
> Spule/Induktivität schwingen, nur eben mit einer anderen Frequenz. Oder?

Ja. Aber die Zeit bis die Energie raus ist, wird größer, daher gibt es 
diese Lücke nicht.
Simuliers hiermit mal, da sieht man es schön:
http://schmidt-walter.eit.h-da.de/smps/abw_smps.html

z.B. mit 12V Eingangsspannung, 5V 100mA Ausgangsspannung und 1mH sieht 
man keine Lücken. Geht man auf wenige 100µH sieht man schön die 
Schwingung.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Basti (Gast)
Bist du sicher, dass diese SS36 eine schnelle Diode ist?
Die einzige Frequenzangabe, die im DB steht, sind 60Hz   :-o
Das sieht mir stark nach einer normalen Gleichrichterdiode aus.
Bei einer IRF 30BQ060 steht da z.B. wesentlich mehr (insbesondere "High 
Speed Operation").

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller wrote:

> Bist du sicher, dass diese SS36 eine schnelle Diode ist?

http://www.fairchildsemi.com/pf/SS/SS36.html

Schottkys sind immer schnell, sogar so schnell, dass es keine Zeitangabe 
im Datenblatt gibt (da sie quasi sofort sperren, lediglich die 
parasitären Kapazitäten verzögern das Sperren).

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> lediglich die parasitären Kapazitäten verzögern das Sperren
Also sind die dann doch nicht gleich schnell...

> dass es keine Zeitangabe im Datenblatt gibt
Aus dem DB der 30BQ060
CT Max. Junction Capacitance 180 pF VR = 5VDC (test signal range 100KHz to 1Mhz) 25°C
oder aus dem der 6CWQ03FN:
CT Typ. Junction Capacitance (Per Leg) 290 pF VR = 5VDC, (test signal range 100Khz to 1Mhz) 25°C
oder aus dem der MBRD630CT (Bild)

Kapazität... Zeit... Frequenz... Geschwindigkeit...
diese Angaben vermisse ich bei der SS36.

EDIT:
@ Benedikt
Würdest du die SS36 einsetzen?

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hab nochmal das Schaltverhalten des LM2575 aufgenommen. Man sieht hier 
deutlich die Schwingungen an der Stelle wo er auf 0V gehen sollte.

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab die Diode schon in einem anderen Netzteil verbaut und dort 
funktioniert das Netzteil mit der Diode problemlos.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller wrote:
> @ Benedikt
> Würdest du die SS36 einsetzen?

Ja. Schottky Dioden sind bei viel Strom, hohen Frequenzen und kleinen 
Spannungen eigentlich immer normalen Dioden vorzuziehen.

Die SS36 hat ganz grob 500pF (aus dem Diagramm entnommen). Bei 1A 
Sperrstrom macht das <1ns zum Umschalten, das sollte für ein mit 52kHz 
getaktetes Schaltnetzteil reichen.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Basti wrote:
> Hab nochmal das Schaltverhalten des LM2575 aufgenommen. Man sieht hier
> deutlich die Schwingungen an der Stelle wo er auf 0V gehen sollte.

Geht er ja auch. Zumindest solange die Spule den Strom weiter fließen 
lässt. Erst wenn diese leer ist, pendelt die Spannung in Richtung 
Ausgangsspannung, mit er das andere Ende der Spule verbunden ist.
Wie bereits gesagt, das ist normal, wenn die Spule zu klein ist.
Selbst in der Theorie ist das so:
Beitrag "Re: Netzteil: elektronische Regelung mit dem LM2575"

Das hier dagegen ist nicht normal:
http://www.mikrocontroller.net/attachment/43230/Au...
Wie man das allerdings weg bekommt, habe ich auch noch nicht 
rausgefunden.

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

dieses Verhalten kenn ich wenn der Laststrom zu gering wird und die 
Ladespule zu groß dimensioniert ist! Versuch mal eine kleinere 
Spule....oder belaste den Regler mal mehr, Versuchsweise!

Gruß

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stephan wrote:
> dieses Verhalten kenn ich wenn der Laststrom zu gering wird und die
> Ladespule zu groß dimensioniert ist!

Umgekehrt: Spule zu klein dimensioniert.

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, stimmt! Das gegenteil wollt ich schreiben, ...arbeite zu viel!!!

Verzeiht mir...

Gruß

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das dürfte aber eigentlich egal sein (wie schon mehrmals geschrieben), 
aus dem Datenblatt des LM2575:

INDUCTOR SELECTION
All switching regulators have two basic modes of operation:
continuous and discontinuous. The difference between the
two types relates to the inductor current, whether it is flowing
continuously, or if it drops to zero for a period of time in the
normal switching cycle. Each mode has distinctively different
operating characteristics, which can affect the regulator performance
and requirements.
The LM2575 (or any of the Simple Switcher family) can be
used for both continuous and discontinuous modes of operation.

continuous mode bzw. discontinuous mode sind hier beschrieben:
http://de.wikipedia.org/wiki/Discontinuous_Current_Mode

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die SS36 hat ganz grob 500pF (aus dem Diagramm entnommen)
Schlags kaputt, ein Diagramm :-o
Das habe ich übersehen :-/

Aber mit den Daten würde ich die SS36 auch nehmen.

> Das hier dagegen ist nicht normal:
>http://www.mikrocontroller.net/attachment/43230/Au...
> Wie man das allerdings weg bekommt, habe ich auch noch nicht rausgefunden.
Da funken irgendwie die ganzen OPAmps in die Regelschleife rein. Und da 
spilen in den Reglekreis alle Spulen mit rein, ob das gutgeht?
Wo genau sind die Messpunkte von
http://www.mikrocontroller.net/attachment/43230/Au...

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schalte doch einfach mal 20k an den Ausgang, damit das Potential besser 
meßbar ist.
dann vielleicht 100p oder so an FB probieren

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt ein 10k am Ausgang, damit funktioniert es auch, heißt das nun 
das die Induktivität zu klein ist?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> damit funktioniert es auch
Was funktioniert damit auch ?
Auch gleich wie ohne 10k-Widerstand?

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schuldigung genau das meinte ich.

Autor: Ahh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von 48V runter auf 8V ist schon etwas rabiat. Je groesser, das 
spannungsverhaeltnis, desto groesser inmH muss auch die Spule sein, da 
man gelueckten Betrieb ja vermeiden moechte. Der gelueckte Betrieb 
definiert den minimalstrom zu einer Spule mit Puls/Pausen Verhaeltnis, 
welches seinerseite durch das Spannungsverhaeltnis definiert ist. Hohe 
Spannungsverhaeltnisse sind eigentlich zu vermeiden, da die Spule auf 
den Ausgangsstrom gewaehlt werden muss, welcher das 
Puls/Pausenverhaeltnis mal groesser als den mittleren Strom sein muss. 
Gleichzeiting braucht man viele mH, benoetigt somit eine dicke, fette 
Spule fuer marginale Leistungen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@  Basti (Gast)
Dann bleibt also "nur" die unschöne Lastwechselreaktion.
Probiers mal ohne die Gleichtaktdrossel aus (wie im Bild).
Mach einfach nur Brücken drüber.
Was passiert?

Woher kommen die +12V?
Sind die stabil?

Warum machst du so eine aufwendige Beschaltung,
wenn du die Spannung sowieso nur mit Potis einstellst?

EDIT:
nochmal mit Bild

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Probiers mal ohne die Gleichtaktdrossel aus (wie im Bild)

wenn das nichts bringt, schalte mal eine Schottky in Reihe zur richtigen 
Drossel, 10k dranlassen und nochmal messen

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Einstellung erfolgt später über ein Mikrocontroller.

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab noch festgestellt das der - Eingang also pin 6 des 
Differenzverstärkers sehr empfindlich ist und sich darüber wohl 
Störungen einfängt.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist klar, dieser Wert wandert direkt zum Feedback Eingang. Häng da mal 
einen kleinen C nach Masse dran, um die Störungen zu unterdrücken.

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab den Differenzverstärker der die Ausgangsspannung 1 zu 1 
überträgt entfernt und nun funktioniert die Schaltung. Ich benötige den 
Differenzverstärker alleredings da ich am Ende einer Leitung die 
Spannung messen möchte und so die Widerstände der Leitung kompensieren 
will.
Weiß vielleicht jemand warum die Schaltung Schwingt, wenn dieser dazu 
geschaltet wird?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast R8 also direkt an den Ausgang angeschlossen?

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R8 ist noch vor dem Ausgangsfilter angeschlossen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Weiß vielleicht jemand warum die Schaltung Schwingt,
> wenn dieser dazu geschaltet wird?
Was schwingt denn?
Überschwinger in der Ausgangsspannung beim Lastwechsel?
Die Ausgangsspannung überhaupt?
Wo gemessen?

Wie wäre es, wenn du die innere Regelschleife mal einfach so laufen 
lässt, und den Fehler, der über den Differenzverstärker am Ende der 
langen Leitung gemessen wird, als Störgröße mit in den Regelkreis 
einkoppelst?

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,
danke nochmal für die Hilfe, dass ganze läuft nun. Ich hab die 
Widerstände nochmal um Faktor 20 kleiner gemacht und nun ist die 
Schaltung nicht so empfindlich gegen Störungen und läuft.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.