www.mikrocontroller.net

Forum: Compiler & IDEs Problem beim Debuggen mit AVRStudio


Autor: ape (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich möchte mein aktuelles WinAVR-Projekt gerne im AVRStudio debuggen.
Normalerweise kann man ja mit make coff bzw. extcoff das nötige cof
File erzeugen.
Jetzt kommt bei diesem Aufruf aber die Meldung:

avr-objcopy: specAna.elf: no recognized debugging information

es wird zwar ein cof-File generiert, wenn ich dieses aber im AVR-Studio
öffne sehe ich nur den nackten unkommentierten Assembler code.
Außerdem meldet AVRStudio:

Coordinator The object file does not contain source code information

Kann das dadran liegen das ich zusätliche Libs eingebunden habe (die
math library und die glcd library fürs nokia 6100 Display)?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.