www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fehler beim Builden eines Eclipse-C-Projektes (für ATmega8)


Autor: cbsma (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

ich habe ein kleines Problem beim builden eines C-Projekts. Ich 
programmiere in Eclipse mit dem Plugin von AVR einen ATmega8. Ich habe 
(wie im Tutorial beschrieben) alle Einstellungen vorgenommen, um Eclipse 
für diesen Zweck zu konfigurieren, aber wenn ich das Projekt builden 
will, erhalte ich die Fehlermeldung:

make: *** No rule to make target `main.o', needed by 
`ErstesTestprojekt.elf'

Ich glaube nicht, dass es am Code liegt, aber hier poste ich ihn 
trotzdem:
#include <avr/io.h>


int main(void)
{
DDRD |= _BV(PD2);

PORTD = _BV(PD2);
}

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.