www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PIC18F252 40MHz PLL RS232 leuft nicht


Autor: mischaka (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich Benutze PIC18F252 mit einen Quarz 10MHz mit  PLLx4.
Also Taktfrequenz 40MHz

RS232 mit 115200baud läuft falsch. Es kommt jede zweite Zeichen falsch 
an.

Es scheint das PLL des PICs unstabil läuft. Oder erzeugt Impulse 
unterschiedlicher länge

Der PIC arbeitet mit 3,3V

Hat jemand eine Lösung?

Autor: Compiler Error (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Hat jemand eine Lösung?
Bestimmt.

Autor: Zwirbeljupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der PIC18F252 ist bei 3.3V nicht für 40 MHz spezifiziert.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.