www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik atmega 2561 + USBasp/fischl.de


Autor: dk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wir können unter AVRstudio 4,15 mit dem USB programmiergerät, nachgebaut 
von fischl.de, nicht auf unsere einen atmega2561 zugreifen.

der programmieradapter funktioniert mit nem atmega8 und atmega16 
einwandfrei, nur der 2561 meldet sich nich.
natürlich haben wir MISO/MOSI/RST/SCK/5V/GND durchgepiept und alle ISP 
frequenzen mehrmals probiert.
wir hätten noch nen paralleladapter der unter ponyprog läuft, grad die 
aktuelle version von ponyprog installiert - da taucht der controler 
nicht in der liste auf :/

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der 2651 hat das ISP Interface nicht auf MOSI/MISO sondern auf PDI/PDO. 
Die Pins liegen auf PE0/PE1

Autor: dk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
echt?
na zum glück haben wir an den pins zufällig auch nen stecker dran.
welche verbindungen brauch ich denn dann zum programmieradapter.
reset + sck auch?

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bis auf PDI/PDO alles wie gehabt.

Autor: A. F. (artur-f) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, da bin ich auf sowas schon beim Atmega128 reingefallen, seit dem 
lese ich die Datenblätter :)

Autor: dk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dankeschön!
er redet mit uns :)

Autor: dk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jetzt hab ich noch nen problem.


Getting isp parameter.. SD=0x00 .. OKOK
Reading FLASH input file.. OK
Entering programming mode.. OK!
Erasing device.. OK!
Programming FLASH ..      OK!
Reading FLASH ..      OK!
WARNING: FLASH byte address 0x0000 is 0xFF (should be 0x0C).. FAILED!
Leaving programming mode.. OK!

diesen fehler kenn ich nur, wenn ein falsches device eingestellt ist.
wenn ich aber die signatur auslese sagt er mir, dass alles ok ist.

Entering programming mode.. OK!
Reading signature .. 0x1E, 0x98, 0x02 .. OK!
Leaving programming mode.. OK!

Autor: A. F. (artur-f) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal die ISP Frequenz runter zu setzen.

Autor: dk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab 1,8mhz 460khz und 115khz probiert -
kein erfolg

Autor: dk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
den flash auslesen klappt ohne fehler,
das hex file steht bis jetzt halt nur mit FFFF.. voll

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.