www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Stromversorgung Attiny13


Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nabend,

Ich sitze gerade hier und zerbreche mir an einer simplen Frage den Kopf:

Ich habe ein 230/6V Trafo. Dem Trafo folgend ein Gleichrichter und ein 
paar Kondensatoren zum Puffern.

Daran soll nun ein tiny13 Betreiben werden. Am besten bei ca 5V. Dieser 
geht unter gewissen Umständen in den "Power Down" Modus.

Wie ist sowas realisierbar?


Gruss Philipp

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit einem Siebelko, einem Spannungsregler 7805 und je einem 100nF an 
Ein- und Ausgang z. B.

Otto

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ein 6V-Trafo ist dafür aber nicht so toll - 9V wäre besser - alternativ 
ein Low-Drop Spannungsregler

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man "gemein" ist mit einem Widerstand den Strom begrenzen
und die Spannung mit einer Z-Diode (4V7) begrenzen.

Tiny13 1,8-5,5V

Nur wenn keine genauen Messungen nötig sind und keine weiteren
Verbraucher (mehrere LEDs, Display etc..).

gruß hans

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nun einen 12V trafo (effektiv sinds dann nach dem gleichrichter 
7V) dahinter den Rundgleichrichter dann 2 Kondensatoren dann den 7805. 
Da kommt eine Spannung von über 6V raus. Gut. Dachte ich mir, dass ich 
einfach ne Diode da reinpack. sinds dann auch ca 5,4 volt. Sofern ich 
dann aber einen Verbraucher anschliesse (also den mC  sowohl PIC als AVR 
, gleiches resultat), messe ich eine Spannung vonn 0,6V. PINbelegung 
habe ich beachtet. An den Ausgängen ist nun 0,15V zu messen (alle Ports 
auf ausgang und an).

Wo könnte der Fehler liegen?

mit freundlichem Gruss

ich :D

Autor: FRAGENSTELLER (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schaltplan???

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde mal sagen, du misst Müll. An einem 12V-Trafo solltest du nach 
dem Gleichrichter fast 17V haben ('1' vergessen?). Deine 
Fantasiespannungen nach dem Spannungsregler deuten auch auf eine 
schwingende Regelung hin. Sind deine Kondis vielleicht hin? Oder hast du 
ihn am Ende falsch angeschlossen?

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ikke wrote:
> Ich habe nun einen 12V trafo (effektiv sinds dann nach dem gleichrichter
> 7V)
Ne, wenn überhaupt sinds dahinter dann 12*Wurzel2 Volt.

> dahinter den Rundgleichrichter dann 2 Kondensatoren dann den 7805.
> Da kommt eine Spannung von über 6V raus.
Dann is da schon ein Fehler drin. Solltest du vorher wirklich 7V haben, 
ist das auch zu knapp für den 7805er.

Autor: Hannes Lux (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trollpost?

...

Autor: ikke (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Folgend der Schaltplan. Nich schön, hab gerade keine Möglichkeit zum 
richtigem Zeichnen habs mit Paint gemacht...

Autor: Beginy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also: Wo ist der Lade- Elko ? Muß gleich hinter den Gleichrichter !
Rote Diode überflüssig. Tiny falsch angeschlossen : Minus an 4, Plus an 
8 .

Autor: Hannes Lux (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Folgend der Schaltplan.

Wo lernt man Sowas? - Willst Du uns veralBÄRn??

Da ist so ziemlich alles falsch, was man falsch machen kann. Ich 
vermisse den Ladeelko hinter'm Gleichrichter und die 
Schwingneigungsunterdrückung am 7805 (im Datenblatt nachsehen). Und der 
Tiny13 braucht seinen Saft auch nicht an Pin 1 und 8 (im Datenblatt 
nachsehen)...

...

Autor: ikke (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bissl unscharf aber was solls... So sieht das von oben aus. Der 2te 
Trafo rechts tut momentan nichts zur Sache ;)

Autor: Beginy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..zeige mal die Verdrahtungsseite und etwas schärfer, bitte...

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuche es mir ja selber beizubringen. Beigebracht bis jetzt noch 
keiner, deshalb kommt man auch nur durch fragen weiter...

Auf der Skizze hab ich einen PIC sybolisieren wollen. Das mit dem AVR 
ist mir bekannt. Ladeelko hab ich noch nichts drüber gelesen :( 
Selbststudium ist nunmal nicht so leicht. Rote Diode ist deswegen rot 
weil sie ja eigendlich weg gelassen werden kann.

heisst das also als Resultat:

- Diode weg lassen
- Elko hinter den 7805 (470 iger ok?)


Gruss Ich :D

Autor: Beginy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...nein, vor den 7805 ! Also zwischen Gleichrichter und 7805 + an +, - 
an -,
Wieviel Strom mußt Du denn haben bzw. was willst Du alles anschließen an 
den 5 Volt Regler ? Für den Tiny allein reichen z.B. 47 uF , 25 Volt

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Angeschlossen soll nachher eigendlich ein tiny13 der einen Transistor 
durchschalten soll. Angeschlossen sind auch 2 von diesen 
Empfängermodulen für IR Signale. Solch ein TSOP.

Gruss ich

Autor: Beginy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..ja, gut, dann kannst Du auch den 470 uF Elko nehmen. Trotzdem scheint 
nach Deinen Spannungsangaben die Verdrahtung einen Fehler zu haben. 
Kontrollier die mal...oder der 7805 ist defekt..

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gut danke ersteinmal :)

Ich löte nachher nochmal, mess ein wenig und sag falls es geht bzw nicht 
geht

gruss ich

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sooo,hab jetzt ein wenig umgelötet.

Hab ich keinen Verbraucher dranne habe ich genau 5V am Ende des 7805.

9,3V, AC kommen vom Trafo.
Nach dem Gleichrichter sind es 10,4V DC (hat das seine Richtigkeit?)

naja und nach dem 7805 halt 5V DC

_

mit Verbraucher schaut das so aus:

4,8V AC aus dem Trafo

3,4V DC nach dem Gleichrichter

0,6V DC nach dem 7805

Woran könnte das noch liegen? :/

Autor: ikke (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier habe ich dann nochmal einen Anhang von der Rückseite :)

Die kleinen Kondensatoren hab ich erstmal gekappt. Sie waren durch einen 
Flüchtigkeitsfehler vor dem 7805...

gruss ikke

Autor: FRAGENSTELLER (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
autsch!

gleichrichter richtig angeschlossen?

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jetzt ja klaps

vielleicht sollte ich mal früher gucken was ich da bau...


ich werd morgen mal den 7805 austauschen. Hab nurnoch einen. Des 
weiteren hab ich noch 2 Spannungsregler aus der DDR. Mal gucken...

gruss ich

Autor: Beginy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieviel Strom zieht denn Dein Verbraucher ? Kurzschluß ? Mess mal !.

Du weißt, dass 230 V lebensgefährlich sind; verwendest Du wenigstens
einen Trenntrafo ?

Autor: Boxi Boxitec (boxi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh Mann, es gibt so schöne Steckernetzteile für unter 10€, da tun sich 
die Leute so nen Pfusch an...

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde sehr gerne ein schon fertiges Netzteil nehmen. Ich werd das 
Ganze nur nachher parallel zu einem Stromkreis (Lampenstromkreis) 
schalten, sodass hier zwar nicht ein Stück der Elektronik irgendwelchen 
Normen entspricht, aber es ist ja nur ein Versuchsaufbau :). Auf 230V 
habe ich ehrlich gesagt auch kaum Lust, da mit die Gefahr bewusst ist.

Ehrlichgesagt habe ich auch kaum Ahnung was ein Trenntrafo ist. Mir hat 
ein Student aus der Uni gesagt die müssten dafür gut sein 
(Physikstudent-Theoretiker, keine Ahnung in welchen Semester).

Die Leitungen bin ich mit einem Durchgangsprüfer schonmal durchgegangen. 
Die müssten eigendlich OK sein (jedenfalls habe ich keine 2 Leiterbahnen 
unfreiwilliger Weise zusammengelötet)


Gruss Philipp

Autor: avion23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hältst du von einem handynetzteil? Die Dinger haben im idle 30mW 
Verlustleistung, sind stabilisiert und sicher.

Autor: ikke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soo
Nu gehts endlich. Was habe ich gemacht? Ich hab die gleiche Schaltung 
nochmal "richtig" aufgebaut mit neuen Bauteilen. Auser dem 
Spannunsstabilisierer, der übrigends noch ging.


Danke für eure Hilfe

Philipp

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.