www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Einfache 12V PWM Schaltung


Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

ich bin schon den ganzen Tag auf der Suche nach einer einfachen 
Schaltung wie ich mit meinen AVR meine LED's mit 12V per PWM ansteuern 
kann.

Was für einen Mosfet kann ich denn am besten benutzen?
Ich hab es schon mit einen BUZ11 probiert aber ohne wirklichen Erfolg.

Hat jemand eine Schaltung um den BUZ11 zu ersetzen?

Gruß Brun

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm statt des Steinzeit-Buz11 einen FET der auch mit den 5V vom AVR 
durchschaltet.

Hier auf der Seite gibts eine Mosfet-Übersicht, wenn du eine 
Typ-Empfehlung willst. (Nach "Logic Level" oder niedriger Ugs(th) 
suchen)

Autor: Dieter S. (accutron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ernst,

warum soll denn der BUZ11 bei 5 V GS-Spannung nicht durchschalten? Die 
typische Schwellenspannung liegt bei 3 V.

@Brun: Wie sieht Deine Schaltung aus?

Dieter

Autor: Brun ... (brun)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal meine Schaltung.

Das komische ist, dass ein Kanal richtig funktioniert, einer überhaupt 
nicht und der andere macht was er will (mal nur an oder aus).

Hab ich evtl. einen dummen Fehler drin?

Gruß Brun

Autor: Dieter S. (accutron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wo liegen die LEDs? In der Leitung zu +12V? Vorwiderstand?

Dieter

Autor: Bohb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch doch mal die Gates mit Pull-Down Widerständen zu beschalten

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter S. wrote:
> Ernst,
>
> warum soll denn der BUZ11 bei 5 V GS-Spannung nicht durchschalten? Die
> typische Schwellenspannung liegt bei 3 V.

Klar, Vgs(th) liegt zw. 2.1 und 4V, bei Id=1mA. d.H. im Schnitt ist der 
Buz11 bei 4V grad mal soweit durchgeschaltet, dass ein Drain-Strom von 
einem mA fliesst. Klar, eine LED sieht man damit schon leuchten...

Weiter hinten im Datenblatt wirds dann deutlicher, z.B. in den Graphen 
zu den Output-Characteristics. Unter 8V Ugs würde ich da keinesfalls von 
"durchschalten" sprechen.

Jetzt kommt noch die PWM ins Spiel, mit (etwas überdimensionierten) 
100Ohm Gate-Widerstand, und schon sieht das Gate die meiste Zeit viel 
weniger als 5V.

Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die LEDs sind zwischen 12V und den BUZ11 mit Vorwiederstand.

Das mit den Pulldown Wiederständen werd ich mal probieren.
Was für einen Wert am besten?

100 Ohm zwischen Gain und AVR sind okay?

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Brun Von der gönne wrote:

> 100 Ohm zwischen Gain und AVR sind okay?

Hängt davon ab, mit welcher Frequenz du deine PWM fährst. Ich würde eher 
so 10-12 Ohm nehmen.

Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wäre ein IRF 530 besser geeignet?
Was für ein Vorwiederstand wäre da dann angebracht?

Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die PWM Frequenz liegt bei 100Hz.
Momentan benutze ich da noch SoftPWM.

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei 100Hz sind die 100 Ohm auch ok.

der IRF530 ist auch besser als der BUZ11, aber eigentlich eher ein 
Hochspannungs-Typ (Uds max 100V)
in der Mosfet-Übersicht wäre der IRLZ34N die nächstbilligere, 
passende Variante.
Wenn du aber von den IRF530 eh welche rumliegen hast, vorher mal ins 
Datenblatt schauen…

Autor: Dieter S. (accutron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ernst Bachmann wrote:
> Dieter S. wrote:
>> Ernst,
>>
>> warum soll denn der BUZ11 bei 5 V GS-Spannung nicht durchschalten? Die
>> typische Schwellenspannung liegt bei 3 V.
>
> Klar, Vgs(th) liegt zw. 2.1 und 4V, bei Id=1mA. d.H. im Schnitt ist der
> Buz11 bei 4V grad mal soweit durchgeschaltet, dass ein Drain-Strom von
> einem mA fliesst. Klar, eine LED sieht man damit schon leuchten...


Na ja, ganz so dramatisch ist es nicht. Bei 4 V fließt ein wesentlich 
größerer Strom. In Fig. 5 kann man da etwa 2 A ablesen. DS-Abfall liegt 
ca. bei 0,2 V. Sollte das nicht stimmen, hätte ich meinen unzähligen 
BUZ11-Schaltuzngen schon mächtig Ärger bekommen.

>
> Weiter hinten im Datenblatt wirds dann deutlicher, z.B. in den Graphen
> zu den Output-Characteristics. Unter 8V Ugs würde ich da keinesfalls von
> "durchschalten" sprechen.
>
> Jetzt kommt noch die PWM ins Spiel, mit (etwas überdimensionierten)
> 100Ohm Gate-Widerstand, und schon sieht das Gate die meiste Zeit viel
> weniger als 5V.

Das kommt ja auch auf die PWM-Frequenz an.

Dieter

Autor: Dieter S. (accutron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bruns:

Achte mal auf die Rechtschreibung: Widerstand.

Hast Du mal die Ansteuerung von den Ports überprüft?

Falls diese passt, könnte auch der MOSFET defekt sein.


Dieter

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter S. wrote:
>
> Na ja, ganz so dramatisch ist es nicht. Bei 4 V fließt ein wesentlich
> größerer Strom. In Fig. 5 kann man da etwa 2 A ablesen. DS-Abfall liegt
> ca. bei 0,2 V. Sollte das nicht stimmen, hätte ich meinen unzähligen
> BUZ11-Schaltuzngen schon mächtig Ärger bekommen.

Klar, da hast du schon recht, aber beim TE scheint es ja doch Probleme 
zu geben.
Was mich hauptsächlich stört, ist das nicht auszurottende Gerücht der 
BUZ11 wäre ein TTL-Logic Level FET.
In dieser Schaltung wird er halt WEIT unter seinen Möglichkeiten 
betrieben, und ein viel kleinerer, aber eben passender FET könnte den 
selben Job erledigen.

>>
>> Weiter hinten im Datenblatt wirds dann deutlicher, z.B. in den Graphen
>> zu den Output-Characteristics. Unter 8V Ugs würde ich da keinesfalls von
>> "durchschalten" sprechen.
>>
>> Jetzt kommt noch die PWM ins Spiel, mit (etwas überdimensionierten)
>> 100Ohm Gate-Widerstand, und schon sieht das Gate die meiste Zeit viel
>> weniger als 5V.
>
> Das kommt ja auch auf die PWM-Frequenz an.

Ja, wie oben nachgefragt. Bei 100Hz sind 100 Ohm schon ok, und die Zeit 
sollte schon reichen, um das Gate zu laden.

Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe grad mal das ganze mit meinen STK500 aufgebaut.
Da hatte das ganze soweit schonmal funktioniert.

Eben gingen noch zwei von meinen BUZ11. Nun ist es nur noch einer und 
ich habe hier etwa fünf kaputte liegen. Sind die so empfindlich? Was 
soll denn da kaputtgehen?

Autor: accutron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bruns,

möglicherweise ist die GS-Isoschicht zerstört durch ESD. Kleiner 
Probeaufbau würde das schnell zeigen, ggf. auch Ohmmeter.

Dieter

Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke,

ich hab mir jetzt erstmal ein paar andere Typen bestellt.


Wie kann ich das denn messen? Und wie kann ich das verhindern?

Ich vermute, dass mein billig China Netzteil daran schuld ist.

@Dieter
Bitte nicht böse nehmen, aber mein Name wird ohne "s" geschrieben.
Ich danke dir auf jeden Fall für deine bisherige Hilfe.

Autor: Dieter S. (accutron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Brun Von der gönne wrote:


> Wie kann ich das denn messen? Und wie kann ich das verhindern?

Am besten bis zum Einlöten alle drei Anschlüsse z. B. per dünnem 
Schaltdraht verbinden. Man kann auch Stanniolfolie nehmen.


> Ich vermute, dass mein billig China Netzteil daran schuld ist.

Das kann man erst sagen, wenn genau feststeht, wie Du gearbeitet hast.

> Bitte nicht böse nehmen, aber mein Name wird ohne "s" geschrieben.

Oh Verzeihung. Das war nicht meine Absicht.

Dieter

Autor: Brun ... (brun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die schon gegen statische Aufladung empfindlich?
Das würde so einiges erklären...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.