www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik falsche Fuse Bits gesetzt


Autor: Benjamin T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hier ist mal wieder jemand der es geschafft hat die CLK FUSE bits falsch 
zu setzten und seinen Mikro Controler tot zu machen.

Ich hab genauer gesagt einen ATMEGA 664 PU und das Pollin 
Evaluationsboard. (http://www.pollin.de/shop/downloads/D810038B.PDF).

Ich habe die folgenden Fuse bits gesetzt 0x60 (LOW) 0x99(HIGH) 
0xFF(Extd) bzw eben CKSEL0-3 programed.

Danach ging gar nix mehr :(

Jetzt hab ich mir schon wie hier beschrieben 
(http://www.klaus-leidinger.de/mp/Mikrocontroller/m...) 
einen Takterzeuger mit 4MHz gebaut und an XTAL1 angeschlossen.
Außerdem hab ich den Quarz Q3 (siehe Boardbeschreibung) ausgelötet, 
sodass jetzt wirklich nur noch der Takt des Quarzoszillators anliegt.

Leider erkennt avrdude den Controler immer noch nicht.

Hat noch jemand einen Tip für mich was ich noch probieren könnte?

Danke

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jezt nicht das Datenblatt da welche Taktquelle ist den CKSEL0-3 
programed? Wenn du nämlich auf Lowfrequency RC gefused hast müßtest du 
es mal mit ner RC kombi versuchen und AVR dude anweisen GAAAAANZ langsam 
zu programmieren.

Autor: Benjamin T (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn ich das aus dem Datenblatt 
(http://www.atmel.com/dyn/resources/prod_documents/...) richtig 
abgelesen hab, hab ich auf External Clock gefused.
Oder sehe ich das falsch?

Falls nicht: wie kann ich mit avrdude langsam programmieren? avrdude 
erkennt nicht mal dass da ein Mikrocontroler dran hängt.

Autor: Benjamin T (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also mir ist noch was eingefallen:
Mein oszillator schwingt mit 4Mhz. Ich habe aber noch dieses CHKDIV8 
FUSE BIT gesetzt. Heisst das, dass meine Taktfrequenz dann eigentlich 
nur noch 0,5Mhz beträgt und das das dann zu gering ist??

Autor: Benjamin T (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem hat sich gelöst. Ich hab mir mit Hilfe eines anderen 
Controlers einen Takt erzeugt. Dann gings ...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.