www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Blue Nice Com IV (BNC4) im SPP-Modus


Autor: CJ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich verwende das Bluetoothmodul Blue Nice Com IV von Amber Wireless.
Mein Versuchsaufbau sieht folgendermaßen aus: (SSP)

                            Downlink
                            ------->
    PC1-Bluetoothdongle )))          ((( BNC4-MAX232-PC2
                            <-------
                             Uplink

Es wird keine Flusssteuerung verwendet, d.h. die Pins RTS und CTS am
BNC4 sind überbrückt. Daten werden über das Tool HTerm von PC1 nach
PC2 gesendet und umgekehrt.

Es besteht nun folgendes Problem:
Downlink: es wird lediglich das erste Sequenz gesendet und danach
kommt nichts mehr an.
Uplink: es werden Sequenzen gesendet, jedoch werden determiniert
empfangen, d.h. Sequenz1 kommt erst an wenn Sequenz2 abgeschickt
wurde, Sequenz2 erst wenn Sequenz3 abgeschickt wurde, usw.
Ist das irgendwie ein Buffer-Problem?

Hat dieses Problem schon einmal jemand gehabt,
wenn ja, wie löst man es?

Schon mal vielen Dank für euere Hilfe!

Gruß
CJ

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.