www.mikrocontroller.net

Forum: Platinen Temperatursensor


Autor: Peter K. (chrisstar)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, habe eine Schaltung für einen Temperatursensor gebaut. Wollte mal 
fragen ob diese Schaltung, so wie ich sie gemacht habe, richtig ist!?

Danke für eure Hilfe

mfg peter

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, als erstes fällt mir ein: Falsches Forum, hier gehts hauptsächlich 
ums Platinen ätzen/erstellen.
Als zweites: Wo zur Hölle ist der Temperatursensor? Sind vier 
Sieben-Segment-Anzeigen an einem Mikrocontroller und wo ist der Sensor?

Autor: Gerry L. (gerrylenz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael wrote:

> Als zweites: Wo zur Hölle ist der Temperatursensor? Sind vier

Kuckst Du an PD6 AD590 :)

Autor: Peter K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser wird an IC3 angebunden

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter K. wrote:
> Dieser wird an IC3 angebunden

und du misst die temperaturabhängige Analogspannung mit einem digitalen 
Eingang?

Wo ist die 5V-Versorgung? Du hast einen Spannungsregler, aber die 5V 
gehen davon nirgends ab?

und warum jetzt doch ein Trafo? Ist doch völliger Overkill...

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der AD590 liefert einen Strom proportional zur Temperatur und hat
nur 2 belegte Anschlüsse!

Normal ist z.B. Versorgung an Pin+ Widerstand 1K zwischen Pin-
und GND und Spannung an Pin- messen (=Spannungsabfall am Widerstand).
Ergibt 1mV/K.

Noch normaler ist Abgleich und Kompensation.

Aber wenn man sowiso nur digital auswertet was falsch
angeschlossen ist stört das nicht!

gruß hans

Autor: Peter K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der temp.sensor hat einen A/C wandler integriert. Natürlich gehen die 5V 
ab.

Unser Lehrer möchte lieber einen Trafo als Quelle

Autor: Peter K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist also die Schaltung soweit in Ordnung?

Autor: Abwasch König (abwaschkoenig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es sein, das der Spannungsregler falsch herum eingezeichnet ist? 
Ich kenne die Dinger nur mit Eingang=Pin 1...

Autor: Peter K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sollte normal stimmen:
VO... Out
VI... In

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Ladeelko C1 ist vielll zu klein.
Mach da mal so um die 1000uF rein.

Gruss Helmi

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter K. wrote:
> Der temp.sensor hat einen A/C wandler integriert.

wenn ich in das Datenblatt vom AD590 schaue steht da nix davon...

> Natürlich gehen die 5V ab.

wo bitte? der Ausgang vom 7805 geht soweit ich das sehen kann nur zum 
Pin 1 vom AD590

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Elkos mögen passen (kommt auf den entnommenen Strom an) was aber 
fehlt sind die Kerkos am Spannungsregler zum Filtern hochfrequenter 
Störungen. Am µC sind die ja dran. Den AD590 hatte ich am Anfang gar 
nicht gesehen, habsch wohl überlesen. Wenn ich jetzt mal vom Datenblatt 
ausgehe das ich mir angeschaut habe dann hat der aber nur zwei Pins und 
keine drei, was aber nix heißen muss. In den Appnotes ist als 
Beschaltung u.a. folgendes drin: Pin 1 an Vcc, von Pin 2 geht es an ein 
100 Ohm Poti das wohl zum Abgleich dient und vom Poti gehts dann mit 
einem 950 Ohm Widerstand gen Masse. Pin 2 des AD590 ist dann der Ausgang 
welcher 1 mV/K bringt. Naja, das ist zumindest die einfachste 
Beschaltung. Was mich hier hauptsächlich stört ist die fehlende 
Möglichkeit eines Abgleichs. Willste das im µC machen?

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael wrote:

>  Willste das im µC machen?

mich würde halt immer noch interessieren, wie er diese Analogspannung 
mit einem digitalen Eingang vernünftig messen will...

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, vielleicht hat er ja eine Idee das Signal des Ad590 mittels des 
ICP-Anschlusses auszuwerten aber wer weiß ;)

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Elkos mögen passen (kommt auf den entnommenen Strom an)

Bei 4.7uF ist das aber nicht sehr viel Strom

Autor: memmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
immernoch die parallel geschalteten Trafowicklungen???

Autor: Peter K. (chrisstar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Temperatursensor hat einen eingebauten A/D Wandler.

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter K. wrote:
> Der Temperatursensor hat einen eingebauten A/D Wandler.

seufz dann zeig mir bitte mal das Datenblatt von einem AD590 mit 
Wandler...

Autor: Peter K. (chrisstar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier: 
http://www1.at.conrad.com/scripts/wgate/zcop_at/~f...


Das mit dem AD590 ist von Eagle raus, da  kein anderer Sensor gefunden 
wurde

Sensor: DS1820

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter K. wrote:
> Hier:
> 
http://www1.at.conrad.com/scripts/wgate/zcop_at/~f...
>
>
> Sensor: DS1820

und warum ist in deinem Schaltplan dann ein AD590 eingezeichnet??

Autor: Peter K. (chrisstar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da der andere nicht im Eagle gefunden wurde, aber die Belegung identisch 
ist. Hab ihn vergessen umzubennen, sry

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter K. wrote:
> Da der andere nicht im Eagle gefunden wurde, aber die Belegung identisch
> ist

langsam komm ich mir echt verarscht vor...der DS1820 hat drei Pins 
belegt, der AD590 nur zwei, sie funktionieren komplett 
unterschiedlich...

und dein µC hängt noch immer nicht an der Spannungsversorgung, da hängt 
nur dein Sensor dran

Autor: Peter K. (chrisstar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieso soll der uC nicht an der Spg.versorgung hängen? Wird ja mit einem 
5V Pfeil gekenntzeichnet

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter K. wrote:
> Wieso soll der uC nicht an der Spg.versorgung hängen? Wird ja mit einem
> 5V Pfeil gekenntzeichnet

dein Regler aber nicht...

Autor: Peter K. (chrisstar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh... stimmt. Danke!

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Bei 4.7uF ist das aber nicht sehr viel Strom

Yo, könnte so für geschätzte 10 mA reichen. Da aber die 
7-Segment-Anzeigen mit drin hängen wirds eng. Vielleicht ist der Ripple 
ja nicht sehr groß sodass es passt. Lieber gleich einen 220µF oder 470 
µF Elko reinkloppen.

Autor: Peter K. (chrisstar)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hab nun meine Schaltung überarbeitet... Seht ihr noch irgendwo Fehler 
hab schon öfters geschaut aber nichts mehr gefunden!

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
memmi wrote:
> immernoch die parallel geschalteten Trafowicklungen???
lol. mensch, junge...

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lustige Symbolvielfalt. Was das soll, weiß wohl auch nur du?
Übrigens sind nicht beide Anoden-Anschlüsse and en 7Segment Anzeigen 
angeschlossen.

Autor: Kai G. (runtimeterror)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Benötigt der Reset nicht einen Pull-up? Oder braucht der Tiny keinen?

btw: Bildformate

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.