www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik [Laie] Problem mit Lernpaket von Franzis (IC)


Autor: Adi A. (mateit)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bin >noch< absoluter Laie in Sachen Elektronik und das soll sich nun 
ändern.
Dazu habe ich mir gestern das "Lernpaket Elektronik mit ICs" vom Franzis 
Verlag gekauft und mich auch gleich hier registriert ;).
Heute habe ich angefangen die Doku zu lesen und natürlich habe ich 
nebenbei die jeweiligen Schaltungen aufgebaut.
Auf Seite 36 der Doku wird das Schaltbild eines Leuchtfeuers 
(http://de.wikipedia.org/wiki/Leuchtfeuer) dargestellt - natürlich 
sofort nachgebaut ;)
Der IC ist ein LM 324 N 
(http://www2.produktinfo.conrad.com/datenblaetter/1...).

Nun aber zu meinem Problem:
In der Anlage seht ihr das Schaltbild, das ich grade fix in Target 
erstellt habe (einfach aus dem Buch "Lernpaket Elektronik mit ICs" von 
Franzis Doku Seite 36 Abb. 5.1.: Schaltbild Leuchtfeuer heraus).

Hier seht ihr meinen funktionierenden Aufbau: 
http://img18.imageshack.us/img18/1401/07032009428.jpg

Wenn ich allerdings meine Schaltung so verändere wie es der obige 
Schaltplan darstellt, funktioniert das Ganze aber leider nicht mehr.

Was ich verändert habe: Ich habe die LED gedreht - Kathode an Pin 10 des 
IC gesteckt und Anode an Spannungsversorgung (rote Leitung). (Also nicht 
Anode an Pin 10 und Kathode an Erde (schwarze Leitung) - wie es das 
Schaltbild vorschreibt).

Nun möchte ich natürlich wissen wieso das so ist. Ich kann mir einfach 
nicht vorstellen, dass die Schaltbilder in dem Buch vorher nicht 
erfolgreich getestet wurden.

Was mache ich falsch bzw. wo liegt der Fehler?


Danke schon im Voraus.

Mit freundlichen Grüßen
MatEIT

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matze,

hab die Schaltung gerade mal simuliert und sie funktioniert nur mit der 
von dir beschriebenen Änderung richtig.
Led leuchtet: lang - kurz - kurz - kurz

Angenommene Betriebsspannung: 5V

Was der linke Teil macht weißt du?

So funktioniert ein OPV = Operationsverstärker:
Ein OPV schaltet den Ausgang auf 5V wenn die Spannung am pos. Eingang 
höher ist als am negativen.
Der Ausgang wird 0V wenn die Spannung am negativen Eingang höher ist als 
am positiven.

Rechter Teil der Schaltung:

Durch die Led nach +5V wird der pos. Eingang des OPV auf 3V gezogen:
5V - 1,8V = ~3V (1,8V ist die Flussspannung der Led)

Somit ist die Schalt-Schwelle auf 3V. D.h. wenn der negative Eingang die 
3V unterschreitet schaltet der OPV seinen Ausgang auf 5V.

Nun passiert folgendes: Der Ausgang des OPV geht auf 5V.
Über den 470ohm Widerstand wird der pos. Eingang auf ~4,8V gezogen. 
(Spannungsteiler: 10kohm/(10kohm + 470ohm)*5V =4,77V )

Der Kondensator ist weiterhin auf 3V wird aber langsam über den 1Mohm 
Widerstand aufgeladen.
Übersteigt dann der Kondensator die 4,8V schaltet der Ausgang wieder auf 
0V zurück. Die Led geht an.
Der Kondensator ist weiterhin auf 4,8V und wird langsam über den 1Mohm 
entladen bis er 3V erreicht hat und das Spiel von vorne losgeht.

Hoffe ich konnte dir zur Erleuchtung beitragen.
Am Besten du überlegst dir es auch noch mal komplett durch.
Wenn du meinst es verstanden zu haben, beschreibe die Vorgänge mit der 
Diode nach Minus.

mfg
      Esko

Autor: Adi A. (mateit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alex,
vielen Dank für diese ausführliche Hilfe!

Was allerdings nun der linke Teil der Schaltung bewirkt weis ich nicht - 
da hällt sich die Doku bedeckt. Auch habe ich erst mit deiner obigen 
Erklärung des OPV diesen verstanden! Danke nochmals.

Die Diode verwirrt mich etwas - denn da wir ja mit 
Gleichstrom/Gleichspannung arbeiten, "blockt" die Diode an ihrer Kathode 
rechts einfallende Ströme. Oder irre mich da? (muss mich ja irren sonst 
könnte man diesen Teil der Schaltung ja weglassen ;) )
Weiterhin komisch finde ich, dass der komplette linke Teil der Schaltung 
geerdet ist, also keine Spannungsversorgung besitzt. Gerade im 
Zusammenhang mit der Diode finde ich das sehr verwirrend. Die Doku hällt 
sich wieder bedeckt... -.-
Auch der Fehler mit dem Schaltbild macht mir die Doku noch 
unverständlicher.

Ich habe den kompletten linken Teil der Schaltung mal entfernt - jetzt 
blinkt die LED die ganze Zeit.



Mit freundlichen Grüßen
Matthias

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Matze Qpunkt wrote:
> Die Diode verwirrt mich etwas - denn da wir ja mit
> Gleichstrom/Gleichspannung arbeiten, "blockt" die Diode an ihrer Kathode
> rechts einfallende Ströme.
Richtig.
Die Diode lässt nur Strom von links nach rechts zu.

> Weiterhin komisch finde ich, dass der komplette linke Teil der Schaltung
> geerdet ist, also keine Spannungsversorgung besitzt.
Da liegst du einem Irrtum auf.
Die Spannungsversorgung ist an die OPVs angeschlossen.
Deren Ausgänge haben dann manchmal 5V, wie oben beschrieben.

> Ich habe den kompletten linken Teil der Schaltung mal entfernt - jetzt
> blinkt die LED die ganze Zeit.
Erkläre doch mal mit eigenen Worten was die linke Schaltung macht.
Wenn du das raus hast kannst du dir überlegen was die Diode macht.

mfg Esko

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Blinker ist nicht unbedingt ein Leuchtfeuer.
Der linke Teil soll bestimmt eine andere Frequenz haben (niedrige) als 
der rechte (hohe). Über die Koppeldiode wird die schnelle Oszillation 
des rechten Teils kurzzeitig gestoppt, so daß ein unterbrochene 
Blitzfolge erscheint.
Stimmen denn die Bauteilwerte?

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wolf wrote:
> ...
Richtig, nur sollte er das selbst rausfinden.

Die Bauteilwerte sind richtig, es funktioniert ja.
Nur muss man die Led nach Masse schalten und nicht nach Plus.

Autor: Adi A. (mateit)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich will ehrlich sein - das hätte ich nicht rausbekommen, aber gut das 
ich es jetzt weis ;)

Alexander Schmidt wrote:
>...
> Nur muss man die Led nach Masse schalten und nicht nach Plus.

Also Kathode nach Masse? So habe ich es zwar gemacht, allerdings ist mir 
gerade aufgefallen, dass meine 9V Blockbatterie kochend heiß wird (ich 
schätze 50°C) -  ist sicher nicht im Sinne des Erfinders, oder? ^^
Demnach kann meine Lösung ja nicht richtig sein :-(( Der Schaltplan nach 
Doku funktioniert aber, wie oben schon beschrieben, nicht.

Desweiteren habe ich gerade mal versucht hinter die komplette Systematik 
OPV zu steigen. Dazu habe ich, das im Anhang dargestellte Schaltbild 
aufgebaut. Über R1 (470 Ohm) fällt eine Spannung von 0 ab?! Am hinteren 
Ausgang des OPV (wie wird dieser genannt?) fällt, gegen Masse gemessen, 
eine Spannung von 8V ab. Was mich mal wieder verwundert, denn eigentlich 
söllte ja entweder verstärkt werden bzw. die 9V durchgeschaltet werden.

Mittlerweile glaube ich, dass die Doku nicht für absolute Anfänger 
gedacht ist. Es werden lediglich einige Beispiele gezeigt - direkt 
erläutert wird nur unzureichend.

Gibt es eine gute Anleitung, die sogar ein blutiger Anfänger verstehen 
kann? Eine in der nicht nur von Mit- und Gegenkopplung, invertierenden 
und nichtinvertierenden OPVs gesprochen wird. Sozusagen alles von Grund 
auf ;) Wiki hilft beispielsweise nicht :-(

Danke schon jetzt für die Hilfe :-)

Gruß
Matthias

Autor: Adi A. (mateit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann leider meinen obigen Beitrag nicht mehr editieren, daher muss 
ich einen Neuen erstellen.


Gerade eben habe ich eine sehr gute Anleitung zum Thema OpAmp gefunden:
http://www.elektronik-kompendium.de/sites/bau/0209092.htm
Wer ebenfalls Anfänger ist, söllte dort mal etwas lesen :-)


Gruß
Matthias

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim Bild oben:
In die Eingänge eines OPV fließt kein Strom hinein. Somit ist auch der 
Widerstand wirkungslos.

Autor: Adi A. (mateit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber wieso fließt kein Strom? Ist der Innenwiderstand des OpAmp zu 
groß?!

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ist der Innenwiderstand des OpAmp zu groß?!

Das macht gerade einen guten OpAmp aus: Je höher der Eingangswiderstand
(bzw. je kleiner der Eingangsstrom), umso besser. Beim LM324 fließt der
Eingangsstrom, wenn überhaupt, nicht in die Eingänge hinein, sondern aus
den Eingängen heraus. Da du aber noch am Anfang deiner Elektroniker-
karriere stehst, ist es völlig in Ordnung, den Eingangsstrom einfach zu
vernachlässigen.

Autor: Adi A. (mateit)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

heute ging es mal wieder weiter in Sachen OpAmp :-)
Da es sich immer noch um den im Lernpaket enthaltenen Microprozessor 
LM324N handelt, habe ich keinen extra Thread erstellt.


Ich habe heute Einiges simulieren lassen.
u.a. > siehe angehängte Grafik.

So wie es der Schaltplan darstellt, wird eine Spannung V = 1,2 MV 
gemessen. Da am nichtinvertierenden Anschluss 24 V und am invertierenden 
12 V anliegen. -> (24 V - 12 V)*100dB (Gleichspannungsverstärkung, DC 
Voltage Gain - aus Datenblatt entnommen - 
http://www2.produktinfo.conrad.com/datenblaetter/1...) 
= 1,2 MV
So weit ist bei mir alles klar.

Was ich allerdings nicht verstehen ist, dass eine Spannungsänderung an 
V1 keinerlei Wirkung auf die Verstärkung hat.
Weiterhin komisch finde ich die Tatsache, dass sobald ich V2 und V3 
gleichsetze eine Spannung von 200 V gemessen wird? Wo kann ich das aus 
dem Datenblatt entnehmen bzw. wie kann ich das berechnen?

Vielen Dank schon im Voraus.

Mit freundlichen Grüßen
Matthias

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> So wie es der Schaltplan darstellt, wird eine Spannung V = 1,2 MV
> gemessen. Da am nichtinvertierenden Anschluss 24 V und am
> invertierenden 12 V anliegen.

Zum Glück hast du die Schaltung nicht real aufgebaut, sonst würden jetzt
Blitze durch den Raum schießen und du befändest dich in größter
Lebensgefahr ;-)

Spaß beiseite:

Was das von dir verwendete Simulationsmodell wohl nicht weiß, ist, dass
die Ausgangsspannung immer innerhalb der Betriebsspannung liegt. Beim
LM324 kann sie sich bei 5V Betriebsspannung etwa zwischen 0V und 3,5V
bewegen. In deinem Beispiel mit V2>V3 würde die Ausgangsspannung also
bei etwa 3,5V (dem oberen "Anschlag") liegen. S. Datenblatt "Output
Voltage High/Low Limit".

Auch die Eingangsspannungen der Schaltung liegen außerhalb des
sinnvollen Bereichs. Dieser reicht bei einer 5V-Versorgung von -0,3V bis
+3,7V. S. Datenblatt "Input Common Mode Voltage Range".

> Was ich allerdings nicht verstehen ist, dass eine Spannungsänderung an
> V1 keinerlei Wirkung auf die Verstärkung hat.

Änderungen der Betriebsspannung sollten bei einem OpAmp kaum einen
Einfluss auf die Ausgangsspannung haben, solange diese Spannungen beide
in dem für korrekten Betrieb zulässigen Bereich liegen. S. Datenblatt
"Power Supply Rejection".

> Weiterhin komisch finde ich die Tatsache, dass sobald ich V2 und V3
> gleichsetze eine Spannung von 200 V gemessen wird?

Die Eingänge eines OpAmp sind nie völlig symmetrisch. Die Spannungs-
differenz, die an den Eingängen anliegen muss, um am Ausgang 0V zu
erhalten, nennt man Offsetspannung und liegt beim LM324 typisch bei 2mV.
Eine Spannungsdiffernz von 0 liegt also aus Sicht des OpAmps um 2mV
daneben. Diese 2mV werden um 100dB (oder Faktor 10⁵) verstärkt, was die
200V ergibt, wobei die 200V am Ausgang aus den o.g. Gründen natürlich
nicht erreicht werden. S. Datenblatt "Input Offset Voltage".

Autor: Adi A. (mateit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
yalu wrote:
>> So wie es der Schaltplan darstellt, wird eine Spannung V = 1,2 MV
>> gemessen. Da am nichtinvertierenden Anschluss 24 V und am
>> invertierenden 12 V anliegen.
>
> Zum Glück hast du die Schaltung nicht real aufgebaut, sonst würden jetzt
> Blitze durch den Raum schießen und du befändest dich in größter
> Lebensgefahr ;-)


hehe - ich weis nicht was du gegen 1 oder 2 MV auf einer Steckplatine 
aus einem Lernpaket hast ^^

-------------------------

Vielen Dank für deine Ausführungen, diese haben mir wirklich geholfen!
Gerade das mit den 200 V ist jetzt auch logisch.


Nochmal was zur Spannungsdifferenz: Wenn ich also 5V an einen Anschluss 
und 5,002 V bzw 4,998 V an den Anderen anschliesen würde, bekäme ich 
eine Ausgangsspannung von 0 V (unabhängig von der Betriebsspannung)?

Danke nochmal.

Gruß
Matthias

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nochmal was zur Spannungsdifferenz: Wenn ich also 5V an einen
> Anschluss und 5,002 V bzw 4,998 V an den Anderen anschliesen würde,
> bekäme ich eine Ausgangsspannung von 0 V (unabhängig von der
> Betriebsspannung)?

Zumindest in der Simulation (wahrscheinlich). In der Realität solltest
du darauf achten, dass die Eingangsspannungen mindestens 1,7V unterhalb
der positiven Versorgungsspannung liegen, sonst funktioniert der OpAmp
nicht richtig. In der Realität wird die Offsetspannung auch nicht 2mV
sein, sondern kann ein Stück darüber oder darunter liegen oder auch
negativ sein.

Wenn du lustig bist und eine sehr ruhige Hand hast, kannst du ja die
eine Eingangsspannung fest vorgeben und die andere mit einem als
Spannungsteiler geschalteten Potentiometer einstellbar machen und dann
versuchen, mit dem Poti die Stelle zu finden, wo die Ausgangsspannung
zwischen 0V (untere Anschlag) und 3,5V (oberer Anschlag) liegt ;-)

Autor: Caro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab auch das Lernpaket Elektronik mit ICs.
Bei mir funktioniert das Leuchtfeuer prima,
genau wie im Anleitungsbuch beschrieben.

Trotzdem find ich es super, dass es hier Leute gibt,
die Sachen erklären.

Ich hab übrigens noch eine rote Leuchtdiode zum 100 Kiloohm
Widerstand geschaltet. Was ich jetz nicht versteh ist,
dass die immer leuchtet, wenn die andere aus ist.
Ich dachte das wär genau umgekehrt. :-<

Kann das jemand erklären ?


Danke,

Caro

Autor: Torsten Broxtermann (tbrox)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der zweite OP ist als invertierender Verstärker geschaltet, das heißt er 
gibt den Eingangssignalen ein "negatives Vorzeichen"

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.