www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik atngw100- buildroot stirbt beim verpacken ab..


Autor: tecdroid (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi, mein buildroot (2.3.0) funktioniert ja so schon ganz gut, nur 
irgendwie stirbt es mir kurz vor ende des builds ab:

<====================
config.status: executing depfiles commands
config.status: executing default commands
touch /root/build/build_avr32/genext2fs-1.4.1/.configured
/usr/bin/make -j1 CFLAGS="-Wall -O2 -D_LARGEFILE_SOURCE 
-D_LARGEFILE64_SOURCE \
    -D_FILE_OFFSET_BITS=64" -C /root/build/build_avr32/genext2fs-1.4.1
make[1]: Entering directory `/root/build/build_avr32/genext2fs-1.4.1'
/usr/bin/make  all-am
make[2]: Entering directory `/root/build/build_avr32/genext2fs-1.4.1'
if /usr/bin/gcc -DHAVE_CONFIG_H -I. -I. -I.     -Wall -O2 
-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE   -D_FILE_OFFSET_BITS=64 -MT 
genext2fs.o -MD -MP -MF ".deps/genext2fs.Tpo" -c -o genext2fs.o 
genext2fs.c; \
  then mv -f ".deps/genext2fs.Tpo" ".deps/genext2fs.Po"; else rm -f 
".deps/genext2fs.Tpo"; exit 1; fi
/usr/bin/gcc  -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE 
-D_FILE_OFFSET_BITS=64   -o genext2fs  genext2fs.o
make[2]: Leaving directory `/root/build/build_avr32/genext2fs-1.4.1'
make[1]: Leaving directory `/root/build/build_avr32/genext2fs-1.4.1'
touch -c /root/build/build_avr32/genext2fs-1.4.1/genext2fs
test -x 
/root/build/build_avr32/staging_dir/sbin/avr32-linux-uclibc-ldconfig && 
/root/build/build_avr32/staging_dir/sbin/avr32-linux-uclibc-ldconfig -r 
/root/build/project_build_avr32/atngw100-base/root 2>/dev/null
make: *** [/root/build/binaries/atngw100-base/rootfs.avr32.ext2] Fehler 
1
===============================>

kann mir das wer erklären/beheben?
mein rechner rennt auf debian 5.0 mit entsprechender toolchain..

Autor: Werner B. (werner-b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht so aus als ob der eigentliche Fehler viel früher passiert und 
unter anderem das Programm

/root/build/build_avr32/staging_dir/sbin/avr32-linux-uclibc-ldconfig

nicht gebaut worden ist.

Manchmal ist es nach einem Fehler und der Nachinstallation von 
Programmen (apt-get) notwendig einen völlig neuen Build-Tree anzufangen, 
da buildroot nicht immer erkennt dass einige Komponenten der Toolchain 
neu/noch erzeugt werden müssen.
Man sollte sich vorher aber das src Verzeichnis sichern ;-)

Viel Erfolg

Autor: tecdroid (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das sbin-verzeichnis existiert garnicht..
evtl. ist meine konfiguration vergurkt?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.