www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART M32C


Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Kann mir jemand mit den Einstellungen des uart1 weiterhelfen.
Möchte daß eine LED toogled, jedesmal wenn ein Byte ankommt.
uC empfängt zwar, springt danach in die Interrupt-Routine(in der
steht:P4 = ~P4); LED leuchtet für 5us, danach kommt ein Reset!?

Hab derzeit folgende Einstellungen der Register(laut Bsp: "M16C/80
Operation of Serial I/O (reception in uart mode)

PSL0 = 0x40;
PS0 = 0xC0;

U1MR = 0x05;
U1C0 = 0x10;
U1BRG = 103;    //(Approx. 9600bps : fi/16(103+1) @ 16MHz = fi)
U1C1 = 0x04;

U1C0 hab ich so angepaßt, weil ich kein cts/rts verwende.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.