www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fuses: JTAG Interface Enabled (JTAGEN=0)


Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich kann im Avr-Studio das JTAG Interace Enabled bit bei den
Fuses-Einstellungen nicht mehr Programmieren.
Weder über das JTAG noch über RS232-CTRL.

Im Troubleshooting steht, dass ich über einen anderen Programmer das
JTAG aktivieren soll. Was ist damit gemeint? Ich hab nur das STK500 mit
dem STK501 TOP Modul und das JTAG?

Gibt es eine andere Möglichkeit das Fuse-Bit zu setzen ?

Merci,
Holger

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kannst du die anderen Fusebits noch setzen?

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein,

leider auch nicht.

Es kommt immer:

Setting device parameters, parallel programming mode..OK
Entering programming mode..OK
Programming fuses..FAILED!
Leaving Programming mode...FAILED!

Danach ein POP-UP Window

mit:

Problems occured when executing command(s). Please check the history
window. See the troubleshooting section in help for information on what
may have caused the problems.


Ich hab den JTAG nicht mehr angeschlossen, und versuche über den RS232
CTRL Port zu programmieren. Ist doch richtig?

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du denn den Controller auch für Parallelprogrammierung verkabelt?

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kaum verkabelt man die Sache richtig, dann kann man auch wieder die Fuse
-Bits setzten.

Vielen Dank,

hat mir ne Menge ärger erspart!


Doch jetzt hab ich wieder das JTAG dran, will mein cof-File laden,
da geht AVR-Studio gleich in den Run-Modus und zeigt mir mein
C-Programm nicht an. Habt Ihr mir da vielleicht auch noch ein Rat?

Kann das vielleicht an meinem Quarz liegen? Ich hab ein 3,6595 MHz
Quarz in dem On-Board-Socket stecken.
Meine Jumper sind im Moment noch so:
XTAL gesetzt
Reset gesetzt
OSCSEL jumper auf 1 und 2 gesetzt! (Heisst doch Software-controlled?)

Eigentlich will ich einen 8 MHz Quarz verwenden. Was muss ich denn da
beachten bzw. einstellen? Verwende einen Atmega128L.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.