www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik RELAIS Ansteuerung ULN2803


Autor: Gerd A. (inputsammler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich brauch euere Hilfe

ICh steuere über das ULN2803 Relais an
Vom Atmega32 umer 100 Ohm.

ATMEGA -> Spannung auf ULN --> ULN schaltet masse auf das Relais soweit 
so gut...
Aber..
Sobald ich mehr als 3 Realais zu schalten versuche geht nichts mehr.

Spannung für die Relais 12V (habe das passende Symbol nicht gefunden im 
EAGLE)

Habe ich evtl die DIODE was falsch gemacht??

Gruß Gerd

Habe schnell den schaltplan in EAGLE gezaubert (nur Relais part)

Autor: Panzerknacker 176-671 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Dioden brauchst du mit dem ULN nicht. Der hat sie schon eingebaut.
Datenblatt lesen.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Gerd A. (inputsammler)

>ICh steuere über das ULN2803 Relais an
>Vom Atmega32 umer 100 Ohm.

Braucht man nicht, siehe Datenblatt.

>Sobald ich mehr als 3 Realais zu schalten versuche geht nichts mehr.

Netzteil zu schwach?

MFG
Falk

Autor: Gerd A. (inputsammler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke,
UPS schon wieder sinnlos 8 DIODEN verbraucht.
Das ist meine Standart Schaltung wenn ich es über Transistoren schalte 
:-).

Die DIODE dürfte doch aber nicht das Problem sein warum es nur max 3 
Relais schalten.

Spannungen am Eingang von AVR sind 4,86V auf allen 8.
Spannung am den DIODEN (von ULN) bricht zusammen 11V ,10V, 9V, 5V, 3V , 
2V

Normal müssen doch immer -12V raus schalten oder ?
Gruß Gerd

Autor: Gerd A. (inputsammler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:
> @Gerd A. (inputsammler)
>
>>ICh steuere über das ULN2803 Relais an
>>Vom Atmega32 umer 100 Ohm.
>
> Braucht man nicht, siehe Datenblatt.
Ja habes vorher gesehen
- All units feature integral clamp diodes for switching inductive
loads
- TTL, 5 V CMOS
> Netzteil zu schwach?
>
5V 3A und 12V 1,5A
ich galube nicht ....

Messe gerade die schaltung durch. Leiterbachnbruch ??

ULN ist OK.

Autor: Panzerknacker 176-671 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch die Masse vom ULN mit der Masse vom Controller verbunden?

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mess mal die Spannung des Netzteils, wenn alle Relais geschaltet sind.
Evtl. bricht diese ein.

Danach misst du die Spannung zwischen einem Ausgang und Minus.
Wenn diese höher als 1,5V ist schaltet der ULN nicht durch.

Die Relais sind auch für 12V?
Denn das erste Datenblatt das ich fand schrieb 24V 400mW.
Kann aber auch ein ähnlicher Typ sein.

Autor: Gerd A. (inputsammler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke an allen für euere HILFE.

Der TYP vom RELAIS ist ein FIN mit 12V.

Nach dem ich alles durchgemessen habe.
Spannung am Netzteil bricht nicht zusammen.

Was mir weitergeholfen hat war den Ausgang von ULN messen.
Dieser wird bei jedem neuen relais mehr ???
--> die Masse vom ULN hatte irgendwo eine nicht 100% Masse sobald Last 
(relais) geschalten wurden wurde die Masse immer geringer.

Alle Lötstellen nachgelötet -- es GEHT ... DANKE euch allen nochmal.

So nun weiß ich auch das ich fpr den ULN2803 keinen DIODEn und RV mehr 
brauche.. Wieder was gespart und gelernt

Habe auch noch die ULN2003APG da brauche ich RV und DIODE auch nicht 
cool

DANKE
Gruß Gerd

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.