www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Oberton oder nicht?


Autor: Marcel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hey!

Ich ärgere mich gerade mit dem USB Controller "USB N9604-28M" herum.
Ich habe zwei Schaltungen aufgebaut, doch leider reagieren die USB 
Controller nicht auf den PC und werden nur als unbekanntes Device 
erkannt.

Laut Datenblatt habe ich 24Mhz Grundtonquarze gekauft. Allerdings bin 
ich mir bei dem Oszibild nicht mehr so sicher.

Könnte mir jemand sagen ob das nach Oberwellenquarz aussieht (hab bis 
jetzt noch nie einen benutzt).

Falls ja, weiß jemand eine einfache Schaltung um den Obertonquarz zu 
benutzen? Oder hat Conrad irgendwelche Grundtonquarze 24Mhz?

Danke schonmal

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, ob es überhaupt Grundtonquarze für 24MHz gibt? Ich weiss es nicht.
Aber dein Bild so aussagekräftig ...:-)

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ich dachte man erkennt es an der Wellenform.

Was brauch man sonst, um den Quarz zu identifizieren?

Achso Einstellungen waren 0,2µS/div und 50mV/div. (Tastkopf 1:10)

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne Schaltung, Quarz-Typ, -Bezeichnung und Hersteller anzugeben:
Kann alles so sein wie Du schreibst - oder auch nicht.

Kurz: Mit diesen wenigen Infos die Du lieferst auch ein Aprilscherz.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
H.joachim Seifert wrote:
> Hm, ob es überhaupt Grundtonquarze für 24MHz gibt?

Ja, gibt es. Im Bereich 20-30MHz werden beide Typen häufig verwendet, 
daher muss man da etwas aufpassen.

Marcel wrote:
> Falls ja, weiß jemand eine einfache Schaltung um den Obertonquarz zu
> benutzen?

Schalte parallel zum Quarz einen Reihenschwingkreis der auf die 
Grundtonfrequenz abgestimmt ist, in diesem Fall also auf 8MHz. Der 
schließt den Grundton kurz, weshalb der Quarz nur auf dem Oberton 
schwingen kann.

Aber der Informationsgehalt von deinem Bild ist in der Tat eher sehr 
niedrig. Das einzige was man erkennen kann ist, dass der Quarz ziemlich 
ungleichmäßig schwingt.

Autor: Marcel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Okay also die Schaltung ist diese: 
http://www.digital-enlightenment.de/usbdmx.htm

Und das einzige Datenblatt was ich hab ist dieses.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, dann wäre das ja mit dem Grundtonqurz schon mal positiv geklärt.

Kann also durchaus einer sein, muß aber nicht. Insbesondere bei der 
Lieferung von C***-

Wirklich sinnig wird's mit diesem Quarz wohl nur werden mit 
(Oberton-)Quarzschwingschaltung und LC-Schwingkreis auf 24MHz 
abgestimmt.

Das Scopebild stammt aus Deiner Schaltung,  vermutlich durch Messung am 
Quarz?
Tastkopf direkt an eine der Quarzanschlüße gehalten?
Wenn ja, dann ist's bei 99.5% der TK der den Quarz zu stark belastet.
d.h. ein Gutteil Deiner "Quarzamplitude ist bei jeder 2. Schwingung 
niedriger" liegt an Deiner Messung. Da schau doch bitte mal ob sich in 
Deiner Schaltung nicht ein besserer (belastungsfähigerer) Meßpunkt 
findet.

Das Scope ist leider auch am Limit, bei 200ns/Div wird's schwer die 
24MHz aufzulösen. Hameg 512-v3?

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Schaltungsbeschreibung stellt der µC den Takt am Clockausgang von 
4Mhz auf 12Mhz hoch. Diese Schwingung ist dann absolut gleichmäßig und 
auch wesentlich stärker (ist der höchstbelastbare Takt den ich finden 
konnte).
Nun wäre die Frage, ob er mit einem nicht richtig funktionierenden Quarz 
überhaupt saubere 12Mhz ausgeben kann.

Das Oszi ist bei 200ns auf minimaler Zeiteinstellung, also ein 
wirklicher Grenzfall.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel wrote:
> Laut Schaltungsbeschreibung stellt der µC den Takt am Clockausgang von
> 4Mhz auf 12Mhz hoch. Diese Schwingung ist dann absolut gleichmäßig und
> auch wesentlich stärker (ist der höchstbelastbare Takt den ich finden
> konnte).

Ja, das muß auch so sein. Die 12MHz sind nach den Digtal-Teilern. Der FF 
Ausgang ist dann das wo Du mißt.


> Nun wäre die Frage, ob er mit einem nicht richtig funktionierenden Quarz
> überhaupt saubere 12Mhz ausgeben kann.

In Grenzen. D.h. je nach Schaltungstoleranz reicht es oder eben nicht. 
Wenn Du am Limit bist, dann kann sogar ein Temperaturwechsel um einige 
Grad Celsius oder Spanungsschwankung zum Aussetzen führen.
Also Anwort auf Deine Frage: Kann, muß aber nciht.

>
> Das Oszi ist bei 200ns auf minimaler Zeiteinstellung, also ein
> wirklicher Grenzfall.

Mein Tip:
Kein freundlicher Bastler, Funker, Profi in Deiner näheren Umgebung der 
Oszi ausleiht und am besten eine FET-TK hat? Bzw. den Du besuchen 
kannst?

Ansonsten bleibt nur das Prinzip: Wird schon reichen, hoffen wir.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel wrote:

> Ich ärgere mich gerade mit dem USB Controller "USB N9604-28M" herum.
> Ich habe zwei Schaltungen aufgebaut, doch leider reagieren die USB
> Controller nicht auf den PC und werden nur als unbekanntes Device
> erkannt.

Das heißt doch aber, dass sie überhaupt auf dem Bus reden, oder?
Dann muss der Takt in Ordnung sein, denn sonst würde da nichts
funktionieren.

Was passiert denn, wenn du den Quarz ablötest?  Dann dürften sie
gar nicht mehr erkannt werden.

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sooo,

ich hab jetzt mal einen sehr "professionellen" Test gemacht.

Ich hab die ganze Schaltung mal in die Kühltruhe gelegt.

Rausgenommen, angesteckt, geht!
Nach ner Weile ging die Schaltung wieder nicht mehr.

Quarz? oder gibt es noch andere sehr temperaturabhängige Bauteile 
(IC's?)?

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Quarzlast an der Grenze, falsche Last-Cs benutzt.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liegen an den beiden Enden des Quarzes zwei kleine Lastkondensatoren? 
Entferne die mal testweise.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch wrote:

> Das heißt doch aber, dass sie überhaupt auf dem Bus reden, oder?
> Dann muss der Takt in Ordnung sein, denn sonst würde da nichts
> funktionieren.

Nein, es reicht aus wenn man den Pullup an die USB Leitung macht. Daran 
erkennt der Host einen angeschlossenen Slave. Nur dieser Widerstand 
alleine bewirkt daher die Meldung "Unbekanntes Gerät".

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaub mich bei der Schaltung an einen Fehler in den Fuse-Bits des 
AVRs zu erinnern...
mit den angegebenen hatte ich damals auch Probleme, bis ich drauf 
gestoßen bin und sie angepaßt habe. Ist aber schon eine Zeit lang her, 
kann im Moment nichts genaueres dazu sagen,
aber ich werde später mal nachsehen.

Gruß
Sebastian

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, vergessen...und Vista erkannte die Schaltung auch nicht 
problemlos, XP hingegen erkannte sie.

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus dem Oszibild kann man sehen, dass dem Grundsignal ein Signal halber
Frequenz mit etwa 1/4 der Amplitude überlagert ist. Diese Störung könnte
von einem internen Frequenzteiler in der Schaltung stammen und stellt
nicht unbedingt ein Problem dar, wenn die Frequenz an sich stimmt.

Ich glaube auch nicht, dass es sich um einen Obertonquarz handelt. Zum
einen liegen dort Grund- und Oberschwingungen um den Faktor 3 (nicht 2)
auseinander), zum anderen würde ein Obertonquarz mit dem Pierce-Oszil-
lator im USB9604 nicht auf 24MHz, sondern auf 8MHz schwingen.

Also liegt es eher daran, dass die Frequenz nicht stimmt (Quarz halb
kaputt oder grob falsche Lastkondensatoren) oder ein Fehler in der Art,
was Sebastian beschrieben hat.

Der Gefriertruhentest deutet aber vielleicht doch eher auf ein
Frequenzproblem hin. Hast du einen Frequenzzähler oder sonst etwas, was
die Frequenz auf <1% genau messen kann? Das Analog-Oszi ist evtl. zu
ungenau.

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle!

Ich habe jetzt mal die Lastwiderstände von 15pF auf 33pF geändert.
Seitdem geht die USB Verbindung problemlos.

Ich dank euch allen für eure Hilfe. Wäre ich nie drauf gekommen.

Thx Marcel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.