www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Attiny24 - timer/counter1 läuft nicht


Autor: Hanspeter F. (efly2005)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Spezialisten !

Wie im Titel angeführt, bringe ich den timer/counter1 nicht zum laufen 
(im Studio4).
Folgenden simplen assembler-code habe ich zum Probieren in Studio4 
geladen:
(quote)
.include "tn24def.inc"
.def temp = R16
.cseg
.org 0
  rjmp reset

Reset:
  ldi temp, 0x01
  out TCCR0B,temp
  ldi temp, 0x01
  out TCCR1B,temp

loop:
  rjmp loop
(unquote)
Wenn ich den code nun schrittweise durchgehe so fängt der Timer0 brav zu 
zählen an, beim Timer1 werden bit1 u. 2 v. TIFR1 gesetzt, der Zähler 
TCNT1 rührt sich jedoch nicht vom Fleck !!

Kann mir jemand eine Hilfestellung anbieten ?

Danke bereits im voraus.

Grüße / Efly2005

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.