www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Linar reglung schwingt


Autor: Sascha Beh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

also ich habe eine kleine Platine geroutet für eine Lineare Regelung,
nachdem der erste Porto geätzt und bestückt war und ich eingeschaltet 
habe Schwung die Schaltung wie erwartet, da ich noch keine Kondensatoren 
in der Rückkopplung der OP's eingelötet hatte da ich noch keine werte 
hatte.

Nach dem Ich zwischen 10pF und 100nF alles durchprobiert hatte und ich 
immer noch nicht zum Erfolg Kamm habe ich dem Leistung Transistor ein 
tief pass an der Basis spendiert (10 Ohm und 100nF).
Mir war schon klar das das keine Lösung ist aber damit hörte die 
Schwindung auf, auch unter last.

Nur dadurch wurde die Reglung derart langsam das es mir einen Transistor 
„gesprengt“ hat d.h. ich habe jetzt ein TIP142 der in 2 gespalten ist 
einmal das Metallteil mit dem Kollektor dran und das Plastikteil mit 
Basis und Emitter. ^^

Danach dachte ich mir wenn ich über dem Spannungsteiler mir den ausgangs 
rippel ein koppel mit einem 1nF könnte ich die Schwingung in Griff 
bekommen aber ...Pustekuchen... auch die Phase zu verschieben indem ich 
ein RC-Glied in die Spannungsückführung eingebaut habe war nicht die 
Lösung...

Daher meine Frage habe ich in der Schaltung ein kapitalen bock den ich 
nicht sehe?

Oder habt ihr noch eine Idee?

Ps.: es dreht sich um die Spannungsreglung da ich die Stromreglung noch 
abgelötet habe also vor der Doppeldiode den 2k21 nicht bestückt habe.

Ps2.: ich habe auch schon mal ein paar andere OP’s getestet ohne Erfolg:
TLC082, OPA2227, LF356M, LT1112, LF412, LT1215, LT1361, OP27G...

Wobei mit einem ADA 4000-2 war die Schwingung weg, da ich aber nicht 
verstanden habe warum die Schwingung weg war habe ich ihn wieder 
ausgelötet und habe jetzt einen LTC2051 eingelötet.

Mfg Sascha Beh

http://8ack5p1n89.de/daten/bilder/schem1.JPG
http://8ack5p1n89.de/daten/bilder/schem2.TIF

Autor: Olli R. (omr) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bildformate, gilt auch fuer Links, da

1. JPGs "verwaschen" aussehen
2. mein Browser keine TIFs anzeigen kann

Olli

P.S.: Wenn man sich anmeldet, kann man seine Beitrage auch editieren :-)

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Gegenkopplungs C C24 hat so keine Wirkung da der Eingang des OPs 
mit C27 auf Gnd liegt. Was will der C24 mit 1nF gegen 1uF vom C27 
ausrichten ?
Mach mal einen Widerstand (10..47K) von deinem Ausgangsfilter mit C27 
und dem Eingang vom OP damit der C24 auch was bewirken kann. Besser 
waere noch hier einen Puffer OP zwischen zu schalten um das 
Tiefpassfilter nicht zu belasten.

Gruss Helmi

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem könnte schon dadurch kommen, weil wegen T1 die 
Gesamtspannungsverstärkung des OPV nochmals erhöht wird (um 20), was 
nach meinen erfahrungen meistens schief geht. Du hast zwar in der 
Rückkopplung einen 1:10 Spannungsteiler drin, was die Sache wieder etwas 
entschärft, aber trotzdem ist die effektive Gesamtverstärkung um Faktor 
2 höher, die der OPV sieht.
Der C24 dürfte Wirkungslos sein, weil er quasi durch C27 kurzgeschlossen 
wird (kap. Spannungsteiler).
Ansosnten Sind Spannungregler aufgrund der kapazitiv belasteten Ausgänge 
ohnehin schwieriger zu handhaben, also wenn rein ohmsche Lasten zu 
verarbeiten wären.

Autor: Sascha Beh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
joar also wie soll ich sagen top^^
an den c habe ich nicht gedacht ...das der op da 1µ|1n sieht habe ich 
voll verpenned...naja als azubi im 7 monat ist das noch ok^^
ohne last habe ich mit einem 20k top werte so ca 400-500µV spitze spitze 
an rippel nur unter last habe ich noch ein ozilator mit 32,6khz aber da 
muss ich hoffendlich nur ein bissi mit der rückkoplung spielen.

macht es sinn dem op0_A die verstärkung zu begrenzen? also noch mal ca 
ein 100k zu dem c24 dazu?

Autor: Hans-jürgen Herbert (hjherbert) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also : dein OP_0A ist ein Regler. Ein PI-Regler.
Lass C24 weg - Der macht den Regler langsamer. Der belastet nur den 
Ausgang des OP-Amp. Deswegen schwingt es noch mehr
Ersetze C31 durch eine Reihenschaltung von vielleicht 20pF und 100 Ohm

Simuliere deine Schaltung mit LT-Spice von 
http://www.linear.com/designtools/software/

Autor: Alex H. (hoal) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie funktioniert eigentlich die Erzeugung der -5V rund um IC2?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.