www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik iPOD audio Ausgang mit zyklischen Störungen


Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich habe meinen iPOD G5 Video an einem AVR angeschlossen und die 
Audiosignale des analogen Ausgangs am Autoradio. Diese werden mit einem 
Relais zugeschalten.

Leider habe ich auf den Signalen ein hörbares Ticken. Die 
Leitungsführung kann ich ausschliessen da ich die Audioleitungen auch 
schon mit einem extra abgeschirmten Kabel direckt an die Eingänge 
angeschlossen hatte.
Das Ticken ist immer noch da. Das seltsame ist dass die Frequenz zum 
Teil unterschiedlich ist. Mal mit 1Hz und manchmal mit 2Hz.

Die Masseleitung des Audiosignals wird separat geführt. Es ist keine 
Verbindung zu der dig. Masse vorhanden.

Hat mir jemand nen Tip wie ich diese Störgeräusche entkoppeln kann?

Gruss,
Georg.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du zur gleichen Zeit ein IPOD Ladegerät angeschlossen?

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nein ein Ladegerät ist nicht angeschlossen.
Die Versorgungsspannung kommt von der Autobatterie.

Ich habe irgenwie das Gefühl dass es von der RS232 Kommunikation kommt.
Da lese ich jede sec. den Positionsstatus.

Allerdings verstehe ich nicht warum die Störungen kommen wenn die 
leitung komplett separat und geschirmt zu den audio eingängen geht.

Als ob intern im iPOD was schief läuft.

Das einzige was ev. noch nicht so sauber sein könnte:

- Ich habe die RS232 Leitungen über induktivkopler laufen. Dadurch ist 
die GND-Leitung des RS232 Signals nicht an der Platine angebunden.
- Die GND Leitung der FiWire Leitung aber schon da ich hier die 
Möglichkeit habe über die FiWire Versorgung zu laden.

Kann es sein dass ich damit eine Masseschleife aufbaue???

Georg.

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,


weiss jemand wie mann Audiosignale grundsätzlich entkoppelt abschliesst 
usw?

Ich komm grad irgendwie nicht weiter.

Gruss,
Georg.

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat mir den keiner nen Tip??
Weiss den jemand zumindest wie FireFire, RS232, Audio und USB in einer 
Dockingstation verschaltet sind?

Gruss,
Georg.

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo LEute,

ich hab jetzt die Ursache für die Störungen gefunden. Weiss aber nicht 
wie ich diesen umgehen soll.

Ich habe ja den AVR am µC hängen. Dieser wird im Auto eingesetzt. Hab da 
nen 7805 als Gleichspannungsregler verbaut.

Angeschlossen ist der iPOD an der RS232 und das Audiosignal wird zum 
Radio durchgeschleifft.

Als Massen habe ich folgende:
SerialGND
AudioGND + GND
und FireWire GND.

All diese Massen hängen ja irgendwann zusammen.
Jetzt ist es so. Wenn ich das FireWire GND dran habe dann hab ich 
Störgeräusche. Ich mein dass ist die Kommunikation über RS232. Ist die 
nicht verbunden dann sind diese weg.

Ich brauch dieses GND aber da ich über die FireWire Versorgung den iPOD 
im Auto lade.

Jetzt stellt sich die Frage wie schaff ich es ohne grossen aufwand den 
FireWire GND von den restlichen zu entkoppeln?

Gruss und Danke,
Georg.

Autor: Sil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du schon eine Lösung gefunden?
Ich hänge hier am gleichen Problem...

Autor: Klaus Brandt (kcx650)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe bei meinem iPod Touch die Erfahrung gemacht, das dass
Ding sehr zickig ist, was die Stromversorgung angeht.
Bei Verwendung eines (billigen) Zigarettenanzünder->USB
Adapters, habe ich ständig ein rythmisches Ticken,
auf der Audioleitung.

Laut iPod Forum, soll das mit einem "anständigen"
Adapter behoben sein.

Hast du die Geräusche auch bei ausgeschaltetem Motor ?

Das Projekt hört sich ansonsten sehr interessant an !
Könntet ihr bitte etwas mehr darüber berichten ?


Gruss

kb

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sowas in der Art hab ich auch. Ich hab für meinen Bruder einen 
Ei-Pott-Lader und Fernbedien-Adapter gebaut. Zum einen lädt der den 
EiPott Touch über die USB Leitungen mit 1A aus einem MAX5035, zum 
anderen setzt er die RC5 IR Befehle einer VDO Dayton 
Lenkrad-Fernbedienung in das Simple Remote Protocol um, und steuert 
somit den Player. Nun gibts aber auch das Problem mit den Störungen, da 
ja erst mal im Adapter alle Massen verbunden sind. Zu Hause am 
Labor-Netzgerät hört man fast nix, aber im Auto (Ton an AUX In vom 
Autoradio) knisterts und tickts wie verrückt. Abhilfe hat schon mal 
gebracht, die Masse nicht an den Pin 2 (oder wars die 3?) am Dock 
Connector anzuschließen, aber weg sind die Störungen trotzdem nicht. 
Wahrscheinlich muss da so ein NF-Übertrager oder ein galvanisch 
getrennter DC-DC-Wandler rein.

Autor: Sil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun...ich möchte meinen IPod über mein Radio als CD-Wechsler steuern. 
Die Steuerung funktioniert soweit auch. Als Prozessor habe ich einen ARM 
von Texas genommen. Wohl etwas überdimensioniert, aber die Dinger sind 
inzwischen recht billig.
Die neuen IPods lassen sich ja nur über 5V laden. Auch das funktioniert 
soweit. Nur: man kann die serielle Übertragung vom/zum IPod als 
Hintergrundgesurre hören. Nimmt man die 5V weg oder schaltet einen 
1k-Widerstand zwischen 5V und IPod, verschwindet dieses Gesurre. Dumm 
ist nur, dass bei 1k der IPod nicht geladen wird. Und genau das will ich 
natürlich, denn sonst ist der Akku des IPods nach längerer Fahrt leer.
Die 5V sind absolut sauber und es stehen 400mA zur Verfügung. Bisher 
zieht mein IPod grade mal 100mA, wenn er geladen wird.
Audiomasse und Logikmasse sind getrennt, daran sollte es also auch nicht 
liegen. Außerdem wäre dann das Gesurre nicht von der Übertragung 
abhängig.
Die Übertragung brauche ich aber, sonst kann ich an meinem Radio die 
aktuelle Position nicht anzeigen.
Ich bin etwas ratlos...

Autor: MrFX (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin!

Ich hab das Problem mit dem Klicken (siehe vorletztes Posting von meinem 
Bruder supachris) nun mit einem DC/DC-Wandler mit galvanischer Trennung 
in der 5V-Versorgung gelöst, zusätzlich war aber auch noch so ein 
KFZ-Mantelstromfilter für NF nötig.

Zum Laden nutze ich nun die Kombination für 500 mA aus den Apple Specs:

http://img16.imageshack.us/img16/4832/ipodladen.png

MfG
MrFX

Autor: Marcus S. (mirt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

habe den Post leider in einem falschen Thread vorher gepostet. Sorry.

ich habe mir auch einen iPod Adapter für's Autoradio gebaut. Habe auch
zyklisches Zirpen auf der Audioleitung. Ich dachte auch erst, es sei die
Serielle Kommunikation zwischen ipod und µC.

Das war es aber nicht. Bei gezogenem µC habe ich dieselben Geräusche.
Mir ist dann aufgefallen, dass jedes mal, wenn auf dem Display des iPod
Titel und Interpret scrollen, dieses Geräusch zu hören ist. Man hört
quasi, wenn sich die Anzeige auf dem iPod verändert.

Die ganzen Störgeräusche treten nur auf, wenn der iPod geladen wird.
Drehzahlpfeifen habe ich zumindest nicht, das konnte ich mit einer
elektronischen Brummsiebung eliminieren.

Habe schon diverse Kondensatoren und Widerstände in Reihe zu den
Audioleitungen und nach Audio und Digital GND probiert, gab aber keine
Besserung.

Gibt es noch Alternativen zu einer galvanischen Trennung der
Ladespannung?

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, man könnte wahrscheinlich auch die Stromversorgung direkt machen, 
aber Audio und Serial galvanisch trennen. Für Audio gibts ja diese 
kleinen NF-Übertrager und für Serial was mit Optokoppler oder ADuM 
Isolatoren....

Autor: Marcus S. (mirt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Vorschläge!

Ich habe jetzt so einiges ausprobiert. Richtig weg waren die 
Störgeräusche wirklich nur mit einer galvanischen Trennung. Ich habe 
dafür einen 12V/12V DC/DC Wandler von R* für ca. 5€ genommen. Ist zwar 
nicht ganz billig, aber der Aufwand ist dafür sehr gering.

Jetzt ist noch zu untersuchen, ob ich die elektronische Brummsiebung 
gegen das Drehzahlpfeifen mit galvan. Trennung weglassen kann.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.