www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmel resetet sich bei Schaltimpulsen


Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Wer kann helfen? Folgendes Problem:
Ein AT90S1200 soll einen Lüftermotor steuern. Also einfach ein und
ausschalten mit verschiedenen programmierten Intervallen. Als Hardware
wird ein Relais angesteuert. Nun habe ich das Problem, das der
Prozessor resetet wenn der Lüftermotor zuschaltet. Also habe ich
erstmal noch ein haufen Kondensatoren eingebaut (Orginal hatte ich den
Stabi mit 2x 100nF geblockt, einen 33uF und 100nF am Prozessor). Kein
Erfolg. Nun kommt es noch dicker: Die Platine habe ich aus einer 9V
Batterie gespeißt und das Relais mit einem Schalter per Hand betätigt -
kein Problem. Dann habe ich die Masseleitung angeschlossen (Das
Leistungsteil ist ca. 2m vom Steuerteil entfernt, dazwischen eien 4
adrige Leitung mit Masse, +12V und Steuerleitung für die Relaisstufe)
und schon spinnt der Prozessor. Weitere Experimente auf meinem
Hobbytisch ergaben, das das Teil auch auf andere Induktive Störungen
reagiert (zBsp. Trenntrafo ein/ausschalten). Vor längerer Zeit hatte
ich mal ein ähnliches Problem mit einer Wasseralarmsteuerung für eine
Waschmaschiene. Da hatte ich erst die Schaltung mit einem Atmel
aufgebaut - Probleme wenn der Motor lief, dann mit einem PIC - das
gleiche und am ende mit Standard-CMOS IC's - das laüft seit Jahren
ohne Störungen. (Abschirmung in Blechgehäuse hatte nichts gebracht!)
Wer kann Helfen - wer kennt diese Probleme...

MB-BlueFire

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Freilaufdiode über der Relaisspule? Spannung des µC mit LC sieben?

Matthias

Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias!
Freilaufdiode ist drinn, Problem auch bei Batteriebetrieb und nur
verbundener Masse - der Rest völlig abgetrennt (kann also nicht über
die UB kommen - Funkstörungen??)
MB-Bluefire

Autor: Stefan Kleinwort (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Resetbeschaltung? Interner oder externer Reset?

Stefan

Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe einen externen Reset drann...

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hatte das gleiche Prob. Bei mir hat eine simple Spule an der
Spannungsversorgung geholfen!

Autor: McMurkser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde ne Spule von Masse nach PE machen. So hab ich es auch gemacht.
Jetzt funktioniert es. Keine Ahnung warum ;). Aber wenigstens es funzt
^^


cya

McMurkser

Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Christian!
Spule(n) und diverse Siebglieder (RC und LC) habe ich schon probiert -
kein Erfolg (Problem ist ja auch bei Batteriebetrieb da!)

Hallo McMurkser!
...Masse nach PE - was ist PE???

MB-BlueFire

Autor: edi.edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann es sein, dass PE = Planet Erde ist?

Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
PE = Planet Erde? - Habe nur Masse = Minus in meiner Schaltung...
Soll ich das Teil eingraben???
MB-Bluefire

Autor: Stefan Kleinwort (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Habe einen externen Reset drann...

Und wie genau? Welcher Chip? Welcher Pullup? Ist die Resetleitung noch
woanders hingeführt? Vielleicht sogar einen Schaltplan?

Meine Erfahrung: solche Probleme liegen zu 90% an Störungen auf der
Resetleitung.

Das Relais schaltest Du hoffentlich über einen Transistor, und es wird
über die 12V versorgt?

Stefan

Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo! ES LÄUFT!
PE - Planet Erde war der richtige Tipp!
Habe einfach Minus = Masse mit dem Schutzleiter der nächstgelegenen
Steckdose verbunden - ES LÄUFT ohne Störungen!!!!!
Danke für den Tipp!
Strom ist immer wieder seltsam - aber nur deshalb macht es ja so einen
Spaß!
So, jetzt kann ich mich auf die Software stürzen...
Tschüß und Danke an alle
MB-Bluefire

Autor: edi.edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PE = Potentialerde....auf dem Planet : Erde ....  LOL

Autor: Mb Bluefire (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Hier ein Link zu meinem nun funktionierenden Project "LiLu":

www.MB-BlueFire.de

oder direkt:

http://home.arcor.de/mbbf/LiLu/lilu.html

Beste Grüße
MB-BlueFire

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@edi.edi
Ich dachte immer, PE hiesse protective earth, tja, man lernt halt nie
aus :-)

Autor: edi.edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
crazy world !
you are right!
ed

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.