www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Stange Programmer und Pollin Evulotionsboard


Autor: Thomas P. (thompo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Ich kann mein Pollin Board über Seriale Schnittstelle (ISP) ohne 
Probleme programieren. Habe mir jetzt ein ISP-Programmer (USB) von 
Stange zugelegt.
AVR Studio erkennt wohl das Teil. Ich kann auch die Frequenz einstellen 
aber die Fuse Bits kann ich nicht bei einem neuen Atmega 8 auslesen. Es 
kommt immer zu Fehlern. Was mache ich Falsch.

Gruß

Thompo

Autor: gast christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem habe ich leider auch!

Autor: overclocker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann denn niemand helfen? Das scheint ein verbreitetes Problem zu 
sein...

Ein paar mal konnte AVR Studio eine Verbindung zum Stange ISP 
herstellen, aber dann kamen immer Fehler, d.h. 
auslesen/verifizieren/flashen war nicht möglich. Jetzt ist nicht einmal 
die Verbindung möglich... "Connect failed"...
COM ist auf COM2 eingestellt, Baud etc gelassen wie es war bzw. zum 
Testen auf 115200 gestellt. Brachte alles nichts.

Das Zielboard hat mit einem AVRISP MKII funktioniert, aber der steht mir 
nicht mehr zur Verfügung.

Kennt jemand einen Lösungsweg?

Autor: Georg W. (gewe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

kann ich hier nicht bestätigen. Pollin Board, ATMega32, Stange ISP auf 
COM5, Vista SP2, AVR Studio 4.17. Target Versorgung am ISP 
ausgeschaltet.

Was habt Ihr an den MISO, MOSI, SCK, Reset-Pin's hängen?

Autor: overclocker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
USB->COM2, Vista SP1, AVR Studio 4.14 R589.

Veraltete Software kann doch nicht zu solchen Problemen führen!?

>Was habt Ihr an den MISO, MOSI, SCK, Reset-Pin's hängen?
??? 15 cm Flachbandkabel, 10cm normalen Draht und dann den µC 
(AtMega1280)
Am Reset noch einen FTDI und einen Kondensator und 10kOhm nach VCC.

Target Versorgung alles durchprobiert, als das Board mit nichts 
verbunden war. Target Versorgung aus, als es eigene Versorgung hatte.

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.sr-tronic.eu/service/Anleitung/Anleitun...
http://www.obd-shop.com/danila/product_details.php...

* Treiber sind installiert?
* STK500v2 ist eingestellt?
* Statt AVR Studio wurde auch AVRDUDE probiert? Im verbose Modus? Gibt 
es einen Logfile-Mitschnitt?

Autor: overclocker (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> * Treiber sind installiert?
> * STK500v2 ist eingestellt?

Ja klar ;)
Nach einem Neustart des PCs kann sich AVR Studio (auf 4.17 R666 
upgedated) wieder mit dem Stange ISP verbinden.

Leider kommt immer ein Fehler, wenn ich etwas mit dem AVR machen will. 
(Im Beispiel "Read Signature", selbes kommt bei allem anderem wie 
"Fuses" etc. auch...)

> * Statt AVR Studio wurde auch AVRDUDE probiert? Im verbose Modus? Gibt
> es einen Logfile-Mitschnitt?

Habe leider mit AVRDUDE noch absolut keine Erfahrungen.

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
overclocker schrieb:

> Habe leider mit AVRDUDE noch absolut keine Erfahrungen.

Das kann man ja ändern, siehe Wikiartikel AVRDUDE

Autor: overclocker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem bei mir lag nicht am ISP-Gerät sondern an mangelhafter 
Verkabelung. Der Stange-ISP ist also doch empfehlenswert, funktioniert 
gut und problemlos, jedoch etwas langsamer als der original Atmel 
AVRISPII.

Autor: Heinz peter Posch (poschi8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat von euch mal jemand so ne Art Tutorial oder sonst etwas für das 
Ding, außer der ISP-Anleitung die beiliegt, denn Ich bin kurz vorm 
verzweifeln.
Mein Rechner will den Programmer einfach nicht erkennen.
Ist es besser wenn Ich mit Windows Vista arbeit, denn zurzeit arbeite 
Ich mit Windows XP.

Mfg,
Poschi

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.