www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kennlinienzündung für Zweitackter


Autor: Florian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
gleich vorweg, ich bin kein Elektroniker oder so. Ich mache das nur aus 
Spaß an der Freud und in der Hoffnung hinterher davon ein (privaten) 
Nutzen zu haben.

Zu meinem Problem. Ich habe mal im Netz einen Schaltplan für eine 
Prozessorzündung für Motoräder gefunden, von einem Dipl.Ing. H. Krause.
Wurde hier auch ein paar mal im Forum verlinkt. Ist also vielleicht 
sogar bekannt.

Ich habe die Schaltung im Wesentlichen so belassen wie sie war, nur ein 
paar LEDs, ein FT232 und die Versorgung über 7805.

Eigentlich funktioniert es auch nur leider wird der Transistor der die 
Zündspule schaltet so heiß das er sich sogar auslötet.

Deshalb habe ich es mit einem MOSFET versucht aber da ist der Funke 
nicht so schön und es scheint als wenn sich der Mega16 ab und an 
resetet.

Ich habe wie gesagt davon nicht so die Ahnung und bräuchte eure Hilfe um 
das Ding mal ein bisschen stabiler zu bekommen.

Ich habe die beiden verschiedenen Schaltungen angehängt. Ist aber nicht 
so schön geworden. Die untere ist die mit dem Transistor. Die ich 
eigentlich von der Funktion her bevorzugen würde, nur habe ich mir echt 
schon die Finger an dem ding verbrannt.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich der Transistor wäre, würde mir auch warm werden.

Der Emitter muß an Masse. Die Zündspule vom Kollektor gegen Plus (mit 
Freilaufdiode am Transistor). Also die Schaltung muß geändert werden.

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Q2 ist C-Schaltung -> Uce ~ 1V * ~ 3A = ~ 3W sportlich!
Was mich wundert ist das er die Rückinduktion der Zündspule
überlebt!

Gruß Z8

Autor: Bernd Hallinger (bhallinger) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fet kann so auch nicht stimmen....

Wenn der Transistor sperrt, würde der Strom nach wie vor über die 
Bodydiode fließen.

Da stimmt was mit dem Schaltzeichen nicht. Bitte mal überprüfen.

Aber ich würde den Transistor gefühlsmäßig auc an Masse schalten. Und 
eben eine schnelle Schotkydiode drüber als Freilauf.

Und zwar egal ob Bipolarer Transistir oder Fet. Der Funke muss mit dem 
Fet wenn er richtig drin ist genausogut sein wie beim bipo.

Ich hoffe die Software verhindert, dass Strom durch die Spule fließt 
wenn der Motor steht.

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, danke für die schnellen Antworten.
Ich habe gerade leider keine Zeit aber ich werde es mir nachher mal 
anschauen was ihr meint.

Tot habe ich den Transistor bis jetzt noch nicht bekommen der wird 
einfach nur schweineheiß.

mfg
Florian

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mal ein ähnliches Problem. Da gings darum, eine Zündspule zu 
simulieren und ich wusste nicht, welchen Transistor ich dafür nehmen 
soll.

Vielleicht hilfts ja: Beitrag "Zündspule an Transistor"

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wieso wird dem Transistor heiß?
So wie es im Schaltbild dargestellt ist, fließt doch gar kein Strom.....

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joo, gar kein Strom ist korrekt und klasse gesehen.

Der Sinn des Optokopplers erschießt sich mir nicht so wirklich. Eingang 
und Ausgang hängen gemeinsam an GND. Was entkopplet der Optokoppler dann 
noch ?


Schätze mal der Schaltplan ist nicht korrekt gezeichnet.

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast
>fließt doch gar kein Strom.....

wieso?

LED im Optokopler an -> Q1 durchgesteuert -> Q2
durchgesteuert -> Strom wird duch R der Zündspule begrenzt.

Tip: mach aus der Kollekorschaltung eine Emitterschaltung (PNP)
     und dreh evtl (venn nötig) die Logik im µC um.

Z8

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So mal für z8, alle andern wegschauen:

Durch die Zündspule fließt in diesem Schaltbild überhaupt kein Strom, da 
nur eine Seite der Spule angeschlossen ist, der 2. Anschluß hängt in der 
Luft, und die isoliert bei 12 Volt tierisch gut.

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So mal für kurz, alle andern wegschauen:

Gesäßvioline!

Es gibt KFZs bei denen der Unterbrecher die Zündspule nach
Masse schaltet und umgekehrt! Bei dieser Schaltung liegt
offensichtlich ein Ende der Zündspule fest auf Masse

Z8

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> liegt offensichtlich ein Ende der Zündspule fest auf Masse

und das kannst du dem Schaltbild entnehmen?
Will auch das Zeug das du rauchst^^

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach Gast (Gast),

wenn was warm wird, fließt Strom.
Übrigens, ich rauche Camel.

Z8 :)

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tierquäler!

Ich bin eher der musikalische Typ (rauche Drum).

Autor: gawk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Florian (Gast):
Klingt nach einem interessanten Projekt. Hast du vielleicht Pläne den 
Source zu veröffentlichen?

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.. grins Z8 :)))

Autor: Paul Baumann (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>der musikalische Typ (rauche Drum).

Ach drum! ;-)
MfG Paul

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
o 6V(12V)
                   !
                   _
                  | |
                  | |  Zündspule
                  | |
                   -
                   !
                   !
                   ! -- ----------------------------
                ! /                !                !
              --!/       BUT12A   ---  ZD200/5W    ----   1N5819
                !\                \ /               /\
                  >               ---!              --
                   !               !                !
                   !               !                !
                  ---             ---              ---

Seit Jahren in ca. 10 * MZ im Einsatz.
Der BUT wird nicht handwarm! (bitte nicht während der Motor läuft
testen! sonst aua!)

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
o--------------------------------------------------- 6V(12V)
                   !                                !
                   _
                  | |                               2xZD200/5W
                  | |  Zündspule                    antiseriell
                  | |                               !
                   -                                !
                   !                                !
                   !                                !
                   ! --------------------------------
                ! /                                 !
              --!/       BUT12A                    ----   1N5819
                !\                                  /\
                  >                                 --
                   !                                !
                   !                                !
                  ---                              ---


sorry, hab mal das alte Zeug rausgekramt.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wichtig ist nebenbei auch den Transistor schnell 
umzuschalten(Ansteuerung) und die Ladezeit der Spule zu beachten ein 
paar mSek zu viel und der Transistor muss leicht mal 20A statt 
vielleicht 5A schalten.

Damit dein µC nicht resettet spendiere dem 7805 eine Drosselspule ala 
MISC 100µH und eine 15V Supressordiode.

Autor: Z8 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, bevor Fagen kommen.

Die Z-Dioden sind drin damit das Teil nicht zerstört wird,
wenn mal die Masse einen Wackler hat. (KFZ halt)

@ Thomas O. -> full ACK

Z8

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ja der Schaltplan ist nur schnell hingeschmiert, und ein Symbol für die 
Zündspule hab ich nicht gefunden.

In der Tat ist es so das die Masse der Spule gleichzeitig die Halterung 
zum Festschrauben ans Fahrzeug ist.

In der Originalen Schaltung ist es auch so das die Spule vor der 
Transistor ist. Wenn ich das aber umdrehe und die Spule for den 
Transistor setze dann ist die ja immer auf Masse oder nicht?

Den Optokoppler habe ich so aus der ursprünglichen Schaltung übernommen. 
Ist das nicht ok so?

Ich habe leider gerade nicht den Plan der eigentlichen Schaltung zur 
Hand sonst würde ich den mal anhängen.
Werde ich noch mal nachholen.

@gawk (Gast)
ist das ernst gemeint? Ist bis jetzt noch nicht sooo anspruschsvoll.

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, wie gesagt, ich bin kein Elektroniker oder sowas.

Ich habe es jetzt zum laufen bekommen aber habe keinen Plan ob das so ok 
ist.

Ich wusste nicht dass man die Spule nur bestimmte Zeit laden darf.

In der Software habe ich den Pin für den Optokoppler getoggel.
Dadurch wurde erstens nur jede zweit Umdrehung gezündet und zweitens 
eine ganze Umdrehung die Spule geladen. jetzt habe ich mit _delay_us die 
Ladung begrenzt und jetzt wird der Transistor nicht mehr so heiß.
Er hat auch noch keinen Kühlkörper dran aber ich lasse ihn gerade in 
einer Schleife von 500 U/min bis 20.000 U/min hoch und runter laufen und 
das schon eine halbe Stunde, noch läuft alles und ich kann ihn immer 
noch anfassen.

Aber es macht mir noch ein bisschen Sorgen das ihr meint die Schaltung 
ist nicht ok so... aber es geht doch...

mfg
Florian

Autor: space (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

zünden Zweitakter nicht jede Umdrehung?
Das gibt nach längerer Motorlaufzeit aber
bestimmt einen netten Knall bei einer
Fehlzündung, abgesehen von der Minderleistung.
Stefan

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit der Ladezeit der Zündspule hat folgenden Hintergrund, die Spule 
hat einen induktiven und einen ohmschen Widerstand, sobald das 
Blechpaket gesättigt ist geht der induktive Widerstand gegen null und es 
wirkt sich nur noch der ohmsche Widerstand aus. Wodurch der Strom sehr 
schnell und stark ansteigt.

z.B. 14V / 0,5 Ohm = 28A und das schaffen die wenigsten Transistoren bei 
so einer hohen Spannung. Wenn die Spule also nicht in die Sättigung 
getrieben wird liegt man je nach Spule bei etwa 5-10A was leicht zu 
managen ist.

Ich würde aber nicht den Hochlauf 500-20.000 U/Min simulieren sonder 
eher eine hohe Drehzahl im Dauerlauf testen also so 15.000 U/Min oder 
sogar den Worst Case also 20.000 U/Min Dauerlauf testen.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nee, Zweitakter zünden jede zweite Umdrehung. Wie der Name schon sagt... 
:-)

Autor: Bosch ist teuer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast

 Du Spaßvogel !

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gibt aber verschiedene Arten von Zündspulen. Moderne 
Hochleistungszündspulen werden natürlich mit konstanter Ladezeit 
betrieben (wobei konstant auch nicht stimmt, da z.B. die Bordspannung 
mit verrechnent wird) aber im Prinzip ja. Im Bereich um die 3ms.
Die Ursprünge liegen aber in der direkten Kontaktzündung d.h. konstanter 
Schliesswinkel. Und das wiederum bedeutet, dass man aufpassen muss, dass 
man die Zündspule im unteren Drehzahlbereich nicht überlastet, im 
Extremfall sogar damit klar kommen muss, das Zündung ein, Motor steht 
und Unterbrecher geschlossen ist, also Dauerstrom duch die ZS...
Umso dünner wird die Zündenergie im oberen Drehzahlbereich, es steht 
nicht mehr genug Ladezeit zur Verfügung.

Autor: Johannes S. (demofreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. schrieb:
> Ich würde aber nicht den Hochlauf 500-20.000 U/Min simulieren sonder
> eher eine hohe Drehzahl im Dauerlauf testen also so 15.000 U/Min oder
> sogar den Worst Case also 20.000 U/Min Dauerlauf testen.

Eben drum würde ich Dauerlauf mit reichlich Leerlaufdrehzahl testen. Da 
wird es ja am heisstesten.

/Hannes

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man sollte erstaml ne Zündspule finden die schnell genug lädt um auch 
bei 20.000 U/Min vollständig geladen werden kann. Und die Ladezeit 
sollte dann konstant gehalten werden, bzw. Batteriespannungsabhängig 
etwas kompensiert werden. Was dann beim Start z.B. die Ladezeit 
vergrößert weil der Anlasser die Bordspannung runterzieht.

Die Ladezeit sollte ja ansonsten konstant gehalten werden egal ob man 
500 U/Min oder 20.000 U/Min fährt. Bei 20.000 U/Min wird der Transistor 
allerdings öfter umgeladen was ihn zusätzlich erwärmt da es hier schon 
auf ne gute Ansteuerung ankommt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.