www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR32Linux - Verbindungsaufbau durch AVR32Studio nicht möglich


Autor: gastli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich verwende ein virtuelles Ubuntu in einer VMware. Das Gastsystem für 
die VMware (im "bridged"-Modus) is WindowsXP.
Der PC mit dem Gastsystem ist an einem Router (mit DHCP server) 
angeschlossen. Zusätzlich ist noch mein AVR32Linux-Board (STK1000) an 
diesem Router angeschlossen.
Das Ping senden funktioniert in beide Richtungen einwandfrei (vom 
virtuellen Ubuntu zum AVR32Linux-Board und umgekehrt).

Um mit dem AVR32Studio debuggen zu können, habe ich wie in den Tutorials 
(u.a. im Cheat Cheet vom AVR32Studio) die Einstellungen für "remot linux 
debug launch" vorgenommen und die IP vom AVR32-Board angegeben. Bei der 
nachfrage für user_ID und Passwort habe ich "avr32" eingegeben.

Jedoch bekomme ich beim Verbindungsversuch immer wieder diese 
Fehlermeldung in der Console vom AVR32Studio:
220 ProFTPD 1.3.1 Server (ATSTK1000 FTP server) [::ffff:192.168.178.27] 

USER avr32 
331 Password required for avr32 

PASS ****** 
530 Login incorrect. 

NOOP 
200 NOOP command successful 

QUIT 
221 Goodbye.

Ich hoffe mir kann jemand einen Tipp geben, was ich falsch mache. 
Außerdem würde mich mal interessieren wie ihr eure AVR32Linux-Bords 
anschließt. Also ob über einen Router oder direkt per Ad-hoc-Verbindung.

Autor: gastli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es sein, dass man den Zugriff über das Netzwerk erst mal irgendwie 
im EvalBoard freischalten muss? Also ähnlich wie es bei zwei PC ist, die 
gegenseitigen Zugriff genehmigen müssen?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich vermute mal es ist kein Password vergeben oder ein Anderes.

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Default Passwort für avr32 kenne ich zwar nicht aber es ist 
gesetzt... also über die Serielle Schnittstelle folgendes eingeben:

     passwd avr32

Dann kannst du ein neues vergeben.
bzw. löschen wenn du einfach nur ENTER drückst

falls das nicht geht probiers mit dem root account und setz den pfad auf 
/home/avr32

Passwort müsste roota sein.

Ansonsten einfach über serielle Verbindung:

     passwd


eingeben ;)

Gruß Christian

Autor: Oliver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hat sich wahrscheinlich bereits erledigt,
aber das default Passwort fuer User "avr32" ist "avr32!" (ohne ""). 
Wichtig ist das "!" am Ende des PAssworts,

br,
Oliver

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.