www.mikrocontroller.net

Forum: Digitale Signalverarbeitung / DSP Probleme einen Freescale DSP56364 zum Laufen zu bekommen


Autor: Cf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

erst einmal bin ich recht neu im Gebiet der DSPs, also entschuldigt 
bitte mein Unwissen in einigen Bereichen.

Ich arbeite momentan an einem Gerät, welches einen Freescale DSP56364 
benutzt.
Dieses Gerät hat bereits eine Zeit lang funktioniert, bis es irgendwie 
defekt ging. Mit einem Oszilloskop habe ich herausgefunden, dass die 
Signale meines Boards beim DSP enden. Daher vermute ich, dass dieses 
Bauteil defekt ist.

Da ich ein Ersatzbauteil hatte, habe ich es auf das Board gelötet, aber 
leider wurde damit das Problem nicht gelöst.
Um den DSP näher zu analysieren, besorgte ich mir ein JTAG-Kabel 
(Wiggler-Nachbau für Parallel-Port) und hab es mit den entsprechenden 
Pins des DSPs verbunden.
Ich habe damit sowohl UrJTAG als auch Suite56 (mit dem Command Converter 
Server) ausprobiert, um auf den DSP zuzugreifen, doch es sieht so aus 
als ob beide Programme ihn nicht finden können. UrJTAGs "detect" Befehl 
endet ohne Geräteliste und mit der Meldung "TDO seems to be stuck at 1" 
während Suite56 nur eine Meldung "Unable to communicate with default 
device" ausgibt.

Die Eingangsspannungen habe ich bereits überprüft und sie sehen alle 
soweit richtig aus.

Meine Fragen nun:
- Was kann ich sonst noch ausprobieren, um zu prüfen, ob der neue DSP 
funktioniert oder ebenfalls defekt ist? Gibt es da beispielsweise ein 
paar Test-Pins zum Prüfen?
- Ich habe gehört, dass diese Serie DSPs besonders anfällig für 
elektrostatische Entladungen ist, sodass vielleicht beide DSPs dadurch 
kaputt gegangen sind. Hat jemand diesbezüglich ähnliche Erfahrungen?
- Ich habe noch einen weiteren Ersatz-DSP hier. Wie kann ich am 
einfachsten prüfen, ob dieser funktionsfähig ist ohne zu riskieren, dass 
ich ihn (z.B. durch falsches Löten) auch beschädige? Möglicherweise ist 
ja die ganze Ladung DSPs, die ich erhalten habe, defekt... :-/

Vielen Dank im Voraus!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.