www.mikrocontroller.net

Forum: Compiler & IDEs Win avr gcc will nicht


Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi
ich hab mir das neue avr Studio draufgespult. Win avr ist auch da.
Leider läßt sich nun mein code(s) nicht mehr übersetzen. Bei meiner 
ersten installation war das auch schon so, das hat sich aber dann 
irgentwie von alleine behoben.
hir mal der Fehler
../12212.c:17: fatal error: opening dependency file dep/12212.o.d: No 
such file or directory

Die file ist aber da und ich kann sie auch mit devcpp öffnen. ich habs 
auch schon mit "make all" versucht, also nicht aus dem avr Studio 
heraus. Geht aber auch nicht.

Ich hab das STK500 und das wird auch geladen.

hat da einer nen Tipp.

mfg

: Verschoben durch Moderator
Autor: oki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hat sich die Spule beim Spulen verklemmt...

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lösche mal das gesamte Verzeichnis dep/.  Darin werden die automatisch
generierten Abhängigkeiten für das Makefile erzeugt.  Wenn sich da
was verklemmt, hast du sonst ein Henne-und-Ei-Problem: solange das
Makefile noch nicht funktioniert (weil es dort eine seiner per .include
reingezogenen Dinge nicht findet), läuft make nicht los und kann diese
Dateien damit auch nicht neu erzeugen.

Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab mal alle dep Verzeichnisse die ich gefunden habe gelöscht. Ohne 
Erfolg
Eine Neuinstallation brachte auch nicht das gewünschte Ergebnis.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann rufe mal ein "make clean" auf und gib uns das ganze Projektver-
zeichnis hier als Datei-Anhang, damit wir uns das angucken können.

Autor: Alf Tenner (rumkugeln)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich hab mal den ganzen fehlertxt mit dazugepackt.
Ich hoffe mal ich hab das richtig mit dem Projektverzeichnis verstanden.

mfg

Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat keiner ne Idee

funktioniert das Makefile bei euch?
Ich hab win avr von der Seite hier. Ist das das richtige?
http://winavr.sourceforge.net/

weiterhin hab ich mir das avr studio hier vom direktlink geholt
http://www.mikrocontroller.net/articles/AVR-Studio

passen die zusammen?

gibt es noch andere Programme zum übersetzen von c Code in hex?

mfg

Autor: Oliver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>funktioniert das Makefile bei euch?

"child died" hat nicht mit dem makefile zu tun, da stimmt die 
Installation nicht.

Tipp mal "which make.exe" in das Fenster, und schau, ob das richtige 
make gefunden wird (das aus dem WinAVR-Paket).

Oliver

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"fork: resource temporarily unavailable" -- da ist irgendwas im
Betriebssystem am Limit, ein neuer Prozess kann nicht mehr
gestartet werden.

Das Projekt selbst kann ich (mit den bereits bei dir zu sehenden
Warnungen) hier auf meinem FreeBSD problemlos compilieren.

Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>da ist irgendwas im Betriebssystem am Limit
also da ist vista drauf. Hab seitem ich win avr,avr Sudio draufgespult 
habe in der Sidebar komische grafikfehler.

An der hardware kanns nicht liegen, das ist ein
amd 9750 quad
8 gb ram
2 grafikkarten
2 500gb festplatte raid0


mfg

Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>which make.exe

ergibt

C:\WinAVR-20080610\utils\bin\make.exe

sollte doch eigentlich das richtige sein(woran erkenne ich das).

mfg

Autor: Oliver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist das richtige -

aber nicht das neueste. Installier doch mal die aktuellste Version von 
WinAVR. 2009-irgendwas.

Oliver

Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du meinst 20090313

http://sourceforge.net/project/showfiles.php?group...

hoffentlich geht das mit vista 64

mfg

Autor: Oliver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beitrag "WinAVR und Windows Vista"

Vielleicht hilfts...

Sonst muß du Tante gurgel bemühen.

>An der hardware kanns nicht liegen, das ist ein
>amd 9750 quad
>8 gb ram
>2 grafikkarten
>2 500gb festplatte raid0

Auf meinem Duron 1300 mit 256MB Ram und Mainboard-Grafik läuft es unter 
Windows 2000 einwandfrei :-)

Oliver

Autor: Alf Tenner (rumkugeln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für euere Hilfe

>Beitrag "WinAVR und Windows Vista"

>Vielleicht hilfts...

die im Beitrag angegebene .dll funst klasse.

>Auf meinem Duron 1300 mit 256MB Ram und Mainboard-Grafik läuft es unter
>Windows 2000 einwandfrei :-)

Ich hab auch noch nen alten xp Rechner AMD 3200+, der war aber zu laut 
also hab ich so lange rumgeschraubt bis er jetzt ab und an nen 
hitzschlag bekommt. Es geht nichts über nen Heatpipekühler mit 12-14. 
Lüfter, auser vielleicht nen ölpc. So einen hab ich auch schon gebaut 
war aber ne riesen Sauerrei.

http://kingdonderguru.ki.funpic.de/Bilder/%d6lvdr/...
http://kingdonderguru.ki.funpic.de/Bilder/%d6lvdr/...
http://kingdonderguru.ki.funpic.de/Bilder/%d6lvdr/...
http://kingdonderguru.ki.funpic.de/Bilder/%d6lvdr/...

mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.