www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Aufstart versuch von einen Quarz


Autor: Nicco (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich bin nicht ein Guru von Quarze, darum hier meine Frage:

Was kann ein Quarz den Start verhindern?
Mein RFID reader von TI (TRF7960) hat das folgende:
ein Enable bit in eingang ein Clock output und die Anschlüsse für ein 
Quarz(OSC_I, OSC_O). Nach das setzen von der Enable pin, soll der Quarz 
schwingen.
Auf der Clock output, solange der Quarz nicht gestartet wird, gibt es 
eine 60khz Frequenz.
Nun ist es so dass es nicht funktioniert. Wie auf den Bild dargestellt, 
versucht den Quarz zu starten, aber bricht ab.
Ich hab Quarz typ und Cap. wert gewechselt, ohne Resultat.
Auf einen Evaluation board funktioniert das ganze perfekt, das einzige 
unterschied ist der quarz selber, welches in einen HC49 case ist.
Nach TI soll der Oszillator die folgende parameter haben:
Parameter Specification
Frequency 13.560000 MHz
Mode of operation Fundamental
Type of resonance Parallel
Frequency tolerance ±50 ppm
Aging < 5 ppm/year
Operation temperature range –20°C to 70°C
Equivalent series resistance 50 ohm, maximum

Da wir wenig Platz haben, habe ich das folgende gewählt (SMD Package):
http://www.jauch.de/ablage/med_00000357_1224147297...
Ich verwende 22pF Kondensatoren.

Vielleicht etwas mit der ESR Wert? Irgendwelche Strombegrenzung?
Oszillator, Cap. sind nicht in der nähe von digital signals, und stehen 
etwa 8mm vom chip. OSC_O ist fix auf ein wert von 1.6V, OSC_I auf null. 
(Was eigentlich auch auf 1.6V sein soll, oder?)

Für irgendwelche Idee bin ich sehr dankbar.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> das einzige unterschied ist der quarz selber ...
Ist das sicher? Und das Layout?

Autor: Helmut -dc3yc (dc3yc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verringere doch mal deine Kondensatoren. Welcher Wert ist auf dem 
Entwicklungsboard? Gehe mal auf 15pF und wenn das nicht geht, auf 10pF.

Servus,
Helmut.

Autor: Nicco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich meine von der Bedienung von der TRF7960 her (Der wird von einen uC 
gesteuert).
Ich schrieb es um der Controller-Teil auszuschliessen (Enable bit reset 
oder irgendwas anders).
Layout mässig ist der Quarz auf die EVM etwa 15mm entfernt und hat Masse 
rundherum. Bei uns liegt es etwas näher und hat in der nähe nur sie 5V 
Speisung.

Autor: Nicco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Bild stammt aus einen Versuch mit 10pF.
Mit 22pF ist es schlechter: nur 2-3 Schwankungen bevor es abbricht. Nach 
etwa 400-500 us gibt es ein weiteres versuch...
Ich hab jetzt andere C werte bestellt und morgen werde ich weitere 
versuche machen...

Auf dem Entwicklungsboard gibt es ein:
http://search.digikey.com/scripts/DkSearch/dksus.d...
mit 27pF Cap.

Autor: Achim S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

dein Quarz soll mit 13,56MHz schwingen, bei der Messung spendierst du 
dem Oszilloskop aber nur eine Abtastrate von 1MS/s (oder interpretiere 
ich deine Scope-Anzeige falsch?).

Das heißt, du hast nur in jeder dreizehnten Oszillation einen einzigen 
Messpunkt, und damit können einem alle möglichen Artefakte angezeigt 
werden. Sieht die Kurve gleich aus, wenn du die Sampling-Rate ordentlich 
nach oben drehst?

schöne Grüße

Achim

Autor: Nicco (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Achim,
du hast recht, ich muss auch nicht alles perfekt darstellen, mir genügt 
es  dieses Quarz zu starten.
Trotzdem hab ich noch zwei Bilder:
Die einte mit ein grösseres sampling ratio...[see next post]

Autor: Nicco (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...[from prev. post]die andere mit den Signal auf die EVM (Übergang von 
60kHz auf 13.56MHz, die 13.56 MHz sind nicht korrekt dargestellt wegen 
den kleinen Ratio...)

Autor: Achim S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke Nicco,

ich hatte gedacht, dass möglicherweise der Oszillator läuft und nur die 
Messung das falsch anzeigt. Aber das ist offensichtlich nicht der Fall.

Auch an den Stellen, wo die 70kHz von was höherfrequentem unterbrochen 
werden (... wo der Oszillator zu starten versucht...), deutet nichts auf 
13MHz hin. Kannst du ausschliessen, dass es nicht einen "trivialen" 
Fehler gibt? Z.B. im Layout die falschen Pads des vierpoligen Gehäuses 
angeschlossen? Oder beim Löten des SMD-Gehäuses an einem Pad keinen 
zuverlässigen Kontakt erzeugt?

schöne Grüße

Achim

Autor: Nicco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen, ich bin so weitergekommen dass ich einen verdächtigen 
habe:

Der ESR wert (serie resistance) ist bei kleinere (Case) grösser als bei 
z.B. HC49.
Ich hab versucht dieses Fehler nachzumachen, und habe bei meinen 
Evaluation Board der HC49 raus gelötet und ein Poti (0-1k) eingebracht. 
Beim hoch schrauben (bis auf etwa 145ohm, aber mit geänderten 
Bedingungen) habe ich ähnliche Signale wie auf unseres Hardware.

Mittlerweile hab ich weitere Quarze bestellt, mit tieferen ESR Werte 
(werde aber die werte von HC49 nicht erreichen), auch mit ein etwas 
grösseres Case als der Original JXS32. Hoffentlich wird das 
funktionieren :)

Hat jemand sonst eine Meinung betreffend ESR? Gibt es eine zauberhafte 
Möglichkeit dieses wert unterzukriegen oder ist die einzige Lösung den 
Case zu vergrössern?

PS an Achim: Quarz ist sauber gelötet worden, und ich habe den Case als 
test 'grounded'.

Autor: Bogumil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann schau mal bei den US-Gurus

Crystal Oscillator Basics and Crystal Selection for rfPIC and ...

http://ww1.microchip.com/downloads/en/AppNotes/00826a.pdf

Autor: Nicco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mmmh, ist doch vielleicht der IC kaputt... Ich warte auf einen neuen 
hardware und werde es neu testen, werde noch Bescheid geben.
Danke soweit für eure tips!

Autor: Nicco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also nach weitere Test habe ich festgestellt dass effektiv nach lange 
umprobieren, der chip kaputt gegangen ist.
Im Moment lohnt es sich nicht den Fehler nachzugehen, hoffentlich wird 
es nicht mehr vorkommen.

Also, besten Dank für eure mithilfe! Ich hab sowieso viel über 
Oszillatoren gelernt :) mindestens das!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.