www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Eagle getrennte Stromnetze


Autor: Christopher G. (cbg)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich plage mich gerade mit Eagle 4 und stehe nun vor einem Problem, dass 
ich selber (und mit der Suchmaschine meiner Wahl) nicht lösen kann. SuFu 
hat auch nicht das was ich wollte ausgespuckt, da ich nicht genau weiß, 
wonach ich suchen soll.

Ich hab auf meinem Board 4 Flachsteckerkontakte, jeweils 2 für GND und 
+24 V.
Jezt möchte ich, dass ich diese als getrennte Netze verwenden kann, aber 
mit dem praktischen +24 V Symbol. Soll also so aussehen, wie im Anhang 
aber mit getrennten Netzen. Wie es jetzt ist, verbindet er mir die 
beiden +24 V Kontakte, wie kann ich das verhindern?

TIA

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich mich recht entsinne: Nimm einmal das 24V-Symbol aus der 
'supply1'-Bibliothek und einmal das aus der 'supply2'-Bibliothek.

Autor: Kevin K. (nemon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kennzeichne lieber das eine symbol mit 24V_1 und das andere mit 24V_2

vermutlich geht obiger tip nicht, da beide symbole das netz in 24V 
umbenennen, diese werden somit verbunden. es gibt in der supply-libary 
aber das symbol +24P, dieses benennt das netz in +24P um

Autor: Christopher G. (cbg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kevin K. schrieb:
> kennzeichne lieber das eine symbol mit 24V_1 und das andere mit 24V_2
Hab ich schon probiert, geht leider nicht. Drum hab ich die Labels auch 
reingegeben, hab aber vergessen es im Post zu schreiben. Er benennt es 
automatisch in +24V um ohne Warnung o.Ä.

@Sven: Muss ich dann ausprobieren.

Ich hab auch schon probiert die supply1 lib zu kopieren und eine eigene 
zu machen. Hab dann das Symbol +24V dupliziert und als +24V_2 eingefügt 
wobei ich das SwapLevel auf 1 geändert habe. Weiß leider noch nicht 
genau, was das SwapLevel bringt, hab gerade erst mit Eagle angefangen. 
Dazugehöriges Package hab ich natürlich auch gemacht, hat aber nichts 
gebracht. Im Board sind sie trotzdem verbunden.

Edit: Von mir aus kann das +24V Symbol auch weg. Ich will einfach keine 
Leitungen verlegen, sondern wie bei LTSpice per Label verbinden, da 
beides häufig verwendet wird.

Autor: Christopher G. (cbg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs nun geschafft.
Das mit dem SwapLevel war natürlich Schwachsinn.
Hab in meiner Supply Lib vergessen den Pin umzubenennen, deswegen hat er 
immer aufs normale GND bzw +24V verbunden.
Pin umbenannt und nun sinds 2 getrennte Netze mit eigenem GND.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.