www.mikrocontroller.net

Forum: Platinen 3D Model Erstellen im Altium Designer


Autor: Markus S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen
ich bin es wiedermal;)
Ich habe wieder eine Frage und zwar, wie kann ich ein 3D Model für einen 
Footprint erstellen. Hat da der Altium Designer Winter 09 ein extra Tool 
dafür oder müssen die 3d Dateien mit einem anderen Tool erstellt werden?

Ich habe schon danach gegooglet, jedoch nichts herausgefunden.
Ich bedanke mich jetzt schon für eure Antworten..

mfg Markus

Autor: Andi ... (xaos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was verstehst du unter "3d dateien" ?
ruf doch einfach eben beim altium support an, die können dir das sofort 
und auf jedenfsll korrekt beantworten

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das geht so:

in der PCB Lib das Bautteil(Footprint) anwählen, dann über Place->3D 
Body.
Da kannst du Dir aussuchen, ob extruded(selbst erstellt) oder .step 
Datei einbinden etc. Du solltest Dir noch den Layer auswählen.
Danach Speichern Fertig!

Aber der Support hilft auch gern. Sowie die Videos sind gut oder die 
pdf!!

Gruß Tom

Autor: ecslowhand (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne STEP-Modell am Besten den Umriss des Bauteils im Bauteileditor auf 
Mechanical 13 zeichenen und dann über "TOOLS-Manage 3D Bodies for 
Current Component.." die Parameter wie Höhe, Farbe, etc. editieren.

EC

Autor: Tobias Plüss (hubertus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man will, dann kann man auch hier http://www.3dcontentcentral.com/ 
zu fast jedem beliebigen Bauteil ein Step-Model runterladen, das sich 
nachher im Altium einbinden lässt. Damit lassen sich dann echt tolle 
3D-Bilder der fertigen Platine erzeugen.

Autor: Markus S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich danke für die hilfreichen Antworten.
auf http://www.3dcontentcentral.com/ habe ich schon einige Bauteile 
gefunden, sehen also gut aus.
Jedoch wenn ich nun von 2D auf 3D wechsle sind die Bauteile grün wie 
könnte ich das ändern?
oder wenn ich auf tools-->Legacy tools-->Legacy 3D wechsle verschwinden 
meine Bauteile welche ich hinzugefügt habe..
Ich hoffe da weiss jemand mehr.

mfg Markus

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das grüne kommt entweder vom Bauteil selbst, oder vom DesignRuleCheck, 
wenn du z.B. Bauteile verwendest, deren Höhe die maximal zulässige Höhe 
aus den DR überschreitet.

Auf den Legacy3D würd ich komplett verzichten, denn der packt das mit 
Step-Files nicht so richtig und kommt auch mit den Höhendefinitionen 
durcheinander (Höhendefinition des Footprints gegen Definition der 
3D-Bodys, etc.). Von einem Step-Export des Legacy3D will ich gar nicht 
reden :)

Ralf

Autor: Markus S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Ralf, dass hat mir sehr geholfen, die Regeln waren richtig 
eingestellt, jedoch musste ich ein Design Rules Check machen und dan 
verschwand die grüne farbe...

jedoch möchte ich nun noch ein Phoenix Stecker importieren, aber da 
kommt jedes mal ein Fehler wie folgt:

Access violation at address 1773D0E6 in module 'ADVPCB.DLL'. Read of 
address 00000000 at 1773D0E6.

Exception Occurred In
PlaceComponentBody

Liegt das am File?

mfg Markus

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der Fehler nachvollziehbar ist, also immer kommt, dann liegts wohl 
am Modell. Poste mal deine AD Version, und häng hier das Phoenix Modell 
rein, ich gucks mir mal an.

Ralf

Autor: Markus S (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den Altium Designer Winter 09

Und angehängt ist das Modell, alle anderen Modelle von Phoenix haben 
funktioniert, also kann es gut sein, dass es am Modell liegt.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fehler tritt bei mir ebenfalls auf (auch AD W09).
Im SolidWorks 2007 kann ich's auch nicht öffnen, das schmiert auch ab. 
Dann liegts wohl am Modell.

Ist das diese Phoenix Bestellnummer? 1803439

Soweit ich das bei Phoenix sehen kann, gibts evtl. für das gleiche 
Bauteil mehrere Modelle wegen den Farben -> wobei, wenn sie Farben 
hätten reinbringen wollen, dann hätten sie Step AP214 verwendet und 
nicht AP203.

Ralf

Autor: Markus S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja genau, dass ist dieses Bauteil von Phoenix, die ganze Reihe 
funktioniert nicht, also der 15Polige verwende ich auf meinem Design 
auch, aber bei dem passiert das gleiche..
Könnte man das auch anders importieren? wäre also genial...

kann man den bei AP214 im Altium die Farbe ändern? ich habe alle 
Bauteile in AP214 runtergeladen...

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich frag bei Gelegenheit mal die Kollegen aus der Mechanikabteilung, die 
haben das Swx2009, vielleicht kann man damit noch was "retten".

AP203 und AP214 sind die STEP-Formate. Während AP203 nur ein Teil 
definiert (und somit nur einfarbig sein kann), ist AP214 für Baugruppen, 
also mehrere Einzelteile ausgelegt.
Im AltiumDesigner kannst du da nix dran drehen, die 3D Funktionen sind 
da eher rudimentär. Ist ja auch ein Layout- und kein 
3D-Konstruktionsprogramm.

Ralf

Autor: Markus S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nun Phoenix das Problem geschildert und haben den Fehler sofort 
behoben.
Also danke für deine mühe Ralf.

mfg Markus

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Roger...

Ralf

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.