www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio findet STK500 nicht


Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm. Seit heute morgen findet AVRStudio mein STK 500 nicht mehr (bah auch
schon über Kommandozeile stk500.exe) benutzt.

Das Kabel ist nicht schuld. (Habe testweise mal Pin2 und 3 am Kabel
überbrückt)

Das einzigste was ich getan habe ist das ich aus Versehen im Betrieb
den Stromstecker herausgezogen habe.

Kann da irgendwas kaputt sein?

Autor: BioSniper (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Prüfe doch mal ob Deine serielle Schnittstelle noch in Ordnung ist.

mfg

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Öhm habe ich schon. Kabel dran Pin2 und 3 mit draht "kurzgeschlossen"
und UartMonitor zeichen gesendet und zurückbekommen..

Autor: BioSniper (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht mal die Software neu installieren, ansonsten wird wohl doch
etwas kaputt sein.

mfg

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt auch mal testweise AVRStudio/STK500 an einem anderen Rechner
ausprobiert mit genau so wenig Erfolg.

Ich hoffe nicht, dass das STK kaputt ist... mein Prof wirds nicht
freuen

Autor: BioSniper (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch so ein Board seit 2 Jahren hier rumliegen, aber es noch
nie benutzt, ich schaue eben mal nach was da so alles drauf ist.

Vielleicht überprüfst Du mal ob da überhaupt Spannung ankommt, da ist
ein Gleichrichter, kannst ja mal messen ob da was raus kommt.

Ansonsten wird es bestimmt schwierig, da sind ja einige grosse smd
Elemente drauf.

mfg

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das Board hat soweit Spannung. Es bootet anständig hoch, mein altes
Programm im 4433 funktioniert noch...

Autor: Walter B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Starte im Unterverzeichnis des AVR Studios mal von Hand das Firmware
Update für das STK500.

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gibt nur aus:
Error: Programmer not found...

Autor: hebel23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Olli,

da ist bestimmt der 8535 hin, war bei mir auch mal genau das gleiche
Problem. Nach einem Tausch und einem neuen Firmwareupgrade ging´s
wieder.

Gruß Andreas

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
falls du einen 8535 im TQFP brauchst, melde dich bei mir. Komischerweise
manchmal schwierig beschaffbar.

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm. Ne ist nen 4433 drin. Aber hab hier noch nen Tiny12 rumfliegen.
Werde den µC mal tauschen und das ganze nochmal probieren

Autor: hebel23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nee Olli,

da hast Du was falsch verstanden. Es geht um den 8535, der neben dem
1200 auf´s Board gelötet ist und dort seine Arbeit verrichtet, indem er
die Verbindung zum PC herstellt und die die Peripherie im STK500
steuert..

Gruß Andreas

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da habe ich echt etwas falsch verstanden. Aber nichsdestotrotz findet
das AVRStudio das STK500 wieder wenn ich einen Tiny12 reinstecke.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
verstehe ich jetzt auch nicht, normalerweise kann man mit dem STK
kommunizieren und Spannungen und Takt einstellen, ohne dass da ein
weiterer zu programmierender Chip drauf ist. Egal, Hauptsache,
funktioniert wieder.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.