www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik max1415 schwingt nicht an


Autor: Weingut Pfalz (weinbauer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forengemeinde,

ich hab mal wieder ein Problemchen, diesmal mit nem Max1415.
Ich möchte ihn an nem Mega128 betreiben.
Die SPI-Kommunikation läuft, soweit auch tadellos,
die Register lassen sich beschreiben und auch problemlos
zürücklesen, soweit so gut, aber der ADC läuft nicht.
Nach der Initialisierung bleibt der Wert statisch, immer auf
dem gleichen Wert. Manchmal hängt er auch Ewigkeiten in der
Initialisierung ...
Das Ding soll auf dem internen OSC laufen, auf 1 MHz, die
CLK In und CLK Out sind unbeschaltet, Out sollte demnach
die 1 MHz Clock bringen (klar, je nach Konfiguration),
bringen tut er aber dort Pulse nur, wenn die SPI-Kommunikation
läuft (siehe Anhang, CH1=CLK Out, CH2 = SCLK) ...
Kennt jemand nen Trick, das Ding sicher zu starten?

Autor: Weingut Pfalz (weinbauer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oops, da hab ich dem Dateinamen die Bezeichnung vom pinkompatiblen 
ad7705 gegeben,
es ist aber definitiv der max1415

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.