www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit 74HC00


Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe ein Problem mit dem 74HC00. Ich betreibe diesen mit 3.3 Volt.
Doch ein aktierter Ausgang liefert immer nur ca. 2.2 Volt. Ist das
Normal? Ich verwende ihn im ISP Teil der Schaltung. Ab wann erkennt der
AVR das Reset Signal als High, also inaktiv? Zurezeit bekommt er Aktiv 0
Volt, inaktiv 2.2 Volt. Ich glaube das ist zuwenig und desshalb lässt
sich der Avr auch nicht programmieren. (?)

MFG Nik

Autor: Zotteljedi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Datenblatt vom HC00 ist die Spannung am aktiven Ausgang relativ
gleich VCC, sollte also wohl um die 3 Volt bei Dir liegen. Mal einen
anderen probiert, falls der was abbekommen hat?

Im Datasheet vom ATMega8 heißt es, daß der RESET als High gilt, wenn er
mindestens 0.9 VCC bekommt (ich nehme mal an, es bedeutet 0.9 * VCC)
also wenn er bei Dir mit 3.3 Volt läuft wären das 3 Volt, Maximum ist
VCC + 0.5 Volt. Die anderen Pins haben übrigens ein kleineres Minimum,
RESET hat eine Extrawurst.

HTH, Felix

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi Zotteljedi!

Danke schön für die Erklärung. Die 0.9 Volt hab ich im Datenblatt auch
gefunden, kam mir aber ein bisschen wenig vor...
Dann würde es stimmen(2.2 Volt sind also zu wenig) Ich hab zum glück
noch ein paar  mehr von den 74hc00 da..ich werd mal ein bisschen
durchprobieren.

MFG Nik

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...sooo, also ich hab mal 5 weitere ausgetestet. Immer dasselbe.
Eigentlich kann ich Fehler im Schaltplan ausschliessen, denn es handelt
sich um die Easy Tcp/Ip Platine von www.elektronikladen.de
Ich versuchs einfach mal, indem ich den 74hc00 mit 5 Volt laufen lasse,
vielleicht kommen dann die benötigten 4 Volt raus ;)

MFG Nik

Autor: Helmut Weiß (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Nik,

das ist sicher nicht normal. Schwingt da etwas? Kann vorkommen, wenn
die Eingänge nicht ordentlich abgeschlossen sind, d.h. über Widerstände
oder direkt nach + oder Gnd gezogen sind. Oder ist der Ausgang zu stark
belastet?

Viele Grüße

Helmut Weiß

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

@all

Also irgendwie hab ichs nun hingekreigt. Ich hab das Gefühl, dass ich
zeimlich miese AVR's erwischt habe. Ausser der Reset pin bräuchte
wirklich auch zwingend 5 Volt. Denn damit gehts nun, unter 3.5 Volt
erkennt er das als 0, bzw aktiv und resettet brav...
Auf jedenfall hab ich nun halt n modifiziertes EasyTcp Ip Platinchen,
aber es geht. Vielen Dank für eure Hilfe..Ich bau das Easy Tcp/ip nun
zum zweiten mal auf..das erste Mal ist's abgeraucht:(
Nun hab ich das Gefühl, dass ich langsam  aber sicher den Durchblick
habe...wenn also jemand Fragen zum Easy Tcp/ip hat..stellt sie mir
ruhig :)

MFG Nik

Autor: Zotteljedi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt, beim ATMega8 scheinen es 90% der Spannung zu sein, mit der
der AVR läuft. Wieviel Du ihm gibst hast Du ja nirgends geschrieben. Da
dies als Minimum angegeben ist, würde ich mich grob beschissen fühlen,
wenn ein AVR, mit 5 Volt betrieben, bereits bei 3.5 Volt etwas tut, das
er laut Datenblatt erst bei 4.5 Volt dürfte.

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich bins nochmals.

Also irgendwie funzt etwas anderes nun nicht. Tut aber nichts weiter
zur Sache, ich bräuchte 'nur' einen Spannungsteiler, der aus 5 etwa
3.3 Volt macht. Die Kombination 1.8 kOhm /3.3 kOhm geht bei mir aber
nicht, dabei entsehen lediglich ca. 1.8 kOhm. Ich denke mal dass bei
zwei gleichen Wiederständen die Spannung halbiert wird. mit zwei 3.3
kOhm gäbe es also ca. 2.5 Volt (?) Naja..wie mach ich dass jetzt, wenn
ich mehr möchte, als die 2.5 Volt.

@Zotteljedi

Achso..ich hab dich dann also ein bisschen falsh verstanden..ich meinte
dass er mit ca. 3 Volt ansprechen sollte (nach deiner Rechnung) Jedoch
scheinen mir die 4.5 Volt nun auch irgendwie logischer :)

MFG Nik

Autor: Helmut Weiß (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann mir kaum vorstellen, daß es schlechte AVR's in Serie gibt. Wir
setzen die pfundweise ein, und alle waren bisher gleich gut.
Schwierigkeiten gibt es eigentlich nur, wenn die Pins nicht nach
Datenblatt benutzt werden, z.B. Reset nicht definiert auf Gnd oder +
liegt. Ich meine +Betriebsspannung, nicht 3,5V bei 5V UB, und nicht 1V
wenn GND gefordert ist. Das gilt auch für die anderen Pins. Dann kann
ich mir noch vorstellen, daß die Fuses des AVR nicht richtig gesetzt
sind, oder auch ein Pin des AVR als Ausgang gesetzt wurde, der
eigentlich als Eingang benutzt werden soll. Dann könnte ein Output des
74HC00 und einer des AVR kollidieren.
Und wenn der AVR mit ca 3V noch läuft, dann könnte es ein L-Typ sein
??!!

mfg

Helmut Weiß

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

@Helmut Weiss
>Dann könnte ein Output des
>74HC00 und einer des AVR kollidieren.

Ja, aber ich hoffe nicht das es irgendwo ein Fehler hat...ich hab die
Platine ja nicht hergestellt/designed.

>Und wenn der AVR mit ca 3V noch läuft, dann könnte es ein L-Typ sein
>??!!

Nein, ist ein normaler, aber er läuft bei mir auch noch wunderbar mit 3
Volt.


Das mit dem Spannungsregler hat sich übrigens erledigt. Ich hab die
Formel auf de.wikipedia.org gefunden. Dabei kam dann ein 1 kOhm und 2.2
kOhm raus. Das gibt zwar auch nicht genau 3.3 VOlt, aber immerhin 3.4,
ist wesentlich näher dran als die 1.8 Volt :)

MFG Nik

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
opsala..spannungsteiler meinte ich eigentlich

Autor: Helmut Weiß (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

@ Nik Bamert

Daß zwei Ausgänge miteinander kollidieren muß kein Design-Fehler sein.
Es sei denn, die Hard- und Software sowie die Erweiterungen wurden
gemeinsam gekauft und richtig angeschlossen. Ich vermute eher einen
selbstgemachten Programmierfehler beim AVR. Da kann ich ja die Pins als
Ein- oder Ausgang definieren. Und wenn ich einen Pin einlese, so ist er
nicht automatisch als Eingang definiert, sondern muss mit Hilfe der
Register als Eingang definiert werden. Und dann ist so etwas schnell
passiert.

Viele Grüße

Helmut Weiß

Autor: octi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hey eine frage ich suche einen Logic IC 74HC00D.Wisst ihr vielleicht ob
es eine andere Beschreibung für ihn gibt?

Autor: Zotteljedi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Google gibt's den von Philips, im Datenblatt findet man 74HC00D
auch:
http://www.standardproducts.philips.com/products/h...
(Tabelle auf Seite 3 oben)

Sieht für mich nach einem stinknormalen 74HC00 in SMD aus, wie Du ihn
z.B. bei Reichelt als "SMD HC 00" für 20 Cent findest.

Jemand anderer Meinung?

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das 'D' im Namen steht für die Gehäusebauform (SO, PDIP, CDIP etc.)
und ist herstellerabhängig.
74hc00 stellen ziemlich viele Firmen her.

Autor: Zotteljedi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber die meisten scheinen in ihrer Angabe nicht auf das D zu bestehen,
googelnderweise fand ich nämlich als Herstellerangabe auf irgendwelchen
Stücklisten oder Bestellformularen immer Philips, selten gar nichts, und
fast nie was anderes (außer Mikroschema, falls das ein Hersteller ist,
und nicht irgendein normales russisches Wort).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.