www.mikrocontroller.net

Forum: PC Hard- und Software minix3 unter virtualPC


Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat jemand minix unter virtualPC am Laufen?
Die Installation läuft problemlos, aber leider habe
ich gerade das Problem, dass die Zeichen | (für die pipe)
sowie Klammerpaare [],{} über ALT-key nicht erreichbar sind.
Die Tastatur ist auf german.map eingestellt.

Würde mich sehr freuen falls mir jemand helfen könnte.

Grüsse

Autor: hp-freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist der Tastatur Treiber wirklich geladen?
Probier mal:

loadkeys /usr/lib/keymaps/german.map

...
hp-freund

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Vorschlag. Das Problem besteht aber weiterhin.
Ich denke die deutsche Tastatur ist schon richtig geladen.
Denn zuerst bei der Installation, als ich "ls -l" eingetippt
habe, kam "ls /l" raus. Das war noch die englische aktiv.
Nach der Installation war "-" richtig.

{[]} erreicht man aber über ALT-<7,8,9,0> Zeichen
Ich tippe darauf, dass die ALT Tastenkode von Minix
bei meiner Tastatur nicht richtig erkannt wird.
Auf den Bildschirm wird dabei kein Zeichen ausgegeben, ganz
so als ob das Zeichen vom System "verschluckt" wird.

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
update: ich habe gerade freeBSD in virtualPC installiert. Auch
hier zeigt sich dasselbe Problem.

Zu meiner Hardwarekonfiguration: Samsung P500 Laptop mit einer externen
USB Tastatur. Die Zeichen |(pipe) sowie Klammer {[]}, lassen sich
aber mit keiner Tastatur "auf den Bildschirm ausgeben" (shell oder
ein Editor).

Autor: hp-freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sollte das die Lösung sein?
Hab ich in einem anderen Forum gefunden:

Alle Zeichen die am PC unter der ALT/GR Taste stecken sind unter 
VirtualPC unter CTRL+ALT, der Rest ist wie am PC.

...
hp-freund

Autor: dago (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weiss nicht genau, wie das bei Minix geht, aber du solltest mal gucken, 
dass die "nodeadkeys" Option an ist.
Im Linux wärs das Layout de-latin1-nodeadkeys.

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Alle Zeichen die am PC unter der ALT/GR Taste stecken sind unter
>VirtualPC unter CTRL+ALT, der Rest ist wie am PC.

für minix ist das tatsächlich die Lösung!
Danke hp-freund.

Seltsamerweise besteht das Problem noch freeBSD. Gut möglich,
dass es ein Konfig-problem seitens von BSD ist.

Gruss und Danke für eure Hilfe.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.